Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell PowerStore PowerStore T and Q Networking Guide for Storage Services

Configure the uplink ports on the Top-of-Rack (ToR) switches

  1. Establish a terminal connection to the first ToR switch (Switch1).
  2. Enter global configuration mode.
    configure terminal
  3. Configure the port channel for the uplinks.
    interface port-channel 50
    description Uplink
    no shutdown
    switchport mode trunk
    switchport access vlan 1
    vlt-port-channel 50
    mtu 9216
    exit
  4. Configure the uplink ports on the switch.
    NOTE:For iSCSI or NVMe/TCP best practices, it is recommended to disable flow control as demonstrated below.
    interface ethernet 1/1/29
    description Uplink_Ports
    no shutdown
    channel-group 50 mode active
    no switchport
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit 
    
    interface ethernet 1/1/30
    description Uplink_Ports
    no shutdown
    channel-group 50 mode active
    no switchport
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  5. Commit the configuration to the NVRAM.
    copy running-configuration startup-configuration
  6. Repeat steps 1 - 5 on the second ToR switch (Switch2).
    Table 1. Code sample for configuring ToR switch uplink portsCode sample for configuring ToR switch uplink ports
    Switch1 Switch2
    configure terminal
    
    interface port-channel 50
    description Uplink
    no shutdown
    switchport mode trunk
    switchport access vlan 1
    vlt-port-channel 50
    mtu 9216
    exit
     
    
    interface ethernet 1/1/29
    description Uplink_Ports
    no shutdown
    channel-group 50 mode active
    no switchport
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216 
    exit
    
    interface ethernet 1/1/30
    description Uplink_Ports
    no shutdown
    channel-group 50 mode active
    no switchport
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
    
    copy running-configuration startup-configuration
    configure terminal
    
    interface port-channel 50
    description Uplink
    no shutdown
    switchport mode trunk
    switchport access vlan 1
    vlt-port-channel 50
    mtu 9216
    exit
     
    
    interface ethernet 1/1/29
    description Uplink_Ports
    no shutdown
    channel-group 50 mode active
    no switchport
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216 
    exit
    
    interface ethernet 1/1/30
    description Uplink_Ports
    no shutdown
    channel-group 50 mode active
    no switchport
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
    
    copy running-configuration startup-configuration

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\