Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell PowerStore PowerStore T and Q Networking Guide for Storage Services

Configure NAS networks on the ToR switches

Configuring LACP is required for deployments with Network Attached Storage (NAS). Two ports are aggregated in an LACP bond. When LACP is configured, the ports run in an active/active mode. If LACP is not set, the ports run in active/passive mode.

Network Attached Storage is only supported with Unified deployments.

  1. Establish a terminal connection to the first ToR switch (Switch1).
  2. Enter global configuration mode.
    configure terminal
  3. Create the NAS VLAN.
    interface vlan 500
    description NAS_Network
    no shutdown
    exit
    
  4. Create the LACP port channel for Node A ports.
    interface port-channel 10
    description NodeA_NAS_LACP_port_channel
    vlt-port-channel 10
    switchport trunk allowed vlan 500
    switchport mode trunk
    spanning-tree port type edge
    mtu 9216
    exit
  5. Create LACP port channel for Node B ports.
    interface port-channel 20
    description NodeB_NAS_LACP_port_channel
    vlt-port-channel 20
    switchport trunk allowed vlan 500
    switchport mode trunk
    spanning-tree port type edge
    mtu 9216
    exit
  6. Move Node A facing port to the first port channel group, and enable active LACP mode.
    interface ethernet 1/1/8
    description NodeA_IO_0_port_3
    no shutdown
    channel-group 10 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  7. Move Node B facing port to the second port channel group, and enable active LACP mode.
    interface ethernet 1/1/47
    description NodeB_IO_1_port_3
    no shutdown
    channel-group 20 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  8. Configure NAS VLAN for Uplink.
    interface port-channel 50
    switchport trunk allowed vlan 500
    exit
  9. Commit configuration changes to nvram.
    copy running-configuration startup-configuration
  10. Repeat steps 1 - 9 on the second ToR switch (Switch2) as demonstrated below.
    NOTE:Be sure to use the correct Ethernet ports when configuring the second ToR switch (Switch2).
Table 1. Code sample for configuration NAS networks on the ToR switchesCode sample for configuration NAS networks on the ToR switches
Switch1 Switch2
configure terminal

interface vlan 500
description NAS_Network
no shutdown
exit

interface port-channel 10
description NodeA_NAS_LACP_port_channel
vlt-port-channel 10
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface port-channel 20
description NodeB_NAS_LACP_port_channel
vlt-port-channel 20
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface ethernet 1/1/8
no shutdown
description NodeA_IO_0_port_3
channel-group 10 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/47
no shutdown
description NodeB_IO_1_port_3
channel-group 20 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface port-channel 50
switchport trunk allowed vlan 500
exit

copy running-configuration startup-configuration
configure terminal

interface vlan 500
description NAS_Network
no shutdown
exit

interface port-channel 10
description NodeA_NAS_LACP_port_channel
vlt-port-channel 10
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface port-channel 20
description NodeB_NAS_LACP_port_channel
vlt-port-channel 20
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface ethernet 1/1/8
description NodeA_IO_1_port_3
no shutdown
channel-group 10 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/47
description NodeB_IO_0_port_3
no shutdown
channel-group 20 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface port-channel 50
switchport trunk allowed vlan 500
exit

copy running-configuration startup-configuration

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\