Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell PowerStore PowerStore T and Q Networking Guide for Storage Services

Configure Cluster network on the Top-of-Rack switches

Configuring LACP is not required, but highly recommended. The first two ports of the 4-Port Card are aggregated in an LACP bond. When LACP is configured the ports run in an active/active mode. When LACP is not set, the ports run in active/passive mode.

LACP requires that a Virtual Link Trunking interconnect (VLTi) has been configured on the switches. See Configure Virtual Link Trunking interconnect for details.

  1. Establish a terminal connection to the first ToR switch (Switch1).
  2. Enter global configuration mode.
    configure terminal
  3. Configure the Native VLAN 1 for the Cluster.
    interface vlan 1
    description Cluster_Network
    no shutdown
    exit
    
  4. Create the LACP port channel for Node A ports.
    interface port-channel 30
    description NodeA_Cluster_LACP_port_channel
    vlt-port-channel 30
    switchport mode trunk
    switchport access vlan 1
    spanning-tree port type edge
    mtu 9216
    exit
  5. Create LACP port channel for Node B ports.
    interface port-channel 40
    description NodeB_Cluster_LACP_port_channel
    vlt-port-channel 40
    switchport mode trunk
    switchport access vlan 1
    spanning-tree port type edge
    mtu 9216
    exit
  6. Move Node A facing port to the first port channel group, and enable active LACP mode.
    interface ethernet 1/1/1
    description NodeA_4port_port_0
    no shutdown
    channel-group 30 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  7. Move Node B facing port to the second port channel group, and enable active LACP mode.
    interface ethernet 1/1/54
    description NodeB_4port_port_1
    no shutdown
    channel-group 40 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  8. Configure Cluster VLAN for Uplink.
    interface port-channel 50
    switchport trunk allowed vlan 1
    exit
  9. Commit configuration changes to nvram.
    copy running-configuration startup-configuration
  10. Repeat steps 1 - 9 on the second ToR switch (Switch2).
Table 1. Code sample for configuration Cluster network on the ToR switchesCode sample for configuration Cluster network on the ToR switches
Switch1 Switch2
configure terminal

interface vlan 1
description Cluster_Network
no shutdown
exit

interface port-channel 30
description NodeA_Cluster_LACP_port_channel
vlt-port-channel 30
switchport mode trunk
switchport access vlan 1
spanning-tree port type edge
mtu 9216
exit

interface port-channel 40
description NodeB_Cluster_LACP_port_channel
vlt-port-channel 40
switchport mode trunk
switchport access vlan 1
spanning-tree port type edge
mtu 9216
exit

interface ethernet 1/1/1
description NodeA_4port_port_0
no shutdown
channel-group 30 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/54
description NodeB_4port_port_1
no shutdown
channel-group 40 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface port-channel 50
switchport access vlan 1
exit

copy running-configuration startup-configuration
configure terminal

interface vlan 1
description Cluster_Network
no shutdown
exit

interface port-channel 30
description NodeA_Cluster_LACP_port_channel
vlt-port-channel 30
switchport mode trunk
switchport access vlan 1
spanning-tree port type edge
mtu 9216
exit

interface port-channel 40
description NodeB_Cluster_LACP_port_channel
vlt-port-channel 40
switchport mode trunk
switchport access vlan 1
spanning-tree port type edge
mtu 9216
exit

interface ethernet 1/1/1
description NodeA_4port_port_1
no shutdown
channel-group 30 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/54
description NodeB_4port_port_0
no shutdown
channel-group 40 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface port-channel 50
switchport access vlan 1
exit

copy running-configuration startup-configuration

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\