Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell SmartFabric OS10 User Guide Release 10.5.3

PDF

Candidate configuration

When you use OS10 configuration commands in Transaction-based configuration mode, changes do not take effect immediately and are stored in the candidate configuration. The configuration changes become active only after you commit the changes using the commit command. Changes in the candidate configuration are validated and applied to the running configuration.

The candidate configuration allows you to avoid introducing errors during an OS10 configuration session. You can make changes and then check them before committing them to the active, running configuration on the switch.

To check differences between the running configuration and the candidate configuration, use the show diff candidate-configuration running-configuration command.

For example, before entering Transaction mode, you can check that no new configuration commands are entered. If the show command does not return output, the candidate-configuration and running-configuration files are the same. Then start Transaction mode, configure new settings, and view the differences between the candidate and running configurations. Decide if you want to commit the changes to the running configuration. To delete uncommitted changes, use the discard command.

View differences between candidate and running configurations
OS10# show diff candidate-configuration running-configuration
OS10#
OS10# start transaction
OS10# configure terminal
OS10(config)# interface vlan 100
OS10(conf-if-vl-100)# exit
OS10(config)# interface ethernet 1/1/15
OS10(conf-if-eth1/1/15)# switchport mode trunk
OS10(conf-if-eth1/1/15)# switchport trunk allowed vlan 100
OS10(conf-if-eth1/1/15)# end

OS10# show diff candidate-configuration running-configuration
!
interface ethernet1/1/15
switchport mode trunk
switchport trunk allowed vlan 100
!
interface vlan100
no shutdown
OS10#

Commit configuration changes in candidate configuration in Transaction mode

  1. Change to Transaction-based configuration mode from EXEC mode.
    start transaction
  2. Enter configuration commands. For example, enable an interface from INTERFACE mode.
    interface ethernet 1/1/1
    no shutdown
  3. Save the configuration changes to the running configuration.
    do commit
    After you enter the commit command, the current OS10 session switches back to the default behavior of committing all configuration changes automatically.
OS10# start transaction
OS10# configure terminal
OS10(config)#
OS10(config)# interface ethernet 1/1/1
OS10(config-if-eth1/1/1)# no shutdown
OS10(config-if-eth1/1/1)# do commit

Compressed configuration views

To display only interface-related configurations in the candidate configuration, use the show candidate-configuration compressed and show running-configuration compressed commands. These views display only the configuration commands for VLAN and physical interfaces.

OS10# show candidate-configuration compressed
interface breakout 1/1/1 map 40g-1x
interface breakout 1/1/2 map 40g-1x
interface breakout 1/1/3 map 40g-1x
interface breakout 1/1/4 map 40g-1x
...
interface breakout 1/1/30 map 40g-1x
interface breakout 1/1/31 map 40g-1x
interface breakout 1/1/32 map 40g-1x
ipv6 forwarding enable
username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH. role sysadmin
aaa authentication local
snmp-server contact http://www.dell.com/support
!
interface range ethernet 1/1/1-1/1/32
 switchport access vlan 1
 no shutdown
!
interface vlan 1
 no shutdown
!
interface mgmt1/1/1
 ip address dhcp
 no shutdown
 ipv6 enable
 ipv6 address autoconfig
!
support-assist
!
policy-map type application policy-iscsi
!
class-map type application class-iscsi
OS10# show running-configuration compressed
interface breakout 1/1/1 map 40g-1x
interface breakout 1/1/2 map 40g-1x
interface breakout 1/1/3 map 40g-1x
interface breakout 1/1/4 map 40g-1x
...
interface breakout 1/1/30 map 40g-1x
interface breakout 1/1/31 map 40g-1x
interface breakout 1/1/32 map 40g-1x
ipv6 forwarding enable
username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH. role sysadmin
aaa authentication local
snmp-server contact http://www.dell.com/support
!
interface range ethernet 1/1/1-1/1/32
 switchport access vlan 1
 no shutdown
!
interface vlan 1
 no shutdown
!
interface mgmt1/1/1
 ip address dhcp
 no shutdown
 ipv6 enable
 ipv6 address autoconfig
!
support-assist
!
policy-map type application policy-iscsi
!
class-map type application class-iscsi

Prevent configuration changes

You can prevent configuration changes that are made on the switch in sessions other than the current CLI session using the lock command. To prevent and allow configuration changes in other sessions, use the lock and unlock commands in EXEC mode.

When you enter the lock command, users in other active CLI sessions cannot make configuration changes. When you close the CLI session in which you entered the lock command, configuration changes are automatically allowed in all other sessions.

OS10# lock 
OS10# unlock 

Conflicting interface ranges

After you apply one or more VLANs to an interface using the switchport trunk allowed vlan command, and try to delete some of the VLANs from the candidate configuration, the system displays an error message. For example, the following is a configuration without conflicts:

OS10# start transaction
OS10# configure terminal
OS10(config)# interface range vlan 2-3
OS10(conf-range-vl-2-3)# exit
OS10(config)# interface range vlan 40-45
OS10(conf-range-vl-40-45)# exit
OS10(config)#
OS10(config)# interface range port-channel 2-3
OS10(conf-range-po-2-3)# switchport mode trunk
OS10(conf-range-po-2-3)# switchport trunk allowed vlan 2-3
OS10(conf-range-po-2-3)# switchport trunk allowed vlan 40-45
OS10(conf-range-po-2-3)# exit
OS10(config)# no interface range vlan 20-30
OS10(config)# do commit

The system already contains the following configuration:

OS10(config)# do show running-configuration interface port-channel
!
interface port-channel3
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 2-3,40-45
OS10(config)#
OS10(config)# do show running-configuration interface vlan
!
interface vlan1
no shutdown
!
interface vlan2
no shutdown
!
interface vlan3
no shutdown
!
interface vlan4
no shutdown
!
interface vlan5
no shutdown

The following depicts a conflicting configuration wherein a few VLANs are created and applied to an interface and then a subset of VLANs are removed from the candidate configuration:

OS10(config)# do start transaction
OS10(config)# interface range port-channel 3
OS10(conf-range-po-3)# switchport trunk allowed vlan 2-5
OS10(conf-range-po-3)# exit
OS10(config)# no interface range vlan 2-4
OS10(conf-range-po-3)# % Error:  Range configuration conflict - the last command was not applied. Please commit (or discard) the rest of the configuration changes and retry.

If you see the error message in bold, commit the entire configuration and then delete a sub set of VLANs.

OS10(conf-range-po-3)#do commit
OS10(conf-range-po-3)# do show running-configuration interface port-channel
!
interface port-channel3
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 2-5
OS10(conf-range-po-3)# do show running-configuration interface vlan
!
interface vlan1
no shutdown
!
interface vlan2
no shutdown
!
interface vlan3
no shutdown
!
interface vlan4
no shutdown
!
interface vlan5
no shutdown
OS10(conf-range-po-3)# no interface range vlan 2-4
OS10(config)# do show running-configuration interface vlan
!
interface vlan1
no shutdown
!
interface vlan5
no shutdown
OS10(config)# do show running-configuration interface port-channel
!
interface port-channel3
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 5
Sometimes, partial removal of VLANs may fail and display the following error message:
% Error:  The command failure resulted in disintegrated candidate configuration. Please discard the current candidate configuration changes.
If you see this error message, discard the entire configuration using the discard command.

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\