Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell SmartFabric OS10 User Guide Release 10.5.4

PDF

Use Case 3: DHCP Relay on VTEPs with DHCP Option-82 sub-options 5,11,151

The following example uses a Clos leaf-spine VXLAN with BGP EVPN topology to show how to set up DHCP relay on tenant VRFs with Option-82 sub-options 5,11,151 on the VTEPs.

  • Option 5 = Link selection sub-option

  • Option 11 = Server ID Override Sub-option
  • Option 151 = Virtual Subnet Selection

VLT implementation of source-interface CLI, link selection, and server-override and VSS suboptions in a VXLAN EVPN scenario

Leaf1 configuration:

1. Enable DHCP Option-82 suboptions - link-selection, server-override, vss:

OS10(config)# ip dhcp-relay link-selection 
OS10(config)# ip dhcp-relay server-override 
OS10(config)# ip dhcp-relay vss 

2.

Configure source interface (giaddr) to be used for DHCP relayed packets in each VRF. IP belonging to the loopback interface in underlay is given here as the server is reachable in the underlay network in default VRF. The response from the DHCP server comes to this IP in underlay default VRF.

OS10(config)# interface loopback1
OS10(conf-if-lo-1)# ip address 172.16.1.1/32
OS10(conf-if-lo-1)# exit
OS10(config)# ip vrf Yellow
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# ip vrf Green
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# 

3. Configure L3 virtual-network interface with VRF and IP address

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip vrf forwarding Yellow
OS10(conf-if-vn-10001)# ip address 10.1.0.1/24
OS10(conf-if-vn-10001)# ip virtual-router address 10.1.0.254
OS10(conf-if-vn-10001)# 
OS10(config)# interface virtual-network 20001
OS10(conf-if-vn-20001)# ip vrf forwarding Green
OS10(conf-if-vn-20001)# ip address 10.2.0.1/24
OS10(conf-if-vn-20001)# ip virtual-router address 10.2.0.254
OS10(conf-if-vn-20001)# 

4. Configure DHCP server address and VSS info. Virtual-network 10001 uses type 0 VSS format (ASCII VPN identifier) and Virtual-network 20001 uses type 1 VSS format (VPN ID). The DHCP server should be configured with these identifiers in the network pools.

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip dhcp-relay vss-info type 0 Yellow
OS10(conf-if-vn-10001)# ip helper-address 10.20.0.3 vrf Yellow
OS10(conf-if-vn-10001)# exit
OS10(config)# interface virtual-network 20001
OS10(conf-if-vn-20001)# ip dhcp-relay vss-info type 1 222:2222
OS10(conf-if-vn-20001)# ip helper-address 10.20.0.3 vrf Green
OS10(conf-if-vn-10001)# exit

Leaf2 configuration:

1. Enable DHCP Option-82 suboptions - link-selection, server-override, vss

OS10(config)# ip dhcp-relay link-selection 
OS10(config)# ip dhcp-relay server-override 
OS10(config)# ip dhcp-relay vss

2. Configure source interface (giaddr) to be used for DHCP relayed packets in each VRF. IP belonging to the loopback interface in underlay is given here as the server is reachable in the underlay network in default VRF.

OS10(config)# interface loopback1
OS10(conf-if-lo-1)# ip address 172.16.1.2/32
OS10(conf-if-lo-1)# exit
OS10(config)# ip vrf Yellow
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# ip vrf Green
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# 

3. Configure L3 virtual-network interface with VRF and IP address

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip vrf forwarding Yellow
OS10(conf-if-vn-10001)# ip address 10.1.0.2/24
OS10(conf-if-vn-10001)# ip virtual-router address 10.1.0.254
OS10(conf-if-vn-10001)# 
OS10(config)# interface virtual-network 20001
OS10(conf-if-vn-20001)# ip vrf forwarding Green
OS10(conf-if-vn-20001)# ip address 10.2.0.2/24
OS10(conf-if-vn-20001)# ip virtual-router address 10.2.0.254
OS10(conf-if-vn-20001)#

4. Configure DHCP server address and VSS info. Virtual-network 10001 uses type 0 VSS format (ASCII VPN identifier) and Virtual-network 20001 uses type 1 VSS format (VPN ID). The DHCP server should be configured with these identifiers in the network pools.

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip dhcp-relay vss-info type 0 Yellow
OS10(conf-if-vn-10001)# ip helper-address 10.20.0.3 vrf Yellow
OS10(conf-if-vn-10001)# exit
OS10(config)# interface virtual-network 20001
OS10(conf-if-vn-20001)# ip dhcp-relay vss-info type 1 222:2222
OS10(conf-if-vn-20001)# ip helper-address 10.20.0.3 vrf Green
OS10(conf-if-vn-10001)# exit

Leaf3 configuration:

1. Enable DHCP Option-82 suboptions - link-selection, server-override, vss:

OS10(config)# ip dhcp-relay link-selection 
OS10(config)# ip dhcp-relay server-override 
OS10(config)# ip dhcp-relay vss

2. Configure source interface (giaddr) to be used for DHCP relayed packets in each VRF. IP belonging to the loopback interface in underlay is given here as the server is reachable in the underlay network in default VRF.

The response from the DHCP server comes to this IP in underlay default VRF.

OS10(config)# interface loopback1
OS10(conf-if-lo-1)# ip address 172.16.1.3/32
OS10(conf-if-lo-1)# exit
OS10(config)# ip vrf Yellow
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# ip vrf Green
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# ip vrf Red
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# 

3. Configure L3 virtual-network interface with VRF and IP address

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip vrf forwarding Yellow
OS10(conf-if-vn-10001)# ip address 10.1.0.3/24
OS10(conf-if-vn-10001)# ip virtual-router address 10.1.0.254
OS10(conf-if-vn-10001)# 
OS10(config)# interface virtual-network 30001
OS10(conf-if-vn-30001)# ip vrf forwarding Red
OS10(conf-if-vn-30001)# ip address 10.3.0.1/24
OS10(conf-if-vn-30001)# ip virtual-router address 10.3.0.254
OS10(conf-if-vn-30001)# 

4. Configure DHCP server address and VSS info. Virtual-network 10001 and 30001 uses type 0 VSS format (ASCII VPN identifier). The DHCP server should be configured with these identifiers in the network pools.

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip dhcp-relay vss-info type 0 Yellow
OS10(conf-if-vn-10001)# exit
OS10(config)# interface virtual-network 30001
OS10(conf-if-vn-30001)# ip dhcp-relay vss-info type 0 Red
OS10(conf-if-vn-30001)# exit
OS10(config)# 

5. Configure route leaking and leak the DHCP Server route to the VRFs Yellow, Green and Red.

OS10(config)# ip prefix-list PrefixList_DHCPServer permit 10.20.0.0/24
OS10(config)# 
OS10(config)# route-map RouteMap_DHCPServer
OS10(config-route-map)# match ip address prefix-list PrefixList_DHCPServer
OS10(config-route-map)# exit
OS10(config)# 

OS10(config)# ip vrf default
OS10(conf-vrf)# ip route-export 0:0 route-map RouteMap_DHCPServer
OS10(conf-vrf)# exit
OS10(config)# ip vrf Yellow
OS10(conf-vrf)# ip route-import 0:0
OS10(conf-vrf)# exit
OS10(config)# ip vrf Green
OS10(conf-vrf)# ip route-import 0:0
OS10(conf-vrf)# exit
OS10(config)# ip vrf Red
OS10(conf-vrf)# ip route-import 0:0
OS10(conf-vrf)# exit
OS10(config)#
NOTE: If Border Leaf switch is already advertising a default route in each VRF to other VTEPs, there is no need to advertise this DHCP server route to other VTEPs. Otherwise, this leaked route could be advertised to other VTEPs using "advertise ipv4 connected" command under EVPN for each VRF.

Leaf4 configuration:

1. Enable DHCP Option-82 suboptions - link-selection, server-override, vss:

OS10(config)# ip dhcp-relay link-selection 
OS10(config)# ip dhcp-relay server-override 
OS10(config)# ip dhcp-relay vss 

2. Configure source interface (giaddr) to be used for DHCP relayed packets in each VRF. IP belonging to the loopback interface in underlay is given here as the server is reachable in the underlay network in default VRF.

The response from the DHCP server comes to this IP in underlay default VRF.

OS10(config)# interface loopback1
OS10(conf-if-lo-1)# ip address 172.16.1.4/32
OS10(conf-if-lo-1)# exit
OS10(config)# ip vrf Yellow
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# ip vrf Green
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# ip vrf Red
OS10(conf-vrf)# ip dhcp-relay source-interface loopback 1
OS10(conf-vrf)# exit
OS10(config)# 

3. Configure L3 virtual-network interface with VRF and IP address

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip vrf forwarding Yellow
OS10(conf-if-vn-10001)# ip address 10.1.0.4/24
OS10(conf-if-vn-10001)# ip virtual-router address 10.1.0.254
OS10(conf-if-vn-10001)# 
OS10(config)# interface virtual-network 30001
OS10(conf-if-vn-30001)# ip vrf forwarding Red
OS10(conf-if-vn-30001)# ip address 10.3.0.2/24
OS10(conf-if-vn-30001)# ip virtual-router address 10.3.0.254
OS10(conf-if-vn-30001)# 

4. Configure DHCP server address and VSS info. Virtual-network 10001 and 30001 uses type 0 VSS format (ASCII VPN identifier). The DHCP server should be configured with these identifiers in the network pools.

OS10(config)# interface virtual-network 10001
OS10(conf-if-vn-10001)# ip dhcp-relay vss-info type 0 Yellow
OS10(conf-if-vn-10001)# exit
OS10(config)# interface virtual-network 30001
OS10(conf-if-vn-30001)# ip dhcp-relay vss-info type 0 Red
OS10(conf-if-vn-30001)# exit
OS10(config)# 

5. Configure route leaking and leak the DHCP Server route to the VRFs Yellow, Green and Red.

OS10(config)# ip prefix-list PrefixList_DHCPServer permit 10.20.0.0/24
OS10(config)# 
OS10(config)# route-map RouteMap_DHCPServer
OS10(config-route-map)# match ip address prefix-list PrefixList_DHCPServer
OS10(config-route-map)# exit
OS10(config)# 

OS10(config)# ip vrf default
OS10(conf-vrf)# ip route-export 0:0 route-map RouteMap_DHCPServer
OS10(conf-vrf)# exit
OS10(config)# ip vrf Yellow
OS10(conf-vrf)# ip route-import 0:0
OS10(conf-vrf)# exit
OS10(config)# ip vrf Green
OS10(conf-vrf)# ip route-import 0:0
OS10(conf-vrf)# exit
OS10(config)# ip vrf Red
OS10(conf-vrf)# ip route-import 0:0
OS10(conf-vrf)# exit
OS10(config)# 
NOTE: If Border Leaf switch is already advertising a default route in each VRF to other VTEPs, there is no need to advertise this DHCP server route to other VTEPs. Otherwise, this leaked route could be advertised to other VTEPs using "advertise ipv4 connected" command under EVPN for each VRF.

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\