Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Dell PowerFlex Rack with PowerFlex 3.x Administration Guide

PDF

Configuring border-leaf switches

Use this task to configure border leaf switches.

Prerequisites

NOTE:Perform this procedure only if you are configuring a leaf-spine network design.

Steps

  1. From the Cisco NX-OS switch CLI, type the following for global configurations:
    VLAN <VLAN ID>
    system jumbomtu 9216
    feature nxapi
    feature ospf
    feature bgp
    feature lldp
    feature udld
    feature interface-VLAN
    feature vn-segment-VLAN-based
    feature hsrp
    feature lacp
    feature vpc
    feature fabric forwarding
    feature nv overlay
    nv overlay evpn
  2. Type the following for the interface configuration for border-leaf to spine switch:
    interface Ethernet<slot>/<port>
    mtu 9216
    medium p2p
    ip unnumbered loopback<loopback-number>
    no ip redirects
    link debounce 500
    no shutdown
    
    interface loopback <loopback number>
    ip address <ip address><subnetmask>
    ip address <ip address><subnetmask>secondary
    
  3. Type the following to configure interface configuration for L3 handoff VRF Lite:
    interface Ethernet<slot>/<port>
    no switchport
    no shutdown
    
    interface Ethernet<slot>/<port>
    vrf member VxFLEX_Management_VRF
    encapsulation dot 1q <vlan id> 
    ip address <ip address>/<subnetmask>
    ip address <ip address><subnetmask>secondary----(Repeat this line for each subnet enabled within VLAN, only if multi-subnet is enabled for any network-type)
    no shutdown
    
    interface Ethernet<slot>/<port>
    vrf member Customer_Production_VRF
    encapsulation dot 1q <vlan id> 
    ip address <ip address>/<subnetmask>
    ip address <ip address><subnetmask>secondary----(Repeat this line for each subnet enabled within VLAN, only if multi-subnet is enabled for any network-type)
    no shutdown
  4. Type the following to configure interface for L2 handoff vpc:
    vpc domain <domain id>
    peer-switch
    peer-keepalive destination <destination ip address> source <source ip address>
    peer-gateway
    
    interface Ethernet<slot>/<port>
    switchport
    switchport mode trunk
    spanning-tree port type network
    switchport trunk allowed VLAN add <vlan id>----(add multi-VLAN numbers if multi-VLAN is used)
    channel-group <channel group number>
    no shutdown
    
    interface port-channel<port channel number>
    vpc peer-link
    
    interface port-channel <port channel number>
    switchport mode trunk
    switchport trunk allowed VLAN add <vlan id>----(add multi-VLAN numbers if multi-VLAN is used)
    vpc <vpc number>
    
  5. Type the following to configure the distributed gateway for L2 handoff:
    interface VLAN<vlan id>
    no shutdown
    vrf member <VRF Name>
    ip address <ip address><subnetmask>
    ip address <ip address><subnetmask>secondary----(Repeat this line for each subnet enabled within VLAN, only if multi-subnet is enabled for any network-type)
    fabric forwarding mode anycast-gateway
    
    interface VLAN<vlan id>
    no shutdown
    vrf member Customer_Production_VRF
    ip address <ip address><subnetmask>
    p address <ip address><subnetmask>secondary----(Repeat this line for each subnet enabled within VLAN, only if multi-subnet is enabled for any network-type)
    fabric forwarding mode anycast-gateway
    
    interface VLAN<vlan id>---(Repeat this section for all multi-VLAN numbers that are configured on all the TOR pairs where controller nodes are connected)
    no shutdown
    vrf member VxFLEX_Management_VRF
    ip forward
    
    interface VLAN<vlan id>---(Repeat this section for all multi-VLAN numbers that are configured on all the TOR pairs where controller nodes are connected)
    no shutdown
    vrf member Customer_Production_VRF
    ip forward
    
  6. Type the following to configure the OSPF underlay:
    router ospf <process id>  
    router-id <router-id>
    bfd
    interface Ethernet<slot>/<port>	
    ip ospf network point-to-point
    ip router ospf <process id >  area <area id>
    no shutdown	
    
    int lo <loopback number>
    ip ospf network point-to-point
    ip router ospf <process id >  area <area id>			
    no shutdown
    
  7. Type the following to configure the BGP:
    ip prefix-list no-hosts-route seq 5 deny 0.0.0.0/0 eq 32            # for L3 handoff
    ip prefix-list no-hosts-route seq 10 permit 0.0.0.0/0 le 32       # for L3 handoff 
    
    router bgp <as-number>
    router-id <router-id>
    
    address-family ipv4 unicast
    address-family l2vpn evpn 
    address-family vpnv4 unicast
    
    neighbor <neighbor-ip address>
    bfd  
    remote-as <neighbor-as-number>
    update-source loopback <loopback-number>
    address-family ipv4 unicast
    send-community
    
    send-community extended
    address-family l2vpn evpn
    send-community
    send-community extended
    vrf <VRF Name>
    address-family ipv4 unicast
    advertise l2vpn evpn
    neighbor <neighbor ip address>
    remote-as <as number>
    address-family ipv4 unicast
    prefix-list no-hosts-route out
    
    vrf Customer_Production_VRF
    address-family ipv4 unicast
    advertise l2vpn evpn
    neighbor <neighbor ip address>
    remote-as <as-number>
    address-family ipv4 unicast
    prefix-list no-hosts-route out
  8. Type the following to configure the VxLAN:
    VLAN <vlan ID>---(Repeat this section for all multi-VLAN numbers that are configured on all the TOR pairs where controller nodes are connected)
    name <vlan name>
    vn-segment <vn-segment ID>
    
  9. Type the following to configure the network virtualization endpoint (NVE) interface:
    interface nve <nve-interface> 				
    no shutdown
    
    source-interfce loopback<loopbacknumber>		
    host-reachability protocol bgp
    member vni <vni number>---(Repeat this section for all multi-VLAN numbers that are configured on all the TOR pairs where controller nodes are connected)
    suppress ARP
    ingress-replication protocol bgp 
    member vni <vni number> associate-vrf
  10. Type the following to configure the MP-BGP EVPN VTEP:
    route-map <map-name> <sequence number>
    router bgp <as-number>
    address-family l2vpn evpn
    neighbor <neighbor-ip address>
    bfd 
    remote-as <neighbor-as-number>
    update-source loopback<loopback-number>
    address-family l2vpn evpn
    send-community extended
    
    vrf  <VRF name>
    address-family ipv4 unicast
    advertise l2vpn evpn
    neighbor <neighbor-ip address> 
    remote-as <neighbor as-number>
    address-family ipv4 unicast
    Prefix-list no-host-route out
    
    vrf Customer_Production_VRF
    address-family ipv4 unicast
    advertise l2vpn evpn
    neighbor <neighbor-ip address> 
    remote-as <as-number>
    address-family ipv4 unicast
    prefix-list no-host-route out
  11. Type the following to configure the EVPN layer-2 networks:
    evpn
    VNI <vni number>
    rd auto
    route-target import auto
    route-target export auto
    
    ! Create EVPN VxFLEX_Management_VRF
     
    vrf <VRF name>
    vni <vni-number>
    rd auto
    address-family ipv4 unicast
    route-target both auto evpn.
    
    Import all SDC VRF to SDS VRF, SDS VRF into Individual VRF.
    
    vrf context <VRF_Name>
    vni <vni-id>
    rd auto
    address-family ipv4 unicast
    route-target both auto evpn
    	route-target import <RT>
    route-target import <RT> evpn
    route-target export <RT>
    route-target export <RT> evpn
    
  12. To enable NXAPI, type:
    switch#conf t
    switch(config)# feature nxapi
    switch(config)#nxapi http port 80

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\