Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC Configuration Guide for the S3100 Series 9.14.2.4

PDF

Sample VRF Configuration

The following configuration illustrates a typical VRF set-up.
Figure 1. Setup OSPF and Static Routes
Setup OSPF and Static Routes
Figure 2. Setup VRF Interfaces
Setup VRF Interfaces

The following example relates to the configuration shown in the above illustrations.

Router 1

ip vrf blue 1 
! 
ip vrf orange 2 
! 
ip vrf green 3 
! 
interface GigabitEthernet 3/1 
	no ip address 
	switchport 
	no shutdown 
! 
interface GigabitEthernet 1/1 
	ip vrf forwarding blue 
	ip address 10.0.0.1/24 
	no shutdown 
! 
interface GigabitEthernet 1/2 
	ip vrf forwarding orange 
	ip address 20.0.0.1/24 
	no shutdown 
! 
interface GigabitEthernet 1/3 
	ip vrf forwarding green 
	ip address 30.0.0.1/24 
	no shutdown 
! 
interface Vlan 128 
	ip vrf forwarding blue 
	ip address 1.0.0.1/24 
	tagged GigabitEthernet 3/1 
	no shutdown 
! 
interface Vlan 192 
	ip vrf forwarding orange 
	ip address 2.0.0.1/24 
	tagged GigabitEthernet 3/1 
	no shutdown 
! 
interface Vlan 256 
	ip vrf forwarding green 
	ip address 3.0.0.1/24 
	tagged GigabitEthernet 3/1 
	no shutdown 
!
router ospf 1 vrf blue
	router-id 1.0.0.1
	network 1.0.0.0/24 area 0
	network 10.0.0.0/24 area 0
!
router ospf 2 vrf orange
	router-id 2.0.0.1
	network 2.0.0.0/24 area 0
	network 20.0.0.0/24 area 0
!
ip route vrf green 31.0.0.0/24 3.0.0.2!

Router 2

ip vrf blue 1
!
ip vrf orange 2
!
ip vrf green 3
!
interface GigabitEthernet 3/1
	no ip address
	switchport
	no shutdown
!
interface GigabitEthernet 2/1
	ip vrf forwarding blue
	ip address 11.0.0.1/24
	no shutdown
!
interface GigabitEthernet 2/2
	ip vrf forwarding orange
	ip address 21.0.0.1/24
	no shutdown
!
interface GigabitEthernet 2/3
	ip vrf forwarding green
	ip address 31.0.0.1/24
	no shutdown
!
interface Vlan 128
	ip vrf forwarding blue
	ip address 1.0.0.2/24
	tagged GigabitEthernet 3/1
no shutdown
interface Vlan 192
	ip vrf forwarding orange
	ip address 2.0.0.2/24
	tagged GigabitEthernet 3/1
	no shutdown
!
interface Vlan 256
	ip vrf forwarding green
	ip address 3.0.0.2/24
	tagged GigabitEthernet 3/1
	no shutdown
!
router ospf 1 vrf blue
	router-id 1.0.0.2
	network 11.0.0.0/24 area 0
	network 1.0.0.0/24 area 0
	passive-interface GigabitEthernet 2/1
!
router ospf 2 vrf orange
	router-id 2.0.0.2
	network 21.0.0.0/24 area 0
	network 2.0.0.0/24 area 0
	passive-interface GigabitEthernet 2/2
!
ip route vrf green30.0.0.0/24 3.0.0.1
!

The following shows the output of the show commands on Router 1.

Router 1

DellEMC#show ip vrf
VRF-Name                         VRF-ID Interfaces
 
default-vrf                      0       Gi 3/1-3/3,
                                         Gi 1/3-1/47,
                                         Gi 2/1-2/47,
                                         Ma 1/1,
                                         Ma 2/1,
                                         Nu 0,
                                         Vl 1
blue                             1       Gi 1/1,
                                         Vl 128
orange                           2       Gi 1/2,
                                         Vl 192
green                            3       Gi 1/3,
                                         Vl 256
DellEMC#show ip ospf 1 neighbor
Neighbor ID 	Pri 	State 		Dead Time Address Interface Area
1.0.0.2 		 1 	FULL/DR 	00:00:32 1.0.0.2 		Vl 128 		0

DellEMC#sh ip ospf 2 neighbor
Neighbor ID  Pri 	State 		Dead Time Address Interface Area
2.0.0.2 		 1 	FULL/DR 	00:00:37 2.0.0.2 		Vl 192 		0
DellEMC#show ip route vrf blue

Codes: C - connected, S - static, R - RIP,
			B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
			O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
			N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
			E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
			L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
			> - non-active route, + - summary route

Gateway of last resort is not set

		Destination 		Gateway 				Dist/Metric 		Last Change
		-----------		------- 				----------- 		-----------
C 		1.0.0.0/24 		Direct, Vl 128 	0/0 					00:20:48
C 		10.0.0.0/24 		Direct, Gi 1/1 	0/0 					00:10:06
O 		11.0.0.0/24 		via 1.0.0.2, 		Vl 128 110/2 	00:11:13

DellEMC#show ip route vrf orange

Codes: C - connected, S - static, R - RIP,
			B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
			O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
			N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
			E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
			L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
			> - non-active route, + - summary route

Gateway of last resort is not set

		Destination 		Gateway 						Dist/Metric 		Last Change
		----------- 		------- 						----------- 		-----------
C 		2.0.0.0/24 		Direct, Vl 192 			0/0 					00:20:55
C 		20.0.0.0/24 		Direct, Gi 1/2 			0/0 					00:10:05
O 		21.0.0.0/24 		via 2.0.0.2,	Vl 192 		110/2				00:10:41

DellEMC#show ip route vrf green

Codes: C - connected, S - static, R - RIP,
			B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
			O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
			N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
			E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
			L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
			> - non-active route, + - summary route

Gateway of last resort is not set

		Destination 		Gateway 						Dist/Metric 		Last Change
		----------- 		------- 						----------- 		-----------
C 		3.0.0.0/24 		Direct, Vl 256 			0/0 					00:20:52
C 		30.0.0.0/24 		Direct, Gi 1/3 			0/0 					00:09:45
S 		31.0.0.0/24 		via 3.0.0.2, Vl 256 	1/0 					00:09:06
======================================================================================

The following shows the output of the show commands on Router 2.

Router 2

DellEMC#show ip vrf
VRF-Name 												VRF-ID 	Interfaces
default-vrf 											0 			Gi 3/0-3,
																		Gi 2/0-17,21-47,
																		Ma 0/0,
																		Ma 1/0,
																		Nu 0,
																		Vl 1
blue 													1 			Gi 2/1,
																		Vl 128
orange 													2 			Gi 2/2,
																		Vl 192
green 													3 			Gi 2/3,
																		Vl 256

DellEMC#show ip ospf 1 neighbor
Neighbor ID 		Pri 			State Dead Time 	Address 	Interface 	Area
1.0.0.1 1 		FULL/BDR 	00:00:36 				1.0.0.1 	Vl 128 			0
!
DellEMC#sh ip ospf 2 neighbor
Neighbor ID 		Pri 			State Dead Time 	Address 	Interface 	Area
2.0.0.1 1 		FULL/BDR 	00:00:33 				2.0.0.1 	Vl 192 			0
!
DellEMC#show ip route vrf blue

Codes: C - connected, S - static, R - RIP,
			B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
			O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
			N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
			E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
			L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
			> - non-active route, + - summary route

Gateway of last resort is not set
		Destination 		Gateway 						Dist/Metric 		Last Change
		----------- 		------- 						----------- 		-----------
C 		1.0.0.0/24 		Direct,	Vl 128 				0/0 					00:27:21
O 		10.0.0.0/24 		via 1.0.0.1,	Vl 128 		110/2 				00:14:24
C 		11.0.0.0/24 		Direct, Gi 2/1 			0/0 					00:19:46

DellEMC#show ip route vrf orange

Codes: C - connected, S - static, R - RIP,
			B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
			O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
			N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
			E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
			L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
			> - non-active route, + - summary route

Gateway of last resort is not set

		Destination 		Gateway 						Dist/Metric 		Last Change
		----------- 		------- 						----------- 		-----------
C 		2.0.0.0/24 		Direct, Vl 192 			0/0 					00:26:44
O 		20.0.0.0/24 		via 2.0.0.1, Vl 192 	110/2 				00:14:22
C 		21.0.0.0/24 		Direct, Gi 2/2 			0/0 					00:20:38

DellEMC#show ip route vrf green

Codes: C - connected, S - static, R - RIP,
			B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
			O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
			N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
			E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
			L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
			> - non-active route, + - summary route

Gateway of last resort is not set

		Destination 		Gateway 						Dist/Metric 		Last Change
		----------- 		------- 						----------- 		-----------
C 		3.0.0.0/24 		Direct, Vl 256 			0/0 					00:26:27
S 		30.0.0.0/24 		via 3.0.0.1, Vl 256 	1/0 					00:17:03
C 		31.0.0.0/24 		Direct, Gi 2/3 			0/0 					00:20:19
DellEMC#

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\