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Dell Encryption 移除代理程式無法解密 OneDrive 隨選檔案

摘要: 由於 Windows 處理隨選檔案的方式,Dell Encryption (先前稱為 Dell Data Protection |加密) 移除代理程式無法解密這些檔案。

本文可能採用自動翻譯。如果您對翻譯品質有任何寶貴意見,請使用此頁面底部的表單告訴我們,謝謝。

文章內容


症狀

受影響的產品:

  • Dell Encryption
  • Dell Data Protection | Encryption

受影響的版本

  • v11.0 及更早版本

受影響的作業系統

  • Windows 10

Dell Encryption 移除代理程式無法隨選解密檔案,且會在每次重新開機後卡在嘗試解密檔案的循環中。

加密移除代理程式狀態為無法解密所有檔案的狀態。

Dell Encryption 移除代理程式執行中

錯誤會記錄在檔案 \ProgramData\Dell\Dell Data Protection\Encryption\cmgdecryptagent.txt 中:

SDE Decrypt Service - DecryptSweep_CheckDecryptFile(): EncryptDecryptFile("C:\Users\\OneDrive - Default Directory\Test @ Default Directory.url") failed, win32Err = 1920 [DEVICE]

原因

不適用

解析度

此問題有兩種可能的解決方案,您可以選擇 停用 OneDrive 並允許解密代理程式完成 ,或者您可以 要求 CmgDecryptAgent v11.0.0. 以取代目前的版本。C舔下面兩種不同的解決方案。

解決此問題,Microsoft OneDrive 必須暫時停用:

  1. 開啟 工作管理員 ,然後前往 啟動 標籤。
  2. 找到 OneDrive Microsoft將其 右鍵按一下 ,然後 停用 該服務。
    停用 OneDrive Microsoft
  3. 刪除 受影響的 OneDrive On-Demand 檔案。
  4. 重新啟動

重新啟動端點後,Dell Encryption 移除代理程式會嘗試解密先前的隨選檔案。解密掃掠成功完成後,Dell Encryption 移除代理程式會在下次重新開機時移除。

Dell Encryption 移除代理程式停用

Microsoft 現在可重新啟用 OneDrive,且應重新加入隨選檔案。

向支援部門索取CmgDecryptAgent.exe (v11.0.0.12)。請參閱以下文章以聯絡支援:

Dell Data Security 國際支援電話號碼

注意:

收到新CmgDecryptAgent.exe後,請在受影響的機器上執行下列步驟:

  1. 停止 Dell Encryption 移除代理程式 服務。
  2. 將現有的CmgDecryptAgent.exe (C:\Program Files\DELL\Dell Data Protection\Encryption) 重新命名為 CmgDecryptAgent_old.exe。
  3. 將新CmgDecryptAgent.exe移至 C:\Program Files\DELL\Dell Data Protection\Encryption
  4. 重新啟動 Dell Encryption 移除代理程式 服務。
  5. 允許 CmgDecryptAgent 掃掠執行並檢查:C:\ProgramData\Dell\Dell Data Protection\Encryption\CmgDecryptAgent.log ,用於驗證 OneDrive 檔案是否正在解密。
注意:如果機器上有多個使用者具有 OneDrive 檔案,則每個使用者都必須登入機器,才能提供對其特定 OneDrive 檔案的存取權限,以便由 CmgDecryptAgent 解密。

如要聯絡支援部門,請參閱 Dell Data Security 國際支援電話號碼
請前往 TechDirect,以線上產生技術支援要求。
如需更多深入見解與資源,請加入 Dell 安全性社群論壇

文章屬性


受影響的產品

Dell Encryption

上次發佈日期

02 7月 2024

版本

15

文章類型

Solution