跳至主要內容
  • 簡單快速地下訂單
  • 檢視訂單及追蹤商品運送狀態
  • 建立並存取您的產品清單

Dell Unity: SP Panic after Being Up for More than 240 Days

摘要: Dell Unity XT 480, 680, or 880 Storage Processor (SP) may panic after being up for more than 240 days. (Dell Correctable)

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Dell Unity XT 480, 680, or 880 SP may panic after being up for 240 days.

原因

An SP panic may occur due to an integer overflow calculation leading to a 64-bit result being stored in a 32-bit variable. 

The issue is most likely to occur on a Unity XT 480, 680, or 880 array running Unity OE versions 5.1.0.0.5.394 through 5.2.2.0.5.004. This is due to changes within that code and the SP hardware used in those models. Older codes and Unity models are less likely to see this issue. 
 
NOTE: The average number of days before an SP restart is 275-300 days. The SP restart can occur before 275 days. Storage Processor restarts do not occur prior to 240 days.

解析度

Fix:
The fix is available in Unity OE version 5.3.0.0.5.120 and later.

Workaround:
Proactively reboot the SP every 240 days to avoid an SP panic. Instructions to reboot an SP are available in the article: Unity: How to Reboot a Storage Processor (User Correctable).

Customers can issue an "uptime" command by connecting to an array using SSH and using the service account to get the SP runtime.

The example below shows uptime is 31 days.
04:30:01 service@xxx spa:~/user# uptime
04:30am  up 31 days  3:41,  2 users,  load average: 29.21, 29.45, 29.51

受影響的產品

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
文章屬性
文章編號: 000200921
文章類型: Solution
上次修改時間: 25 9月 2024
版本:  19
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。