跳至主要內容
  • 簡單快速地下訂單
  • 檢視訂單及追蹤商品運送狀態
  • 建立並存取您的產品清單

PowerStore: Служби часу не синхронізуються зі службою NTP Windows Server, якщо дисперсія кореневого каталогу перевищує 5 секунд

摘要: PowerStore не синхронізується із сервером NTP з дисперсією кореневого каталогу більше 5 секунд. Windows NTP Server без дійсного джерела NTP за замовчуванням має кореневу дисперсію, починаючи з 10 секунд. Отже, сервер Windows NTP розглядається як недійсний та ігнорується. ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Подібна помилка може спостерігатися під час роботи майстра початкового настроювання (ICW):
Issue: The time between vCenter and PowerStore has diverged for 27 seconds. (0xE0E700200002)
Resolution: Synchronize the time between your vCenter server and PowerStore.
Або оповіщення з кодами помилок 0x01806d02, 0x01806d03 або 0x01806c02 може з'явитися після додавання NTP-сервера
Alert id       : [...]
Error Code     : 0x01806d02
Severity       : Minor
Timestamp (UTC): 2022-07-01 13:40:35+00
Appliance Name : PowerStore-1
Resource Type  : node
Resource Name  : PowerStore-1-node-B
Description    : Time difference between the node and the following NTP servers exceeds system requirements: ntp.domain.local - 5.89 sec., ntp01.domain.local - 5.89 sec..


Виконання таких дій на сервері Windows, на якому запущено служби NTP, показує дисперсію кореневого компонування, більшу за 10:
w32tm /query /status
C:\Users\example> w32tm /query /status
Leap Indicator: 0(no warning)
Stratum: 4 (secondary reference - syncd by (S)NTP)
Precision: -23 (119.209ns per tick)
Root Delay: 0.1015253s
Root Dispersion: 10.7922013s
ReferenceId: 0x0A181B1B (source IP:  xx.xx.xx.xx)
Last Successful Sync Time: 30/03/2022 07:48:15
Source: xx.xx.xx.xx
Poll Interval: 6 (64s)

Тут перераховані всі NTP-сервери, які необхідно дослідити:
w32tm /query /peers
C:\Users\example> w32tm /query /peers
#Peers: 1

Peer: xx.xx.xx.xx
State: Active
Time Remaining: 52.0325146s
Mode: 1 (Symmetric Active)
Stratum: 3 (secondary reference - syncd by (S)NTP)
PeerPoll Interval: 6 (64s)
HostPoll Interval: 6 (64s)

原因

  1. Сервери Windows NTP не настроєно на використання дійсного зовнішнього джерела годинника (наприклад, атомного, GNSS або радіогодинника), або
  2. Сервери Windows NTP не мають дійсного основного або надійного зовнішнього джерела NTP, або
  3. Запити основної гілки блокуються брандмауером.

解析度

1) Відкрийте порт 123 (UDP) у брандмауері, щоб дозволити Windows NTP зв'язуватися з time.windows.com або з дійсним зовнішнім джерелом NTP.


2) Крім того, після впровадження правила брандмауера налаштуйте інший дійсний сервер часу, замінивши "ntp_server" нижче на дійсне ім'я хоста:
w32tm /config /manualpeerlist:"ntp_server" /syncfromflags:manual /reliable:yes /update


3) Якщо дійсне джерело годинника (кварцовий / атомний годинник / годинник GPS) не може бути підключено до вашого сервера NTP, або дійсний сервер NTP не може бути налаштований або порти не можуть бути відкриті, ви можете розглянути можливість зміни цих значень реєстру:
HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Config
LocalClockDispersion = 1
AnnounceFlags = 0x05
ПРИМІТКА: реалізуючи примусову LocalClockDispersion, ви приймаєте наслідки потенційно ненадійного джерела часу для ваших внутрішніх пристроїв. Рекомендація полягає в тому, щоб замість цього приєднати атомні, GNSS або радіогодинникові пристрої до вашого сервера з найнижчим рівнем 1 в межах повністю ізольованого домену.

4) Якщо служби часу Windows працюють як віртуальна машина, переконайтеся, що інструменти Hyper-V або VMware також не встановлюють час, щоб існувало лише одне надійне джерело годинника.

Посилання:

Вимкнути синхронізацію часу в ESXi (див. https://kb.vmware.com/s/article/1189):У Hyper-V:5) Перезапустіть і повторно синхронізуйте служби часу Windows:

зображення.png

зображення.png


net stop w32time
net start w32time
w32tm /resync /rediscover
 

其他資訊

受影響的產品

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T

產品

PowerStore
文章屬性
文章編號: 000197889
文章類型: Solution
上次修改時間: 14 12月 2022
版本:  9
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。