Preskočiť na hlavný obsah
  • Zadávajte objednávky rýchlo a jednoducho
  • Pozrite si svoje objednávky a sledujte priebeh doručenia
  • Vytvorte si zoznam svojich produktov a majte ho vždy poruke

适用于 Windows 用户的打印机后台处理程序错误故障排除和解决方案

Zhrnutie: 了解如何解决 Windows 中的打印后台处理程序错误。了解如何停止并启动打印后台处理程序,并使用这些分步指南对打印机问题进行故障排除。

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

存在打印后台处理程序错误。发送到打印机的文档不会打印,并且卡在打印机后台处理程序中。

受影响的操作系统:

  • Windows 11
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7

Príčina

打印后台处理程序出现问题可能会导致一些打印和通信问题。有时,重新启动或清除打印后台处理程序可能会解决这些问题。打印后台处理程序可使您的 Windows 计算机与打印机交互,并在队列中对打印作业进行排序。

Riešenie

目录:

  1. 如何手动停止和启动打印后台处理程序
  2. 如何从 Spool 文件夹中手动删除文件
  3. 如何从注册表中手动删除打印机
  4. 如何解决打印机假脱机程序错误

如何手动停止和启动打印后台处理程序

  1. 单击 开始 按钮,然后选择 运行 。键入 command图 1),然后单击 OK 以显示命令提示符(图 2)。

    在运行窗口中键入命令

    图 1:打字 command 在“运行”窗口中


    命令提示符

    图 2:命令提示符

  2. 在命令提示符下,键入 net stop spooler 然后按 Enter 键以停止 打印后台处理程序。
  3. 在命令提示符下,键入 net start spooler 然后按 Enter 键以启动 打印后台处理程序。

如何从 Spool 文件夹中手动删除文件

如果您的作业卡在无法删除的打印队列中,则可能需要手动删除它们。

  1. 停止 打印后台处理程序。
提醒:有关如何停止打印机后台处理程序的更多信息,请参阅本文的 How to Manually Stop and Start the Print Spooler (如何手动停止和启动打印后台处理程序 )部分。
  1. 浏览至 C: 驱动器并将其打开。
  2. 浏览至 WINDOWS 然后将其打开。
  3. 浏览至 SYSTEM32 然后将其打开。
  4. 浏览至 SPOOL 然后选择它。
  5. 浏览至 PRINTERS
  6. 删除 位于此文件夹中的所有文件。例如,它们可能显示为 FP00008 或者 FP00008.SHD
  7. 启动 打印后台处理程序。
提醒:有关如何启动打印机后台处理程序的更多信息,请参阅本文的 How to Manually Stop and Start the Print Spooler (如何手动停止和启动打印后台处理程序 )部分。

如何从注册表中手动删除打印机

也可以从计算机的注册表中删除打印机。如果无法删除或移除打印机,并且重新启动打印后台处理程序未清除此问题,请从注册表中手动删除打印机。

警告:从注册表中更改或删除文件可能会导致操作系统出现问题,例如无法引导至 Windows。请勿修改注册表,除非您愿意这样做。如果注册表损坏,您可能必须重新安装 Windows 操作系统。
  1. 单击 开始 按钮,然后单击 运行 。键入 command 然后单击 OK 以显示命令提示符。
  2. 键入 regedit 然后按 Enter。这将显示注册表编辑器(图 3)。

    Registry Editor

    图 3:Registry Editor

  3. 在 注册表编辑器 中,展开 计算机
  4. 展开 HKEY_CURRENT_USER 文件夹(图 4)。

    HKEY_CURRENT_USER 文件夹

    图 4:HKEY_CURRENT_USER 文件夹

  5. 展开 Printers 文件夹。
  6. 双击 Connections 文件夹(图 5)

    Connections 文件夹

    图 5:Connections 文件夹

  7. 仅删除打印机队列和打印机(图6)。请勿删除任何其他内容。

    打印机队列和打印机

    图 6:打印机队列和打印机


如何解决打印机假脱机程序错误

Windows 11 和 Windows 10

  1. 键入 troubleshooting 在 Windows 搜索 框中。
  2. 单击 Troubleshooting Settings (控制面板)
  3. 单击 Hardware and Sound (硬件和声音)下的 Use a printer (使用打印机)。
  4. 单击高级
  5. 单击 以管理员身份运行 。询问时,输入您的凭据或取消凭据(如果您不知道这些凭据)。
  6. 单击Next(下一步)并按照提示进行操作。
提醒:如果问题仍然存在,则您必须卸载打印机驱动程序,并为您的打印机重新安装最新的打印机驱动程序。有关戴尔打印机的更多信息,请参阅戴尔知识库文章 Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware (戴尔打印机卸载、下载和安装打印机驱动程序、软件、手册和固件)。对于非戴尔品牌打印机,请参阅打印机制造商的网站。

Windows 8.1 和 Windows 8

  1. 按住 Windows 键,然后按键盘上的 Q 键。
  2. 键入 troubleshooting 在搜索框中。
  3. 单击Troubleshooting(故障诊断)。
  4. 单击 Hardware and Sound (硬件和声音)下的 Use a printer (使用打印机)。
  5. 单击 高级
  6. 单击 以管理员身份运行 。询问时,输入您的凭据或取消凭据(如果您不知道这些凭据)。
  7. 单击Next(下一步)并按照提示进行操作。
提醒:如果问题仍然存在,则您必须卸载打印机驱动程序,并为您的打印机重新安装最新的打印机驱动程序。有关戴尔打印机的更多信息,请参阅戴尔知识库文章 Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware (戴尔打印机卸载、下载和安装打印机驱动程序、软件、手册和固件)。对于非戴尔品牌打印机,请参阅打印机制造商的网站。

Windows 7

  1. 单击 Start
  2. 在 Windows 搜索框中,键入 troubleshooting
  3. 单击“疑难解答”(它应位于控制面板下的列表顶部)。
  4. 单击 Hardware and Sound (硬件和声音)下的 Use a printer (使用打印机)。
  5. 单击高级
  6. 单击 以管理员身份运行 。询问时,输入您的凭据或取消凭据(如果您不知道这些凭据)。
  7. 单击Next(下一步)并按照提示进行操作。
提醒:如果问题仍然存在,则您必须卸载打印机驱动程序,并为您的打印机重新安装最新的打印机驱动程序。有关戴尔打印机的更多信息,请参阅戴尔知识库文章 Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware (戴尔打印机卸载、下载和安装打印机驱动程序、软件、手册和固件)。对于非戴尔品牌打印机,请参阅打印机制造商的网站。

Dotknuté produkty

Printers & Accessories
Vlastnosti článku
Číslo článku: 000125904
Typ článku: Solution
Dátum poslednej úpravy: 25 jan 2024
Verzia:  7
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.