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「IDPA:DP4400 RUCKがiDRACとのTLS通信障害により、ESXi firmware_readiness checkを「failed」と報告する

Сводка: この記事では、iDRACでサポートされていないTLSバージョン設定に起因するRUCK障害について説明します。

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

RUCKは、次のエラーで失敗することがあります。

+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+
| Component | Check              | Status | Message                                       | Remedy                                        |
+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+
| ESXi      | firmware_readiness | FAILED | Firmware pre-upgrade checks failed. [ XXX.XXX.| Use KB https://www.dell.com/support/kbdoc/191 |
|           |                    |        | XXX.XXX ]: The cached response with Node Event| 627 to fix the issue.                         |
|           |                    |        | Service is disabled. Node Event Service is in |                                               |
|           |                    |        |  a degraded state,iDRAC Service Module is not |                                               |
|           |                    |        |  available/active at this time. Check iDRAC S |                                               |
|           |                    |        | ervice Module/iDRAC status.                   |                                               |
+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+

 

次の出力: dpacli -agentinfo (ACM CLIから実行)では、エージェントのステータスが「Degraded」または「Error」と表示される場合があります。

    "status": {
        "idraccache": "Degraded",
        "idracConnection": "N/A",
        "iSM": "N/A",
        "agent": "Degraded"
    }

 

    "status": {
        "idraccache": "OK",
        "idracConnection": "OK",
        "iSM": "N/A",
        "agent": "OK"
    }

 

ESXiログ /scratch/log/pta_debug.log 次のようなエラー パターンが表示される場合があります。

2023/11/27 18:55:24[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:24[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:24[UTC] [2108525:197131072] WARN  - WSManClient::isValidResponse: Http request to host: 169.254.0.1, failed with status code: -2
2023/11/27 18:55:25[UTC] [2108525:173456192] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - DoMethod: Failed to connect to server. Retrying once . . .
2023/11/27 18:55:29[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - isValidResponse: request failed with status code: -2.
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - DoMethod: RedFish request failed. [status: -2, response-body: ]

 

Причина

iDRAC Webサーバーは、TLSバージョン1.3を使用した接続のみを受け入れるように設定されています。
この構成は、IDPAおよびPowerProtect DPシリーズ アプライアンスではサポートされていません。

 

Разрешение

メモ: iDRAC Webサーバー構成のデフォルトのTLSバージョンは「TLS 1.1以降」です。次の例では、「TLS 1.2以上」が望ましいことを前提としていますが、必要に応じてこの設定をデフォルト設定に戻すことができます。

 

この問題を解決するには、以下の手順を実行してください。

  1. ブラウザーでiDRAC UIを開き、「root」ユーザーとしてログインします
  2. [iDRAC Settings] -> [Services] -> [Web Server] -> [Settings]に移動します。
  3. [TLS Protocol]構成で、[TLS 1.2 and Higher]が選択されていることを確認します
  4. この変更を適用するには、[Apply]を選択します

 

これらの変更後、エージェントの状態は 5 分から 10 分以内に正規化されます (それ以上のアクションは必要ありません)。変化が見られない場合は、ホスト オペレーティング システムでiSMおよびPTAgentサービスを再起動することをお勧めします。

  1. ESXi(ハイパーバイザー)コンポーネントへのPuTTY/SSH接続を「root" ユーザー
  2. 実行 /etc/init.d/dcism-netmon-watchdog restart
  3. 実行 /etc/init.d/DellPTAgent restart
    iDRAC設定

 

Затронутые продукты

PowerProtect Data Protection Software, Integrated Data Protection Appliance Software

Продукты

PowerProtect Data Protection Appliance, Integrated Data Protection Appliance Family
Свойства статьи
Номер статьи: 000219917
Тип статьи: Solution
Последнее изменение: 12 Mar 2024
Версия:  5
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