Перейти к основному содержимому
  • Простое и быстрое размещение заказов
  • Просмотр заказов и отслеживание состояния доставки
  • Создание списка продуктов и доступ к нему

IDPA: DP4400 RUCK rapporterer ESXi-firmware_readiness kontrollen som mislykket på grunn av kommunikasjonsfeil med TLS med iDRAC

Сводка: Denne artikkelen beskriver en RUCK-feil som følge av en konfigurasjon av en TLS-versjon som ikke støttes i iDRAC.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

RUCK kan mislykkes med følgende feil.

+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+
| Component | Check              | Status | Message                                       | Remedy                                        |
+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+
| ESXi      | firmware_readiness | FAILED | Firmware pre-upgrade checks failed. [ XXX.XXX.| Use KB https://www.dell.com/support/kbdoc/191 |
|           |                    |        | XXX.XXX ]: The cached response with Node Event| 627 to fix the issue.                         |
|           |                    |        | Service is disabled. Node Event Service is in |                                               |
|           |                    |        |  a degraded state,iDRAC Service Module is not |                                               |
|           |                    |        |  available/active at this time. Check iDRAC S |                                               |
|           |                    |        | ervice Module/iDRAC status.                   |                                               |
+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+

 

Utgangen av dpacli -agentinfo (kjøres fra ACM CLI) kan vise agentstatusen som "Degraded" eller "Error".

    "status": {
        "idraccache": "Degraded",
        "idracConnection": "N/A",
        "iSM": "N/A",
        "agent": "Degraded"
    }

 

    "status": {
        "idraccache": "OK",
        "idracConnection": "OK",
        "iSM": "N/A",
        "agent": "OK"
    }

 

ESXi-loggen /scratch/log/pta_debug.log kan vise følgende mønster av feil.

2023/11/27 18:55:24[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:24[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:24[UTC] [2108525:197131072] WARN  - WSManClient::isValidResponse: Http request to host: 169.254.0.1, failed with status code: -2
2023/11/27 18:55:25[UTC] [2108525:173456192] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - DoMethod: Failed to connect to server. Retrying once . . .
2023/11/27 18:55:29[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - isValidResponse: request failed with status code: -2.
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - DoMethod: RedFish request failed. [status: -2, response-body: ]

 

Причина

iDRAC-webserveren er konfigurert til å godta tilkoblinger bare ved hjelp av TLS versjon 1.3.
Denne konfigurasjonen støttes ikke for verktøy i IDPA- og PowerProtect DP-serien.

 

Разрешение

MERK: Standard TLS-versjon for konfigurasjon av iDRAC-webserver er "TLS 1.1 og høyere". Følgende eksempel forutsetter at "TLS 1.2 og høyere" foretrekkes, men denne innstillingen kan returneres til standardkonfigurasjonen om nødvendig.

 

Utfør følgende trinn for å løse dette problemet.

  1. Åpne iDRAC-brukergrensesnittet i en nettleser, og logg på som rotbruker
  2. Gå til "iDRAC Settings" -> "Services" -> "Web Server" -> "Settings"
  3. Under "TLS Protocol"-konfigurasjonen må du sørge for at "TLS 1.2 and Higher" er valgt
  4. Velg "Apply" for å bruke denne endringen

 

Etter disse endringene bør agenttilstanden normaliseres innen 5-10 minutter (krever ingen ytterligere tiltak). Hvis ingen endring observeres, anbefales det å starte iSM- og PTAgent-tjenestene på nytt på vertsoperativsystemet.

  1. Åpne en PuTTY/SSH-tilkobling til ESXi-komponenten (Hypervisor) som "root" bruker
  2. Kjør /etc/init.d/dcism-netmon-watchdog restart
  3. Kjør /etc/init.d/DellPTAgent restart
    IDRAC-innstillinger

 

Затронутые продукты

PowerProtect Data Protection Software, Integrated Data Protection Appliance Software

Продукты

PowerProtect Data Protection Appliance, Integrated Data Protection Appliance Family
Свойства статьи
Номер статьи: 000219917
Тип статьи: Solution
Последнее изменение: 12 Mar 2024
Версия:  5
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.