Перейти к основному содержимому
  • Простое и быстрое размещение заказов
  • Просмотр заказов и отслеживание состояния доставки
  • Создание списка продуктов и доступ к нему

IDPA: DP4400 RUCK ilmoittaa ESXi-firmware_readiness tarkistuksen epäonnistuneeksi iDRACin TLS-yhteysvirheen vuoksi

Сводка: Tässä artikkelissa kuvataan RUCK-vika, joka johtuu iDRACin TLS-versiomäärityksestä, jota ei tueta.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

RUCK saattaa epäonnistua seuraavan virheen vuoksi.

+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+
| Component | Check              | Status | Message                                       | Remedy                                        |
+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+
| ESXi      | firmware_readiness | FAILED | Firmware pre-upgrade checks failed. [ XXX.XXX.| Use KB https://www.dell.com/support/kbdoc/191 |
|           |                    |        | XXX.XXX ]: The cached response with Node Event| 627 to fix the issue.                         |
|           |                    |        | Service is disabled. Node Event Service is in |                                               |
|           |                    |        |  a degraded state,iDRAC Service Module is not |                                               |
|           |                    |        |  available/active at this time. Check iDRAC S |                                               |
|           |                    |        | ervice Module/iDRAC status.                   |                                               |
+-----------+--------------------+--------+-----------------------------------------------+-----------------------------------------------+

 

Tuotos dpacli -agentinfo (ACM-komentoriviliittymästä) agentin tilana saattaa näkyä Degraded tai Error.

    "status": {
        "idraccache": "Degraded",
        "idracConnection": "N/A",
        "iSM": "N/A",
        "agent": "Degraded"
    }

 

    "status": {
        "idraccache": "OK",
        "idracConnection": "OK",
        "iSM": "N/A",
        "agent": "OK"
    }

 

ESXi-loki /scratch/log/pta_debug.log Voi ilmetä seuraava virhemalli.

2023/11/27 18:55:24[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:24[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:24[UTC] [2108525:197131072] WARN  - WSManClient::isValidResponse: Http request to host: 169.254.0.1, failed with status code: -2
2023/11/27 18:55:25[UTC] [2108525:173456192] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - DoMethod: Failed to connect to server. Retrying once . . .
2023/11/27 18:55:29[UTC] [2108525:172927808] WARN  - HttpsClient::handle_handshake: <0x8cda828> async_handshake() failed - tlsv1 alert protocol version [336151598]
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - isValidResponse: request failed with status code: -2.
2023/11/27 18:55:29[UTC] [2108525:194489152] WARN  - DoMethod: RedFish request failed. [status: -2, response-body: ]

 

Причина

iDRAC-verkkopalvelin on määritetty hyväksymään yhteydet ainoastaan TLS-versiolla 1.3.
IDPA- ja PowerProtect DP -sarjan laitteet eivät tue tätä kokoonpanoa.

 

Разрешение

HUOMAUTUS: iDRAC-verkkopalvelinkokoonpanon TLS-oletusversio on TLS 1.1 and Uudempi. Seuraavassa esimerkissä oletetaan, että TLS 1.2 ja uudemmat ovat suositeltavia, mutta tämä asetus voidaan tarvittaessa palauttaa oletuskokoonpanoon.

 

Voit ratkaista ongelman seuraavasti.

  1. Avaa iDRAC-käyttöliittymä selaimessa ja kirjaudu root-käyttäjänä
  2. Siirry kohtaan iDRAC Settings -> Services -> Web Server -> Settings
  3. Varmista TLS Protocol -määrityksessä, että TLS 1.2 and Higher on valittu
  4. Ota muutos käyttöön valitsemalla Apply

 

Näiden muutosten jälkeen agentin tilan pitäisi normalisoitua 5–10 minuutin kuluessa (ei vaadi lisätoimia). Jos muutoksia ei havaita, suosittelemme käynnistämään iSM- ja PTAgent-palvelut uudelleen isäntäkäyttöjärjestelmässä.

  1. Avaa PuTTY/SSH-yhteys ESXi (Hypervisor) -komponenttiin nimellä "root" käyttäjä
  2. Suorita /etc/init.d/dcism-netmon-watchdog restart
  3. Suorita /etc/init.d/DellPTAgent restart
    IDRAC-asetukset

 

Затронутые продукты

PowerProtect Data Protection Software, Integrated Data Protection Appliance Software

Продукты

PowerProtect Data Protection Appliance, Integrated Data Protection Appliance Family
Свойства статьи
Номер статьи: 000219917
Тип статьи: Solution
Последнее изменение: 12 Mar 2024
Версия:  5
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.