Przejdź do głównej zawartości
  • Szybkie i łatwe składanie zamówień
  • Wyświetlanie zamówień i śledzenie stanu wysyłki
  • Tworzenie i dostęp do listy produktów
Niektóre numery artykułów mogły ulec zmianie. Jeśli szukasz czegoś innego, spróbuj wyszukać wszystkie artykuły. Wyszukaj artykuły

Resolve No Bootable Device Found Error in Legacy Mode on Dell Computers

Podsumowanie: Resolve "No bootable devices were found" error on laptops and PCs. Learn how to fix no boot device available, detected, or found by switching to UEFI mode and reinstalling Windows 10 or Linux. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Follow the guidelines below to resolve the following error message:

The No boot device Found error appears when the Boot Sequence is set to Legacy mode or the operating system is installed under Legacy mode. 


No boot device found error

The following error may appear after operating system installation: No boot device found
This error occurs when the device BIOS boot sequence is set to Legacy mode.

"No bootable devices were found" error

If the operating system is installed in Legacy mode, the error message appears when you reboot the computer. The failure cannot be recovered by changing the BIOS setting back to Unified Extensible Firmware Interface (UEFI). The operating system should be reinstalled.

Note:
  • Only Windows 10 and higher and Linux operating systems in UEFI boot mode are supported on these specific Dell computers.
  • Ensure that UEFI mode is enabled in the BIOS before trying to reinstall the operating system.
  • Using an Optical Drive to install the operating system is not supported in legacy mode as there is no Optical Drive option in the Boot Menu.
  • The above Dell computers have a 7th-generation Coffee Lake processor (and above). The computers are designed to boot exclusively in the UEFI; boot environment.
  • As a result, the operating system fails to boot if Legacy boot mode is selected on these computers.

Przyczyna

Wrong boot mode set in BIOS.

Rozwiązanie

If the operating system is installed with UEFI before the boot sequence is changed, the computer can be recovered by changing the Boot sequence back to UEFI.

If the operating system is installed with Legacy mode, the computer cannot be recovered by changing the Boot sequence back to UEFI mode.
Operating system reinstallation should be performed.

Follow the steps below to reinstall Windows 10 or higher:

  1. From a power off state, power on the computer and Press F2 at the Dell logo to boot into the BIOS setup menu.
  2. Choose Boot sequence and change the option from Legacy to UEFI then click Apply in the lower right corner of the screen:
    Change Boot List Option from Legacy to UEFI in BIOS settings
  3. Choose Advanced Boot Options and disable Enable Legacy Option ROMs then click Apply in the lower right corner of the screen:
    Enable Legacy Option ROMs in BIOS settings
  4. Choose Secure Boot -> Secure Boot Enable and change the option from Disabled to Enabled.
  5. Then click Apply in the lower right corner of the screen:
    Enable the Secure Boot Enable setting in BIOS
  6. Click Exit in the lower right corner of the screen and wait for the computer to reboot.
  7. Reinstall the Windows 10 operating system.

Follow the steps below to install the Linux operating system:

  1. Follow steps 1 through 3 from the steps above for installing Windows 10 (these steps are the same for a Linux install).
  2. Verify the Secure Boot > Secure Boot Enable option is Disabled in the BIOS:
    Disable Secure Boot Enable in BIOS
  3. Choose SATA Operation -> SATA Operation and change to AHCI mode:
    Enable SATA AHCI
  4. Click Exit in the lower right corner and wait for the computer to reboot.
  5. Reinstall the Linux operating system.

Dodatkowe informacje

Produkty, których dotyczy problem

OptiPlex 3060 Tower, OptiPlex 3060 Micro, OptiPlex 3060 Small Form Factor, OptiPlex 5060 Tower, OptiPlex 5060 Micro, OptiPlex 5060 Small Form Factor, OptiPlex 7060 Tower, OptiPlex 7060 Micro, OptiPlex 7060 Small Form Factor, Precision 3630 XL Tower , Precision 3430 Small Form Factor, Precision 3630 Tower ...
Właściwości artykułu
Numer artykułu: 000128655
Typ artykułu: Solution
Ostatnia modyfikacja: 17 paź 2024
Wersja:  10
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.