Ga naar hoofdinhoud
  • Snel en eenvoudig bestellen
  • Bestellingen en de verzendstatus bekijken
  • Een lijst met producten maken en openen

Felsöka problem med igenkänning av optiska enheter i Windows

Samenvatting: Lär dig att diagnostisera och åtgärda problem med CD-, DVD- eller Blu-Ray-enhetsigenkänning i Windows 11 och Windows 10 på Dells stationära eller bärbara datorer.

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

Berörda operativsystem:

  • Windows 11
  • Windows 10

Anvisningarna nedan hjälper dig att diagnostisera och lösa problem om CD-, DVD- eller Blu-Ray-enheten inte känns igen i Microsoft Windows eller andra program.

Oorzaak

Det kan finnas flera orsaker till att Microsoft Windows eller andra program inte ser eller inte identifierar en CD-, DVD- eller Blu-Ray-enhet. Nedan följer några instruktioner som kan hjälpa dig att lösa problemet i vissa fall om enheten inte har slutat fungera helt.

Använd felsökningsanvisningarna nedan om CD-, DVD- eller Blu-Ray-enheten inte visas i Utforskaren eller Den här datorn (den kallades Utforskaren i Microsoft Windows 7 och tidigare versioner av Microsoft Windows) och enheten är markerad med ett gult utropstecken i Enhetshanteraren. I Enhetshanteraren kanske du också märker att något av följande fel visas i området Enhetsstatus på fliken Egenskaper. Så här visar du Enhetshanteraren: Tryck på Windows-tangenten + R för att öppna dialogrutan Kör. Skriv devmgmt.msc för att öppna dialogrutan Kör och tryck sedan på Retur för att visa Enhetshanteraren.

  • Windows kan inte starta den här maskinvaruenheten eftersom konfigurationsinformationen (i registret) är ofullständig eller skadad. (Kod 19)
  • Enheten fungerar inte som den ska eftersom Windows inte kan läsa in de drivrutiner som krävs för den här enheten. (Kod 31)
  • En drivrutin (tjänst) för den här enheten har inaktiverats. En alternativ drivrutin kanske tillhandahåller den här funktionen. (Kod 32)
  • Windows kan inte läsa in drivrutinen för den här maskinvaran. Drivrutinen är kanske skadad, eller saknas. (Kod 39)
  • Windows har läst in drivrutinen för den här maskinvaran men hittar inte maskinvaruenheten. (Kod 41)

Anvisningarna nedan kan användas för både interna och externa CD-, DVD- eller Blu-Ray-enheter, men en del av grunderna kan skilja sig åt.

Obs! Instruktionerna nedan gäller för följande Microsoft Windows-operativsystem, men vissa instruktioner kan skilja sig något med äldre versioner av Microsoft Windows:
  • Windows 11
  • Windows 10

Oplossing

Klicka på felsökningsstegen nedan om du vill ha fler instruktioner. Om problemet kvarstår går du till nästa felsökningssteg.

Kontrollera att drivenheten känns igen i BIOS och systeminställningarna. Det här steget gäller endast för datorer med interna enheter.

  1. Starta om datorn och tryck på F2-tangenten medan den startar om.
  2. Kontrollera om enheten identifieras i BIOS (bild 1, 2 och 3). Om ja, gå till nästa steg.
    Mer information finns i följande artikel i Dells kunskapsbank: Instruktioner för att hämta och visa handböcker.
    BIOS-alternativ 1
    Figur 1: Optisk enhet i BIOS


    BIOS-alternativ 2Bild 2: Optisk enhet i BIOS


    BIOS-alternativ 3Bild 3: Optisk enhet i BIOS
 
  • Om enheten inte identifieras i BIOS måste du koppla bort och återansluta enheten på datorn.
    Fler instruktioner om hur du kopplar från och återansluter CD-, DVD- eller Blu-Ray-enheten finns i följande artikel i Dells kunskapsbank: Instruktioner för att ladda ner och visa handböcker.
  • Om enheten fortfarande inte identifieras kontaktar du Dells tekniska support för reparationsalternativ inom garantin.

Du kan köra felsökaren av maskinvara och enheter som är inbyggd i Microsoft Windows. Felsökaren för maskinvara och enheter är endast tillgänglig i Microsoft Windows 7, Windows 8, Windows 8.1 och Windows 10.
Så här kör du felsökaren för hårdvara och enheter:

  1. Tryck på Windows-tangenten + R för att öppna dialogrutan Kör.
  2. I dialogrutan Kör skriver du kontroll och trycker sedan på Retur.
  3. Skriv felsökare i sökrutanKontrollpanelen i det övre högra hörnet och klicka sedan på Felsökning.
  4. Under objektet Maskinvara och ljud klickar du på Konfigurera en enhet.
    Obs! Du måste logga in på Windows med ett konto med administratörsbehörighet. Om du får några uppmaningar från Kontroll av användarkonto medan du kör felsökaren av maskinvara och enheter klickar du på Ja.

Windows 10 och Windows 11

  1. Klicka på Start.
  2. Öppna Inställningar
  3. Klicka på Uppdateringar och säkerhet och sedan på Felsökning.
  4. Klicka på Maskinvara och enheter och gå till Kör felsökaren.
  5. Följ anvisningarna på skärmen för att köra felsökaren.

Drivrutiner för CD-, DVD- eller Blu-Ray-enheten ingår i operativsystemet och kräver därför inte att du installerar någon specifik drivrutin. Avinstallera drivrutinen och starta om datorn Installera om drivrutinen, vilket löser de flesta problem som är relaterade till drivrutinen.

Följ anvisningarna nedan för att avinstallera och installera om drivrutinen:

  1. Tryck på Windows-tangenten + R för att öppna dialogrutan Kör.
  2. Skriv devmgmt.msc i dialogrutan Kör, tryck sedan på Retur.
    Obs! Du måste logga in på Windows med ett konto med administratörsbehörighet. Om du får några uppmaningar från Kontroll av användarkonto medan du kör felsökaren av maskinvara och enheter klickar du på Ja.
  3. I fönstret Enhetshanteraren expanderar du DVD-/CD-ROM-enheter. Högerklicka på CD-/DVD-/Blu-Ray-enheten som visas i listan och klicka sedan på Avinstallera.
  4. Klicka på OK för att bekräfta att du vill ta bort enheten.
  5. Starta om datorn (När omstarten är klar installerar operativsystemet automatiskt de drivrutiner som krävs).

Om du har andra problem med CD-, DVD- eller Blu-ray-enheten på datorn kan du läsa följande artikel i Dells kunskapsbank: Felsöka CD/DVD- eller Blu-Ray-enhetsproblem i Microsoft Windows.

Extra informatie

Getroffen producten

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations
Artikeleigenschappen
Artikelnummer: 000134006
Artikeltype: Solution
Laatst aangepast: 23 jan. 2025
Versie:  13
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.