The steps for applying the hotfix are consistent for all Avamar Server versions, however, the screenshots used in this KB article are for reference only. The actual screens on your system may appear slightly different.
Check the history tab to verify previously installed hotfixes, follow Appendix B for instructions.
원인
Avamar utilizes an Avamar workflow package (AVP) that automates the software steps needed to complete installing Hotfix. While this is an automated process monitoring progress and responding to prompts that require user input and any error that may occur during the installation is required.
Requirements:
Valid license installed on the Avamar Server
The Avamar system is healthy and functioning normally
Internet Explorer, Firefox, or Chrome Web browser.
This procedure has three steps:
Download the hotfix
Upload the hotfix to Avamar.
Install the hotfix.
해결
Downloading the Hotfix
The avp packages can be downloaded from the support site or links that are provided in DSA/DTA/KB article.
Below is an example of how to download the hotfix from the support site.
We are selecting Avamar Server and then the version number. Selecting download will download the file to the local machine.
Support page link: https://dell.com/support
Uploading the hotfix to Avamar using Avamar Installation Manager (AVI)
Uploading is done using Avamar Installation Manager. Files can be uploaded from the local machine.
Check Appendix A if the direct upload does not work.
Follow the below steps from the local machine to upload the hotfix files.
Using the web browser type the URL address for the Avamar :
Note: It may take up to 15 minutes for the package to appear. Click the refresh button in the top right of the window to refresh the package list.
When the Avamar hotfix package appears, click Install to execute the workflow.
The Installation Setup screen (displayed below) appears:
Click on Continue at the bottom of the screen.
The installation runs and displays its progress.
Once the installation has completed, the progress page will show "Completed hotfix-xxxxxx" in the information log at the bottom of the page. The procedure is completed. Log out to exit out of the Avamar Installation Manager.
Cumulative hotfix installation Note: After a hotfix or cumulative hotfix installation, it may be necessary to upgrade the Avamar Administrator GUI (MCGUI). If there is a version mismatch, a warning message shows when opening the Avamar Administrator GUI. In this case, an update is needed. For more information, see the Avamar Administrator Guide "Installing Avamar Administrator".
Starting Avamar 18.2 we have a new HTML5 web GUI, you can access by typing HTTPS://<hostname>aui
For any questions or issues with this procedure, contact an account representative or DELL EMC Customer Support at https://www.dell.com/support/home
추가 정보
APPENDIX A:
Instructions for copying hotfix AVPs to the Avamar system.
Method 1:
Download the AVP hotfix file for the appropriate Avamar version.
Log in to Avamar as the admin user.
Copy the AVP from the location where it was downloaded to the Avamar Server directory /usr/local/avamar/src/.
root@utility:~/#: cd /home/admin/me/ root@utility:/home/admin/me/#: ls v18_1_0_33_mc_cumulative_201808.avp root@utility:/home/admin/me/#: mv v18_1_0_33_mc_cumulative_201808.avp /data01/avamar/repo/packages/ root@utility:/home/admin/me/#: ls /data01/avamar/repo/packages/ v18_1_0_33_mc_cumulative_201808.avp root@utility:/home/admin/me/#: ls -ltrh /data01/avamar/repo/packages/ total 373M -rw-r--r-- 1 avi avi 373M Dec 3 15:45 v18_1_0_33_mc_cumulative_201808.avp
Method 2:
Download the AVP hotfix file for the appropriate Avamar version.
Log in to Avamar Installation Manger.
Navigate to Repository tab and upload required AVP.
Proceed with the steps from the resolution section to install the hotfix.
APPENDIX B: How to check previously installed hotfixes.
Log in to Avamar installation Manager.
Navigate to the History tab to check previously installed hotfixes.