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High Memory Usage Due to SupportAssistAgent.exe

概要: This article provides information about SupportAssistAgent.exe causing high memory usage (>90%) in Task Manager.

この記事は自動翻訳されたものである可能性があります。品質に関するフィードバックがある場合は、このページの下部にあるフォームを使用してお知らせください。

文書の内容


現象

Affected Products:

  • SupportAssist for Home PCs

Affected Versions:

  • v3.13.x
  • v3.14.x

Affected Platforms:

  • Alienware
  • G Series
  • OptiPlex
  • Latitude
  • Inspiron
  • Precision Workstations
  • Vostro
  • XPS

SupportAssist v3.13.x and 3.14.x in some machines causes high memory usage. When this phenomenon occurs, the Task Manager shows the memory usage percentage >90%.

This may impact computer performance while at times the computer may stop responding, and the screen goes black.

Task Manager showing SupportAssistAgent.exe high memory usage
Figure 1: (English Only) Task Manager showing SupportAssistAgent.exe high memory usage

原因

The IoT connection is done using Microsoft Azure SDK, which is causing the memory leakage.

解決方法

The issue has been resolved with the latest release v4.0.3.

  • The latest version is auto upgraded, or you receive a prompt to upgrade when you open SupportAssist User Interface.
  • You can manually upgrade the version, for more information reference Explore SupportAssist for Home PCs.

The platforms listed below cannot be auto upgraded to SupportAssist v4.0.3.

Platforms temporally excluded:

Platforms
Dell G15 5530
Dell G16 7630
Inspiron 14 5440
Inspiron 14 5445
Inspiron 14 7440 2-IN-1
Inspiron 15 3520
Inspiron 15 3530
Inspiron 16 5640
Inspiron 16 5645
Vostro 14 3430
Vostro 15 3530
Vostro 16 5640
Vostro 3420
Vostro 3520
Note: Users with these platforms can still upgrade following the steps below.

Steps to manually download and install SupportAssist v4.0.3:

  1. Install the latest .net desktop runtime: https://dotnet.microsoft.com/download/dotnet/6.0 This hyperlink is taking you to a website outside of Dell Technologies.

.NET Desktop Runtime 6.0.29
Figure 2: (English Only) .NET Desktop Runtime 6.0.29

  1. To find the System Type search for System Information in the Windows search bar.

System Information
Figure 3: (English Only) System Information

  1. Download the latest SupportAssist .msi (SupportAssistx64-4.0.3.61632.msi) from the Dell Downloads Catalog.
  2. Download the latest SupportAssist .msp (SupportAssistx64-4.0.3.61632.msp) from the Dell Downloads Catalog.
  3. Create a folder in the C drive and name it SA.
  4. Copy the downloaded .msi and .msp files to the SA folder in the C drive.
  5. Open Command Prompt as Administrator
    1. Type msiexec /i C:\SA\SupportAssistx64-4.0.0.61632.msi /qb /l*v and press Enter. Wait for the .msi installation to complete.

.msi install window.
Figure 4: (English Only) .msi install window.

  1. Type msiexec /p C:\SA\SupportAssistx64-4.0.3.61632.msp /qb /l*v and then press Enter. Wait for the .msp installation to complete.

.msp install window
Figure 5: (English Only) .msp install window

  1. Go to Programs and open SupportAssist application.

文書のプロパティ


影響を受ける製品

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations, SupportAssist for Home PCs

最後に公開された日付

30 5月 2024

バージョン

5

文書の種類

Solution