メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能

PowerScale:ファームウェアの並列アップグレード中にクラスターにアクセスできなくなる

概要: 「--fw-pkg」スイッチを含むOneFSの並列アップグレード、またはPowerScaleノード(F200、F210、F600、F710、F900、F910)を含むファームウェアのみの並列アップグレード中に、クラスターにアクセスできなくなります。

この記事は次に適用されます:   この記事は次には適用されません: 

現象

アップグレード中、エンドユーザーはクラスターにアクセスできなくなります。クラスターは、読み取り専用(RO)ステータスのために複数のノードがダウンし、分割されていることを示しています。ログには、ノードがiDRACと通信できなくなったため、ROが設定されていることが示されています。ファイル システム操作は、デッドロック、タイムアウト、クォーラムの損失により、中断または中止される場合があります。

原因

アップグレード プロセス中にiDRACファームウェア バージョンがアップデートされている場合、プロセスの一環としてiDRACが再起動します。iDRACにアクセスできない時間枠が約3分間あります。これにより、ハードウェアの正常性モニタリングが妨げられるため、iDRACがオンラインに戻るまでノードは読み取り専用に設定されます。アップグレード エンジンは、ディスク プール予約別に各ネイバーフッドのアップグレード ステータスを追跡します。iDRACの再起動中にノードがROに設定されると、既存のディスク プール予約がキャンセルされます。予約が解放されると、アップグレード エンジンはネイバーフッド内の次のノードでアップグレードを開始します。これにより、クラスターがウェッジ状態になるまで、アップグレードを開始するノードの数が徐々に多くなります。

解決方法

この問題が発生した場合は、 Dellテクニカル サポート にお問い合わせの上、このナレッジベース記事番号をお伝えください

この問題の恒久修正は、OneFSの現在のバージョンに含まれています。このドキュメントは、以下を実行している場合に は適用されません
  • OneFS 9.4.0.19以降
  • OneFS 9.5.0.9以降
  • OneFS 9.7.1.0以降
  • OneFS 9.8.0.1以降
OneFSの以前のバージョン、Gen6.5ハードウェアを搭載したクラスターでは、ノード ファームウェア パッケージを含むアップグレードを実行する場合にのみ--rollingスイッチを使用します。並列アップグレードの制限事項は、ファームウェアを適用する場合に固有です。コマンドの例は次のとおりです。
# isi upgrade cluster start --parallel /ifs/data/OneFS_v9.5.0.7_LTS2023_V2_Install.isi (safe command as it does not include the node firmware package)

# isi upgrade firmware start --rolling --fw-pkg=/ifs/data/Isi_Fw_Package_v12.0.tar (safe command as you are doing a rolling upgrade)

# isi upgrade firmware start --parallel --fw-pkg=/ifs/data/Isi_Fw_Package_v12.0.tar (could induce DU as you are doing a firmware update with the parallel option)

# isi upgrade cluster start --parallel /ifs/data/OneFS_v9.5.0.7_LTS2023_V2_Install.isi --fw-pkg=/ifs/data/Isi_Fw_Package_v12.0.tar (could induce DU as you are including firmware in a parallel upgrade)

対象製品

PowerScale F200, PowerScale F600, PowerScale F900
文書のプロパティ
文書番号: 000222012
文書の種類: Solution
最終更新: 17 9月 2024
バージョン:  6
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。