AppSync:ucrtbase.dllのモジュールに障害が発生してAppSync 4.2エージェントがクラッシュする

概要: AppSync 4.2がインストールされている場合、エージェントが断続的にクラッシュすることがあります。特徴は、サービス プランの実行中にエージェントとの通信が断続的に失われ、ホスト システム ログおよびアプリケーション イベント ログに多数のイベントが表示されることです。この問題は、Windows 2016と2019の両方で発生する可能性があります。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

AppSync 4.2またはAppSync 4.2.0.1エージェントによる断続的なクラッシュが発生することがあります。この問題は、次の症状で特定できます。

まず、AppSyncサービス プランのイベントに次のエラーが表示されることがあります。
 
AppSync server failed to connect to agent host: <Host Name>. Ensure the agent host is up and reachable from the AppSync server. If this is a Windows agent host, ensure AppSync Host Plug-in service is in running state.
 
ホストを確認すると、ホスト アプリケーション イベント ログに次のメッセージが表示されている可能性があります。
 
03/05/2021 12:56:47 PM  Information   <Host Name> 1001    Windows Error Reporting          Fault bucket , type 0  Event Name: BEX64  Response: Not available  Cab Id: 0    Problem signature:  P1: APPSYN~1.EXE  P2: 4.2.0.0  P3: 602b55dd  P4: ucrtbase.DLL P5: 10.0.10240.16390  P6: 55a5b718  P7: 0000000000064388  P8: c0000409  P9: 0000000000000005  

原因

これは、ホスト システムがAppSyncと互換性のないバージョンのucrtbase.dllを実行していることが原因である可能性があります。または、AppSyncエージェントのコード バグが原因であることもあります。

解決方法

この問題を解決するには、次の手順に従います。
  1. ホスト上ですべての累積的なWindows Updatesとセキュリティ アップデートを実行し、必要に応じてホストを再起動します。
    ucrtbase.dllファイルに以下の最小バージョンがあることを確認します。
Windows Server 2016の場合、ucrtbase.dllの最小バージョンが10.0.14393.2097であることを確認します。
Windows Server 2019の場合、ucrtbase.dllの最小バージョンが10.0.17763.719であることを確認します。

ホスト プラグイン サービスを再起動し、サービス プランを再度実行します。
  1. この時点で問題が解決しない場合は、この問題に対してホットフィックスが作成されています。これは、サービス リクエストを開くことで取得できます。 
文書のプロパティ
文書番号: 000185071
文書の種類: Solution
最終更新: 28 2月 2022
バージョン:  4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。