症状
ポリシー、デバイス、クライアントの所有者の通知は送信されません。
通知フィールドのアクション フィールドのコマンドは正しいです。
原因
これは、バックアップ サーバーとメール サーバー間の通信不足、またはオペレーティング システム レベルでの権限の問題が原因である可能性があります。
手順
NetWorker
は、オペレーティング システムのメール コマンドmailx(Linux)と
smtpmail (Windows)を使用して、標準出力バイアルEメールを送信します。Eメールを送信するために満たす必要がある条件を示す以外に、Eメール メッセージの送信に関連するNetWorker機能はほとんどありません。たとえば、次のようになります。バックアップの完了/失敗、デバイスの空き容量など
- 使用しているNetWorkerサーバーから次のコマンドを実行して、ドメインに適したメール サーバーを使用していることを確認します( ドメインを置き換えます)。com をドメイン名に置き換えます)。
Linuxの場合
dig +short domain.com MX
Windows:
nslookup
set q=mx
domain.com
メモ: この方法でメール サーバーにクエリーを実行できない場合は、ドメイン/メール管理者にメール サーバーのアドレスを確認してください。
- NetWorkerサーバーがメール サーバーを解決し、Simple Mail Transfer Protocol (SMTP)ポート(25)に接続できることを確認します(手順1で報告したメール サーバーと mailserver.domain.com 置き換えます)。
nsrports -t mailserver.domain.com -p 25
NetWorkerサーバーからオペレーティング システムのmailコマンドを実行して、Eメール メッセージをNetWorkerの外部に送信できるかどうかを確認します(
recipient@domain.com をEメール アドレスに置き換えます)。
Linuxの場合
echo "test email" | mail -s "test email" recipient@domain.com
Windowsの場合:
echo "test email" | smtpmail -h mailhost_address -s "test email" recipient@domain.com
メモ: これらのコマンドは、コマンドが実行されたディレクトリーのリストを含むEメールを送信します。これらはNetWorker以外のコマンドです。詳細は、
mail
および
smtpmail
のマニュアルページを参照してください。
ログ:
Linux NetWorkerサーバーでは、メールの問題に関する詳細な洞察を得るために、次のログとディレクトリーを確認します。
メッセージが送信され、配信が受け入れられた場合の一般的なメールログファイル。
mqueue でスタックしたメッセージが、サーバーから送信または受け入れられません。電子メール メッセージが送信および配信されている場合、mqueue は空である必要があります。
NetWorkerサーバーがWindowsの場合、Exchange管理者はExchange側からログを確認する必要があります。
結論:
NetWorkerサーバーからエラーを特定できるかどうかにかかわらず、ドメイン/メール管理者は、メール サーバーのログをチェックして、通知に関する特定のエラーを確認する必要があります。NetWorkerサーバーのコマンド ラインからメール コマンドが正常に実行されたら、目的の通知フィールドにオペレーティング システムのメール コマンドとオプションを入力します。
NetWorker:ポリシー電子メール通知を構成する方法