メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能

Felsöka problem med igenkänning av optisk enhet i Windows

概要: Lär dig att diagnostisera och åtgärda problem med igenkänning av CD-, DVD- eller Blu-Ray-enheter i Windows 11, Windows 10 och Windows 8 eller 8.1 på stationära eller bärbara Dell-datorer. ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Berörda operativsystem:

  • Windows 11
  • Windows 10
  • Windows 8 eller 8.1

Anvisningarna nedan hjälper dig att diagnostisera och lösa problem om CD-, DVD- eller Blu-Ray-enheten inte identifieras i Microsoft Windows eller andra program.

原因

Det kan finnas flera orsaker till varför Microsoft Windows eller andra program inte kan se eller inte identifiera en CD-, DVD- eller Blu-Ray-enhet. Nedan följer några instruktioner som kan hjälpa dig att lösa problemet i vissa fall om enheten inte är helt trasig.

Använd felsökningsanvisningarna nedan om CD-, DVD- eller Blu-Ray-enheten inte syns i Utforskaren eller Den här datorn (den hette Windows Explorer i Microsoft Windows 7 och tidigare versioner av Microsoft Windows) och enheten är markerad med ett gult utropstecken i Enhetshanteraren. I Enhetshanteraren kan du också märka att ett av följande fel visas i området Enhetsstatus på fliken Egenskaper . Så här visar du Enhetshanteraren: Tryck på Windows-tangenten + R för att öppna dialogrutan Kör. Skriv devmgmt.msc för att öppna dialogrutan Kör och tryck sedan på Retur för att visa Enhetshanteraren.

  • Windows kan inte starta den här maskinvaruenheten eftersom konfigurationsinformationen (i registret) är ofullständig eller skadad. (Kod 19)
  • Enheten fungerar inte korrekt eftersom Windows inte kan läsa in de drivrutiner som krävs för den här enheten. (Kod 31)
  • En drivrutin (tjänst) för den här enheten har inaktiverats. En alternativ drivrutin kanske tillhandahåller den här funktionen. (Kod 32)
  • Windows kan inte läsa in drivrutinen för den här maskinvaran. Drivrutinen är kanske skadad, eller saknas. (Kod 39)
  • Windows har läst in drivrutinen för den här maskinvaran men hittar inte maskinvaruenheten. (Kod 41)

Anvisningarna nedan kan användas för både interna och externa CD-, DVD- eller Blu-Ray-enheter, men en del av grunderna kan skilja sig åt.

Obs! Anvisningarna nedan gäller följande Microsoft Windows-operativsystem, men vissa instruktioner kan variera något för äldre versioner av Microsoft Windows:
  • Windows 11
  • Windows 10
  • Windows 8 eller 8.1

解決方法

Klicka på felsökningsstegen nedan om du vill ha fler instruktioner. Om problemet inte är löst går du till nästa felsökningssteg.

Kontrollera att enheten identifieras i BIOS och systeminställningarna. Det här steget gäller endast för datorer med interna enheter.

  1. Starta om datorn och tryck på F2-tangenten medan den startar om.
  2. Kontrollera om enheten identifieras i BIOS (bild 1, 2 och 3). Om ja går du vidare till nästa steg.
    Mer information finns i följande artikel i Dells kunskapsbank : Instruktioner för att hämta och visa handböcker.
    BIOS-alternativ 1
    Bild 1: Optisk enhet i BIOS


    BIOS-alternativ 2bild 2: Optisk enhet i BIOS


    BIOS-alternativ 3bild 3: Optisk enhet i BIOS
 
  • Om enheten inte identifieras i BIOS måste du koppla bort och återansluta enheten till datorn.
    Mer information om hur du kopplar bort och återansluter CD-, DVD- eller Blu-Ray-enheten finns i följande artikel i Dells kunskapsbank: Instruktioner om hur du hämtar och visar handböcker.
  • Om enheten fortfarande inte identifieras kontaktar du Dells tekniska support för reparationsalternativ inom garantin.

Du kan köra felsökaren av maskinvara och enheter som är inbyggd i Microsoft Windows. Felsökaren av maskinvara och enheter är endast tillgänglig i Microsoft Windows 7, Windows 8, Windows 8.1 och Windows 10.
Så här kör du felsökaren av maskinvara och enheter:

  1. Tryck på Windows-tangenten + R för att öppna dialogrutan Kör.
  2. I dialogrutan Kör skriver du kontroll och trycker sedan på Retur.
  3. I det övre högra hörnet, i sökrutanKontrollpanelen, skriver du felsökare och klickar sedan på Felsökning.
  4. Under objektet Maskinvara och ljud klickar du på Konfigurera en enhet.
    Obs! Du måste logga in på Windows med ett konto med administratörsbehörighet. Om du får några uppmaningar från Kontroll av användarkonto medan du kör felsökaren av maskinvara och enheter klickar du på Ja.

Windows 10 och Windows 11

  1. Klicka på Start.
  2. Öppna Inställningar
  3. Klicka på Uppdateringar och säkerhet och sedan på Felsökning.
  4. Klicka på Maskinvara och enheter och gå till Kör felsökaren.
  5. Kör felsökaren genom att följa anvisningarna på skärmen.

Windows 8.1, 8 eller 7

  1. Tryck på Windows-tangenten + R för att öppna dialogrutan Kör.
  2. Skriv kontroll i dialogrutan Kör och tryck sedan på Retur.
  3. I sökrutan i Kontrollpanelen skriver du felsökare och klickar sedan på Felsökning.
  4. Under Maskinvara och ljud klickar du på Konfigurera en enhet. Om du uppmanas att ange ett administratörslösenord eller bekräfta skriver du lösenordet eller ger en bekräftelse.

Drivrutiner för CD-, DVD- eller Blu-Ray-enheten ingår i operativsystemet och kräver därför inte att du installerar en specifik drivrutin. Avinstallera drivrutinen och starta om datorn och installera om drivrutinen, vilket löser de flesta problem som är relaterade till drivrutinen.

Följ anvisningarna nedan för att avinstallera och installera om drivrutinen:

  1. Tryck på Windows-tangenten + R för att öppna dialogrutan Kör.
  2. Skriv devmgmt.msc i dialogrutan Kör, tryck sedan på Retur.
    Obs! Du måste logga in på Windows med ett konto med administratörsbehörighet. Om du får några uppmaningar från Kontroll av användarkonto medan du kör felsökaren av maskinvara och enheter klickar du på Ja.
  3. I fönstret Enhetshanteraren expanderar du DVD-/CD-ROM-enheter. Högerklicka på CD-/DVD-/Blu-Ray-enheten som visas i listan och klicka sedan på Avinstallera.
  4. Klicka på OK för att bekräfta att du vill ta bort enheten.
  5. Starta om datorn (när omstarten är klar installerar operativsystemet automatiskt de nödvändiga drivrutinerna).

Information om andra problem med CD-, DVD- eller Blu-ray-enheten på datorn finns i följande artikel i Dells kunskapsbank: Troubleshooting CD/DVD or Blu-Ray Drive Problems in Microsoft Windows (Felsöka CD-/DVD- eller Blu-Ray-enhetsproblem i Microsoft Windows).

その他の情報

対象製品

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations
文書のプロパティ
文書番号: 000134006
文書の種類: Solution
最終更新: 21 11月 2023
バージョン:  12
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。