メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能

How to Resolve a Boot Issue After Running an Ubuntu Recovery on the Operating System

概要: This article takes you through recovering from a No boot issue on a Dell Notebook using the Ubuntu operating system.

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

The following article provides information about a problem with booting to the operating system after running the Ubuntu operating system recovery tool on Dell laptops.


Does your Ubuntu laptop fail to boot after running the recovery tool?

At the recovery stage, the primary hard drive would normally be expected to be assigned as /dev/sda to proceed with system recovery.

However, in some cases, the Realtek RTS5170 card reader will accidentally report the card reader as /dev/sda, ahead of the real hard drive.

When this occurs the primary hard drive will be assigned as /dev/sdb instead.

This means that the next time you reboot the system after recovery has finished, the boot manager will be looking for the primary hard drive in the wrong location, as the primary hard drive will have shifted to /dev/sda. The boot manager entry change will make it so that the system will not boot up and will stop at the screen shown below :

Gave up waiting for root device. Common problem:
 - Boot args (cat /proc/cmdline)
 - Check rootdelay: (did the system wait long enough?)
 - Check root: (did the system wait for the right device?)
 - Missing modules (cat /proc/modules: ls /dev)
ALERT! /dev/disk/by-uuid/e279d132-d5b4-42a6-932f-225b4be3f0c8 does not exist. Dropping to a shell!

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in-commands.

(initramfs) _

原因

Cause information is not available.

解決方法

  1. Download the latest Ubuntu LTS image from Ubuntu.com. This hyperlink is taking you to a website outside of Dell Technologies.

  2. Create a bootable USB stick or DVD with the Dell Ubuntu image.

    • Burning a bootable Ubuntu DVD on a working Windows PC (Windows 7 / 8)::

      1. Right-click on the downloaded ISO image and select Open with > Windows Disc Image Burner.

      2. Select the location of your DVD-RW drive and choose Burn. (I recommend you check the Verify disc after burning option, it will confirm the image has been burned correctly.)

    • Burning a bootable Ubuntu USB stick on a working Windows PC (Windows 7 / 8):

      1. Download a USB installer such as Pen Drive Linux's USB Installer. This hyperlink is taking you to a website outside of Dell Technologies.

      2. For this particular installer - select Ubuntu from the drop-down list.

      3. Click Browse and open the downloaded ISO image.

      4. Choose the USB drive and click Create.

  3. Boot the system from either the USB stick or the DVD you've created. You may need to press rapidly on the F12 key at the Dell logo screen when you power the system on - to bring up onscreen a boot device selection menu. (Choose the option that matches the media you are using.)

  4. Choose the Try Ubuntu without installing option from the media's boot menu.

  5. This will boot you into a desktop but has not installed anything on your hard drive. Whilst on the desktop press the Ctrl+Alt+T keys together to open a terminal window. Follow the steps below to resolve the boot location problem:

    1. Change to root.

      sudo –s

    2. Remount the CDRom to set it read-write.

      mount –n –o remount, rw /cdrom/

    3. Enter the command.

      cd /cdrom/factory

    4. Edit the /cdrom/factory/common.cfg file using either the vi or gedit editors. Change the original command to set options="boot=casper automatic-ubiquity noprompt quiet splash -- modprobe.blacklist=rts5139 nomodeset"

    5. Save the file, exit the editor and the terminal window and reboot the system.

  6. If the system still won't boot try the following steps:

    1. Make sure the hardware is running fine by running diagnostics.

      1. if it fails for anything, contact technical support and pass on the error message and validation code.

      2. If it passes, then proceed to the next step.

    2. Run the following command in Terminal:

      ls -lah

    3. If you get anything other than drwxrwxrwt, run the following command:

      chown username: username .Xauthority

    4. If that doesn't work run:

      sudo chmod a+wt /tmp

    5. You can also try running:

      dpkg-reconfigure lightdm

    6. If none of these work, then you are looking at recovering from your system image or backup media.


Additional Information :

Note: Software support is provided by Canonical through the following methods:
Technical Support is provided by Dell :
Note: Do you own a Dell laptop? Send your laptop in for in-warranty repairs, and we will identify and resolve the problem if laptop does not boot. This service is currently available in Canada, France, Germany, Italy, the Netherlands, Poland, the United Kingdom, and the United States.

対象製品

Inspiron
文書のプロパティ
文書番号: 000129823
文書の種類: Solution
最終更新: 31 5月 2024
バージョン:  6
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。