メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能

วิธีการซ่อมแซมโปรแกรมโหลดบูต EFI บนฮาร์ดไดรฟ์ GPT สําหรับระบบปฏิบัติการ Windows บนคอมพิวเตอร์ Dell ของคุณ

概要: บทความนี้แสดงข้อมูลเกี่ยวกับวิธีการแก้ไขปัญหากับ EFI Bootloader ไม่บูตอย่างถูกต้องบนฮาร์ดดิสก์ไดรฟ์ GPT มันมีคําแนะนําสําหรับระบบปฏิบัติการ Windows ต่างๆ

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

原因

แนะ นำ

 

คนส่วนใหญ่ที่มีปัญหาการบูตบนระบบปฏิบัติการ Windows เลือกที่จะติดตั้งระบบปฏิบัติการใหม่แทนที่จะพยายามแก้ไขปัญหาการบูตเอง

บทความนี้เกี่ยวข้องกับการซ่อมโปรแกรมโหลดบูตอินเทอร์เฟซเฟิร์มแวร์แบบขยายได้ (EFI) บน GUID [ตัวระบุที่ไม่ซ้ํากันทั่วโลก] ตารางพาร์ติชัน (GPT) ฮาร์ดดิสก์ไดรฟ์

โซลูชันนี้ใช้ได้กับระบบปฏิบัติการที่ติดตั้งบนระบบอินพุต/เอาท์พุตพื้นฐาน (BIOS) ของอินเทอร์เฟซเฟิร์มแวร์แบบขยายได้ (UEFI) แบบรวม


กลับไปที่ด้านบน


解決方法

วิธีซ่อมแซมโปรแกรมโหลดบูต EFI ของคุณ

 

โดยทั่วไป Windows 7 และ Windows 8 จะติดตั้งบน BIOS แบบดั้งเดิมที่ใช้บันทึกการเริ่มระบบหลัก (MBR) อย่างไรก็ตาม Windows 11 และ Windows 10 ได้รับการออกแบบมาเพื่อติดตั้งบน UEFI BIOS โดยใช้โปรแกรมโหลดบูต EFI และ GPT

หมายเหตุ: การพยายามซ่อมแซมรากของฮาร์ดไดรฟ์อาจทําให้คุณสูญเสียข้อมูลใด ๆ บนไดรฟ์ที่ไม่ได้สํารองข้อมูลไว้ก่อนหน้านี้ เป็นแนวทางปฏิบัติที่ดีที่สุดในการสํารองข้อมูลไดรฟ์ใด ๆ อย่างเต็มที่ก่อนที่จะทํางานกับไดรฟ์หรือระบบปฏิบัติการ

โครงสร้าง GPT เกี่ยวข้องกับปัญหามากมายที่คําสั่ง Bootsect ได้รับการออกแบบมาเพื่อแก้ไขใน MBR อย่างไรก็ตามคําแนะนําต่อไปนี้จะนําคุณไปสู่การซ่อมแซมโปรแกรมโหลดบูต EFI:

หน้าต่าง 11

ถ้าคุณมีสื่อการติดตั้ง:

  1. ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท

  2. บูตจากสื่อ

  3. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ

  4. เลือก "แก้ไขปัญหา"

  5. เลือก ตัวเลือกขั้นสูง

  6. เลือก พร้อมท์คําสั่ง จากเมนู:

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      select disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  7. ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรที่ไม่ได้ใช้งานอยู่แล้ว:

    1. พิมพ์และเรียกใช้คําสั่ง:

      select vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

 
หมายเหตุ: ไปที่ข้อมูลที่ส่วนท้ายของ คําแนะนําส่วนนี้
 

ถ้าคุณ ไม่มี สื่อการติดตั้ง:

  1. ใช้หนึ่งในวิธีในบทความต่อไปนี้เพื่อเริ่มระบบลงในเมนูตัวเลือกการเริ่มต้นขั้นสูงของ Windows:

  2. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น

  3. เลือก พร้อมท์คําสั่ง จากแท็บ ตัวเลือกขั้นสูง ในหน้าจอ แก้ไขปัญหา :

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      select disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  4. ตรวจสอบว่าพาร์ติชัน EFI (EPS) ใช้ระบบแฟ้ม FAT32 และกําหนดอักษรชื่อไดรฟ์ให้กับพาร์ติชันที่ไม่ได้ใช้งานอยู่:

    1. พิมพ์และเรียกใช้คําสั่ง:

      select vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

  5. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

หน้าต่าง 10

ถ้าคุณมีสื่อการติดตั้ง:

  1. ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท

  2. บูตจากสื่อ

  3. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ

  4. เลือก "แก้ไขปัญหา"

  5. เลือก ตัวเลือกขั้นสูง

  6. เลือก พร้อมท์คําสั่ง จากเมนู:

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      sel disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  7. ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรที่ไม่ได้ใช้งาน):

    1. พิมพ์และเรียกใช้คําสั่ง:

      sel vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter <drive letter>:

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

หมายเหตุ: หากคุณใช้ Windows 10 (เวอร์ชัน 1709 หรือใหม่กว่า) ให้ละเว้นขั้นตอนที่ 8 และไปที่ข้อมูลที่ส่วนท้ายของ คําแนะนําส่วนนี้
 
  1. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

 

ถ้าคุณ ไม่มี สื่อการติดตั้ง:

  1. ใช้หนึ่งในวิธีในบทความต่อไปนี้เพื่อเริ่มระบบลงในเมนูตัวเลือกการเริ่มต้นขั้นสูงของ Windows:

  2. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น

  3. เลือก พร้อมท์คําสั่ง จากแท็บ ตัวเลือกขั้นสูง ในหน้าจอ แก้ไขปัญหา :

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      sel disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  4. ตรวจสอบว่าพาร์ติชัน EFI (EPS) ใช้ระบบแฟ้ม FAT32 และกําหนดอักษรชื่อไดรฟ์ให้กับพาร์ติชันที่ไม่ได้ใช้งานอยู่:

    1. พิมพ์และเรียกใช้คําสั่ง:

      sel vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>:

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

  5. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

หน้าต่าง 8 และ 8.1

ถ้าคุณมีสื่อการติดตั้ง:

  1. ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท

  2. บูตจากสื่อ

  3. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ

  4. เลือก "แก้ไขปัญหา"

  5. เลือก พร้อมท์คําสั่ง จากเมนู:

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      sel disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  6. ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรระบุ (กําหนดตัวอักษรที่ไม่ได้ใช้งานอยู่แล้ว):

    1. พิมพ์และเรียกใช้คําสั่ง:

      sel vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>:

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

  7. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

ถ้าคุณ ไม่มี สื่อการติดตั้ง:

  1. รีสตาร์ทเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณ

  2. แตะอย่างรวดเร็วบนปุ่ม <F8> เมื่อคอมพิวเตอร์ส่วนบุคคลเปิดอยู่ แต่ก่อนที่หน้าจอเริ่มต้นของ Windows จะปรากฏขึ้น

    โปรดทราบว่าการดําเนินการนี้อาจต้องใช้ความพยายามหลายครั้ง เวลาสําหรับตัวเลือกนี้สั้นลงจากใน Windows 7

  3. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น

  4. เลือก พรอมต์คําสั่ง จากหน้าจอ แก้ไขปัญหา :

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      sel disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  5. ตรวจสอบว่า พาร์ติชัน EFI (EPS) กําลังใช้ระบบแฟ้ม FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรระบุ (กําหนดตัวอักษรที่ไม่ได้ใช้งานอยู่แล้ว):

    1. พิมพ์และเรียกใช้คําสั่ง:

      sel vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>:

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

  6. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

วินโดวส์ 7

ถ้าคุณมีสื่อการติดตั้ง:

  1. ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท

  2. บูตจากสื่อ

  3. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ

  4. เลือกระบบปฏิบัติการ และคลิก ถัดไป

  5. เลือก พร้อมท์คําสั่ง จากเมนู:

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      sel disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  6. ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรที่ไม่ได้ใช้งานอยู่แล้ว:

    1. พิมพ์และเรียกใช้คําสั่ง:

      sel vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>:

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

  7. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

ถ้าคุณ ไม่มี สื่อการติดตั้ง:

  1. รีสตาร์ทเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณ

  2. แตะอย่างรวดเร็วบนปุ่ม <F8> เมื่อคอมพิวเตอร์ส่วนบุคคลเปิดอยู่ แต่ก่อนที่หน้าจอเริ่มต้นของ Windows จะปรากฏขึ้น

  3. เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น

  4. เลือก พร้อมท์คําสั่ง จาก ตัวเลือกการกู้คืน

    1. พิมพ์และเรียกใช้คําสั่ง:

      diskpart

    2. พิมพ์และเรียกใช้คําสั่ง:

      sel disk 0

    3. พิมพ์และเรียกใช้คําสั่ง:

      list vol

  5. ตรวจสอบว่า พาร์ติชัน EFI (EPS) กําลังใช้ระบบแฟ้ม FAT32 และกําหนดอักษรชื่อไดรฟ์ให้กับพาร์ติชันที่ไม่ได้ใช้งานอยู่

    1. พิมพ์และเรียกใช้คําสั่ง:

      sel vol <number of volume>

    2. พิมพ์และเรียกใช้คําสั่ง:

      assign letter=<drive letter>:

    3. พิมพ์และเรียกใช้คําสั่ง:

      exit

  6. เมื่อต้องการซ่อมแซมบันทึกการบูต:

    1. พิมพ์และเรียกใช้คําสั่ง:

      cd /d <drive letter>:\EFI\Microsoft\Boot\

    2. พิมพ์และเรียกใช้คําสั่ง:

      bootrec /FixBoot

Windows 11 และ Windows 10 (เวอร์ชัน 1709 และใหม่กว่า):

  1. สร้างร้านค้า BCD ใหม่

    1. ก่อนอื่นให้เรียกใช้คําสั่งด้านล่างเพื่อสํารองข้อมูล BCD เก่า:

      ren BCD BCD.bak

    2. ตอนนี้สร้างใหม่โดยใช้คําสั่งนี้:

      bcdboot c:\Windows /s <boot letter>: /f ALL (คุณสามารถเพิ่มสวิตช์ก่อน /s สําหรับตําแหน่งที่ตั้งของคอมพิวเตอร์: /l <language code>. โดยค่าเริ่มต้นจะใช้ /l en-us ภาษาอังกฤษสหรัฐอเมริกา)

    3. bootrec /rebuildbcd

Windows 10 (ก่อนเวอร์ชัน 1709), Windows 8 และ Windows 7:

  1. สร้างร้านค้า BCD ใหม่

    1. ก่อนอื่นให้เรียกใช้คําสั่งด้านล่างเพื่อสํารองข้อมูล BCD เก่า:

      ren BCD BCD.old

    2. ตอนนี้สร้างใหม่โดยใช้คําสั่งนี้:

      bcdboot c:\Windows /l en-us /s <boot letter>: All


กลับไปที่ด้านบน


 

วิธีซ่อมแซมบันทึกการบูตหลักของคุณ (MBR)

 

ขั้นตอนเหล่านี้ใช้กับไดรฟ์รุ่นเก่าที่ใช้เป็นไดรฟ์สําหรับเริ่มระบบบนระบบปฏิบัติการ Windows ล่าสุด

  1. ใช้ปุ่ม F12 ที่หน้าจอ Dell Splash เพื่อเข้าสู่เมนูการบู๊ต ช่วยให้คุณบูตจากสื่อการติดตั้ง Windows หรือดิสก์ที่สามารถบู๊ตได้หรือแฟลชไดรฟ์

  2. คลิกลิงก์ซ่อมแซมคอมพิวเตอร์ของคุณที่ด้านล่างของหน้าจอติดตั้งทันที

  3. คลิก แก้ไขปัญหา

  4. เลือก พรอมต์คําสั่ง

  5. ป้อนคําสั่งสามคําสั่งต่อไปนี้ตามลําดับโดยกดปุ่ม Enter :

    bootrec /fixmbr

    bootrec /fixboot

    bootrec /rebuildbcd

  6. รีสตาร์ทคอมพิวเตอร์โดยเอาสื่อการติดตั้งออกเพื่อตรวจสอบว่าการซ่อมแซมทํางานหรือไม่

 

หากคุณต้องการความช่วยเหลือเพิ่มเติม โปรดติดต่อฝ่ายสนับสนุนด้านเทคนิค

 

  ติดต่อเรา  


กลับไปที่ด้านบน


その他の情報


การสนับสนุนนอกการรับประกัน ไม่อยู่ภายใต้การรับประกัน? ไม่มีปัญหา เรียกดูเว็บไซต์ Dell.com/support และป้อนป้ายบริการของ Dell และดูข้อเสนอของเรา

หมายเหตุ: ข้อเสนอมีให้สําหรับลูกค้าคอมพิวเตอร์ส่วนบุคคลในสหรัฐอเมริกาแคนาดาสหราชอาณาจักร ฝรั่งเศสเยอรมนี จีน และญี่ปุ่นเท่านั้น เซิร์ฟเวอร์และที่เก็บข้อมูลไม่สามารถใช้ได้

対象製品

Inspiron, Latitude, Vostro, XPS, Fixed Workstations
文書のプロパティ
文書番号: 000124331
文書の種類: Solution
最終更新: 27 5月 2024
バージョン:  14
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。