メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能
  • 「Company Administration(会社情報の管理)」では、お使いのDell EMCのサイトや製品、製品レベルでのコンタクト先に関する情報を管理できます。

Dell VxRail. Учетная запись root ESXi заблокирована на 900 секунд после неудачных попыток входа

概要: В этой статье описывается решение проблемы, при которой удаленный доступ для локальной учетной записи пользователя ESXi root блокируется на 900 секунд после неудачных попыток входа. Подключитесь к консоли iDRAC, чтобы получить доступ к оболочке ESXi, затем выполните команду сброса. ...

この記事は次に適用されます:   この記事は次には適用されません: 

現象

Учетная запись root одного или нескольких хостов ESXi заблокирована из-за нескольких неудачных попыток входа.

Не удается подключиться к узлу с помощью SSH или веб-интерфейса.

Подтвердите проблему с помощью консоли iDRAC в оболочке ESXi.

В vCenter отображается предупреждающее сообщение, подобное следующему:

Remote access for ESXi local user account 'root' has been locked for 900s after 14 failed login attempts.

Сообщение о блокировке удаленного доступа

Рис. 1. Удаленный доступ заблокирован.

На затронутом хосте обнаружены журналы, аналогичные следующим:

/var/log/vobd.log

2020-04-03T17:27:58.790Z: [GenericCorrelator] 8202447897096us: [vob.user.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
2020-04-03T17:27:58.790Z: [UserLevelCorrelator] 8202447897096us: [vob.user.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
2020-04-03T17:27:58.791Z: [UserLevelCorrelator] 8202447897325us: [esx.audit.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.

 

/var/log/auth.log

2020-04-03T17:29:06Z sshd[701694298]: Connection from 192.168.100.40 port 55682
2020-04-03T17:29:06Z sshd[701333862]: pam_tally2(sshd:auth): user root (0) tally 34, deny 5
2020-04-03T17:29:08Z sshd[701694298]: error: PAM: Authentication failure for root from 192.168.100.40
2020-04-03T17:29:08Z sshd[701694492]: pam_tally2(sshd:auth): user root (0) tally 35, deny 5
2020-04-03T17:29:08Z sshd[701694492]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.100.40  user=root
2020-04-03T17:29:10Z sshd[701694298]: error: PAM: Authentication failure for root from 192.168.100.40
2020-04-03T17:29:10Z sshd[701694298]: error: Received disconnect from 192.168.100.40 port 55682:3: com.jcraft.jsch.JSchException: Auth cancel [preauth]
2020-04-03T17:29:10Z sshd[701694298]: Disconnected from authenticating user root 192.168.100.40 port 55682 [preauth]

原因

Возможно, пароль root для узла был изменен, но не обновлен в программном обеспечении для мониторинга стороннего производителя.

Это приводит к множеству неудачных попыток входа в систему (иногда сотням или даже тысячам). Из-за этого учетная запись root блокируется на 15 минут, что приводит к невозможности подключения к узлу через SSH или входа в веб-интерфейс узла.

Вход можно выполнить с помощью DCUI и оболочки ESXi.

Начиная с vSphere 6.0, при блокировке учетных записей поддерживается доступ через SSH и vSphere Web Services SDK. Интерфейс Direct Console Interface (DCUI) и оболочка ESXi не поддерживают блокировку учетных записей. По умолчанию до блокировки учетной записи допускается не более пяти неудачных попыток. По умолчанию учетная запись разблокируется через 15 минут.

解決方法

Для решения этой проблемы:
  1. Подключитесь к консоли iDRAC , а затем к оболочке ESXi.
  2. Включите оболочку , выполнив вход в DCUI и включив оболочку ESXi в разделе «Troubleshooting Options».
  3. Вы также можете сделать Cntrl-Alt-F1 , чтобы получить доступ к оболочке.
  4. После подключения к оболочке ESXi выполните указанные ниже команды. Вывод должен соответствовать приведенному ниже снимку экрана, за исключением того, что в графе «От» указано «неизвестно».
#pam_tally2 --user root
#pam_tally2 --user root --reset
#pam_tally2 --user root
ESXi: команды и выходные данные Рис. 2. ESXi: команды и выходные данные
  1. После выполнения указанных выше команд войдите в веб-интерфейс узла ESXi.
  2. Перейдите в меню Monitor, затем Events. Вы должны увидеть IP-адрес, который пытался войти в систему, указанный в списке как «failed».
  3. Необходимо определить приложение на основе указанного здесь IP-адреса. Остановите его или настройте для него правильные учетные данные.

その他の情報

Подробнее см. в статье VMware Пароли ESXi и блокировкаЭта гиперссылка позволяет перейти на сайт за пределами Dell Technologies. учетной записи.

Посмотрите это видео о разблокировке учетной записи root для устранения неполадок ESXi.

Продолжительность: 00:04:56 (чч:мм:сс)При
наличии языковых настроек для скрытых субтитров (субтитров) можно выбрать с помощью значка «Настройки» или «CC» в этом видеопроигрывателе.

Связанные ресурсы
Ниже приведены некоторые рекомендуемые ресурсы по этой теме, которые могут вас заинтересовать:

対象製品

VxRail, VxRail E560F

製品

VxRail E560F
文書のプロパティ
文書番号: 000071365
文書の種類: Solution
最終更新: 14 6月 2024
バージョン:  13
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。
文書のプロパティ
文書番号: 000071365
文書の種類: Solution
最終更新: 14 6月 2024
バージョン:  13
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。