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Dell VxRail: ESXi-Root-Konto ist für 900 Sekunden gesperrt, nachdem Anmeldeversuche fehlgeschlagen sind

概要: Dieser Artikel enthält eine Lösung, wenn der Remotezugriff für das lokale ESXi-Nutzerkonto "root" nach fehlgeschlagenen Anmeldeversuchen für 900 Sekunden gesperrt wird. Stellen Sie eine Verbindung zur iDRAC-Konsole her, um auf die ESXi-Shell zuzugreifen, und führen Sie dann den reset-Befehl aus. ...

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文書の内容


現象

Das Root-Konto eines oder mehrerer ESXi-Hosts ist aufgrund mehrerer fehlgeschlagener Anmeldeversuche gesperrt.

Die Verbindung zum Node kann nicht über SSH oder die Webnutzeroberfläche hergestellt werden.

Bestätigen Sie das Problem über die Verbindung der iDRAC-Konsole mit der ESXi-Shell.

In vCenter wird eine Warnmeldung ähnlich der folgenden angezeigt:

Remote access for ESXi local user account 'root' has been locked for 900s after 14 failed login attempts.

Meldung

Abbildung 1: Der Remotezugriff ist gesperrt.

Auf dem betroffenen Host sind Protokolle ähnlich den folgenden zu finden:

/var/log/vobd.log

2020-04-03T17:27:58.790Z: [GenericCorrelator] 8202447897096us: [vob.user.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
2020-04-03T17:27:58.790Z: [UserLevelCorrelator] 8202447897096us: [vob.user.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.
2020-04-03T17:27:58.791Z: [UserLevelCorrelator] 8202447897325us: [esx.audit.account.locked] Remote access for ESXi local user account 'root' has been locked for 900 seconds after 32 failed login attempts.

 

/var/log/auth.log

2020-04-03T17:29:06Z sshd[701694298]: Connection from 192.168.100.40 port 55682
2020-04-03T17:29:06Z sshd[701333862]: pam_tally2(sshd:auth): user root (0) tally 34, deny 5
2020-04-03T17:29:08Z sshd[701694298]: error: PAM: Authentication failure for root from 192.168.100.40
2020-04-03T17:29:08Z sshd[701694492]: pam_tally2(sshd:auth): user root (0) tally 35, deny 5
2020-04-03T17:29:08Z sshd[701694492]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.100.40  user=root
2020-04-03T17:29:10Z sshd[701694298]: error: PAM: Authentication failure for root from 192.168.100.40
2020-04-03T17:29:10Z sshd[701694298]: error: Received disconnect from 192.168.100.40 port 55682:3: com.jcraft.jsch.JSchException: Auth cancel [preauth]
2020-04-03T17:29:10Z sshd[701694298]: Disconnected from authenticating user root 192.168.100.40 port 55682 [preauth]

原因

Das Root-Kennwort für den Node wurde möglicherweise geändert, aber die Drittanbieter-Monitoringsoftware wurde nicht mit dem neuen Root-Kennwort aktualisiert.

Dies führt zu mehreren fehlgeschlagenen Anmeldungen (manchmal Hunderte oder sogar Tausende). Dadurch wird das Root-Konto für 15 Minuten gesperrt, was dazu führt, dass keine SSH-Verbindung zum Node hergestellt oder sich nicht bei der Node-Webnutzeroberfläche anmelden kann.

Sie können sich über die DCUI und die ESXi-Shell anmelden.

Ab vSphere 6.0 wird die Kontosperre für den Zugriff über SSH und über das vSphere Web Services SDK unterstützt. Das Direct Console Interface (DCUI) und die ESXi Shell unterstützen keine Kontosperrung. Standardmäßig sind maximal fünf fehlgeschlagene Versuche zulässig, bevor das Konto gesperrt wird. Das Konto wird standardmäßig nach 15 Minuten entsperrt.

解決方法

So beheben Sie dieses Problem:
  1. Stellen Sie eine Verbindung zur iDRAC-Konsole und dann zur ESXi-Shell her.
  2. Aktivieren Sie die Shell , indem Sie sich bei der DCUI anmelden und die ESXi-Shell unter den Troubleshooting-Optionen aktivieren.
  3. Sie können auch eine Cntrl-Alt-F1 , um auf die Shell zuzugreifen.
  4. Führen Sie nach Herstellung der Verbindung mit der ESXi-Shell die folgenden Befehle aus. Die Ausgabe sollte mit dem Screenshot unten übereinstimmen, mit der Ausnahme, dass der Eintrag "From" "unknown" lautet.
#pam_tally2 --user root
#pam_tally2 --user root --reset
#pam_tally2 --user root
ESXi-Befehle und -Ausgabe Abbildung 2: ESXi-Befehle und -Ausgabe
  1. Melden Sie sich nach dem Ausführen der obigen Befehle bei der Webnutzeroberfläche des ESXi-Node an.
  2. Gehen Sie zu Überwachen und dann zu Ereignisse. Es sollte eine IP-Adresse angezeigt werden, die versucht hat, sich anzumelden, aber als fehlgeschlagen aufgeführt wird.
  3. Sie müssen die Anwendung anhand der hier aufgeführten IP-Adresse identifizieren. Beenden Sie die Anwendung entweder oder konfigurieren Sie sie mit den richtigen Zugangsdaten.

その他の情報

Weitere Informationen finden Sie im VMware-Artikel ESXi-Kennwörter und KontosperrungDieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies..

Sehen Sie sich dieses Video zu ESXi Break Fix Unlock root User Account an.

Dauer: 00:04:56 (hh:mm:ss)
Wenn verfügbar, können Spracheinstellungen für Untertitel über das Symbol "Einstellungen" oder "CC" in diesem Videoplayer ausgewählt werden.

Verwandte Ressourcen
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文書のプロパティ


影響を受ける製品

VxRail, VxRail E560F

製品

VxRail E560F

最後に公開された日付

14 6月 2024

バージョン

13

文書の種類

Solution