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OMSA 8.4: O certificado é inválido no navegador — O certificado autoassinado com intervalo de datas inválido ou a expiração ocorre dentro de 36 dias.

概要: Saiba como resolver um problema com os certificados OMSA 8.4.

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現象

O Dell OpenManage Server Administrator (OMSA) 8.4 introduziu um bug em que o certificado SSL autoassinado gerado durante a instalação do OMSA é criado com uma data de validade anterior à data de criação.

原因

Isso faz com que a maioria dos navegadores da Web e scanners de segurança notifiquem o usuário de que o certificado é inválido e, portanto, não confiável. No entanto, a maioria dos navegadores ainda permitirá que o usuário prossiga com cautela.

Além disso, ao criar um certificado autoassinado de substituição na GUI ou CLI da Web do OMSA, a data de expiração do certificado resultante parece ser apenas algumas semanas após a criação, apesar de o OMSA permitir um período de validade de até 3.650 dias (10 anos).

解決方法

Esse certificado inválido só é criado durante a nova instalação do OMSA 8.4. Os upgrades das versões anteriores do OMSA manterão o certificado válido existente.
Há uma solução temporária manual para criar um certificado autoassinado adequado:


1) Em um shell do Windows: 

cd "C:\Arquivos de Programas\Dell\SysMgt\jre\bin" ou no shell do Linux: cd /opt/dell/srvadmin/lib64/openmanage/jre/bin/


2) Crie o certificado:

keytool -genkey --dname "CN=localhost, ou=Dell, O=Dell, c=FR" -alias dellcert --storepass Dell123 -validity 900 -keyalg RSA -keysize 2048 -sigalg SHA256withrsa --storetype pkcs12 -keystore delcert.pfx


3) Verifique os valores do certificado:

keytool -list -keystore delcert.pfx -storepass Dell123 -storetype PKCS12 -v


4) Faça com que a CLI do OMSA instale o certificado em seu keystore (que tem uma senha oculta)

omconfig preferences webserver attribute=uploadcert certfile=delcert.pfx type=pkcs12 password=Dell123 webserverrestart=true


対象製品

PowerEdge
文書のプロパティ
文書番号: 000063530
文書の種類: Solution
最終更新: 14 8月 2024
バージョン:  5
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