メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能
  • 「Company Administration(会社情報の管理)」では、お使いのDell EMCのサイトや製品、製品レベルでのコンタクト先に関する情報を管理できます。

Il riavvio degli agent di gestione in VMware ESXi per risolvere il problema della creazione di macchine virtuali potrebbe non riuscire perché l'agent non è in grado di recuperare le opzioni di creazione di VM dall'host

概要: Guida dettagliata per risolvere l'errore "VMware ESXi to resolve Virtual machine creation may fail because agent is unable to retrieve VM creation options from the host" quando un amministratore non è in grado di connettersi direttamente all'host ESXi o gestire in vCenter Server. ...

この記事は次に適用されます:   この記事は次には適用されません: 

現象

vCenter Server visualizza l'errore:

Virtual machine creation may fail because agent is unable to retrieve VM creation options from the host.
Avvertenza: Se LACP è configurato sulla rete vSAN, non riavviare gli agent di gestione sugli host ESXi che eseguono vSAN.
  • Il riavvio degli agent di gestione può influire sulle attività in esecuzione sull'host ESXi al momento del riavvio.
  • Verificare la presenza di eventuali problemi di storage prima di riavviare il servizio host daemon hostd o services.sh.

原因

Gli agent o i servizi sull'host ESXi potrebbero essere stati interrotti.

解決方法

Riavviare gli agent di gestione in ESXi utilizzando l'interfaccia utente di Direct Console (DCUI)

  1. Connettersi alla console dell'host ESXi.
  2. Premere F2 per personalizzare il sistema.
  3. Accedere come root.
  4. Utilizzare le frecce su e giù per passare a Troubleshooting Options e selezionare Restart Management Agents.
  5. Premere Invio.
  6. Premere F11 per riavviare i servizi.
  7. Al riavvio del servizio, premere Enter.
  8. Premere Esc per disconnettersi.
Nota: È inoltre possibile riavviare i servizi utilizzando Host Client. In Host Client, selezionare Host, quindi Manage, quindi Services, quindi selezionare il servizio da riavviare.


Riavviare gli agent di gestione in ESXi utilizzando la shell ESXi o SSH

  1. Accedere alla shell ESXi o SSH come root. Per abilitare la shell ESXi o SSH, consultare Utilizzo della shell ESXi in ESXi 6.x, 7.x e 8.x (2004746).Questo link ipertestuale indirizza a un sito web esterno a Dell Technologies.
  2. Riavviare il daemon dell'host ESXi e i servizi vCenter Agent utilizzando questi comandi:
/etc/init.d/hostd restart
/etc/init.d/vpxa restart
Attenzione:
  • Se LACP è abilitato e configurato, non riavviare i servizi di gestione utilizzando il comando services.sh. Riavviare invece i servizi indipendenti utilizzando il comando /etc/init.d/module restart.
  • Se il problema non viene risolto e si stanno riavviando tutti i servizi che fanno parte dello script services.sh, interrompere il tempo di inattività prima di procedere con lo script.
  • Se NSX è configurato nell'ambiente, non eseguire il comando /sbin/services.sh restart perché riavvia tutti i servizi sull'host ESXi.
  • Se è necessario riavviare gli agent di gestione sull'host ESXi, riavviare vpxa, host.d e fdm singolarmente.
  • Se è necessario eseguire anche il comando /sbin/services.sh restart perché il riavvio di ogni agent di gestione non funziona, eseguire la migrazione di tutte le VM dall'host ESXi e impostare l'host in modalità di manutenzione, se possibile.
  • Se non si è certi che NSX for vSphere sia installato su un host ESXi, eseguire questo comando per verificare:
    • esxcli software vib list --rebooting-image | grep esx-*
  • Cercare i seguenti VIB per determinare se NSX è installato sull'host ESXi:
vsip-esx
esx-vxlan
  • Se si utilizza una scheda grafica condivisa in un ambiente di visualizzazione (VGPU, vDGA, vSGA), non utilizzare services.sh. In questo modo si arresta il servizio xorg responsabile della grafica a livello di sistema operativo guest. L'estrazione della scheda grafica dal sistema operativo guest causa l'arresto anomalo del carico di lavoro VDI utilizzando la scheda grafica condivisa. Verificare di utilizzare una scheda grafica condivisa solo per riavviare hostde vpxa , se non si è in modalità di manutenzione.

Consultare l'articolo della Knowledge Base di VMware per maggiori informazioni: Riavvio degli agent di gestione in ESXi (1003490) Questo link ipertestuale indirizza a un sito web esterno a Dell Technologies.

その他の情報

Risorse
correlate Di seguito sono riportate alcune risorse consigliate correlate a questo argomento che potrebbero risultare interessanti:

対象製品

VxRail, VxRail Appliance Family

製品

VxRail 460 and 470 Nodes, VxRail G410, VxRail G Series Nodes, VxRail E Series Nodes, VxRail E560, VxRail E560F, VxRail G560, VxRail G560F, VxRail Gen2 Hardware, VxRail P Series Nodes, VxRail P470, VxRail P570, VxRail P570F, VxRail S Series Nodes , VxRail S470, VxRail S570, VxRail Software, VxRail V Series Nodes, VxRail V470, VxRail V570, VxRail V570F ...
文書のプロパティ
文書番号: 000057281
文書の種類: Solution
最終更新: 16 2月 2024
バージョン:  9
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。
文書のプロパティ
文書番号: 000057281
文書の種類: Solution
最終更新: 16 2月 2024
バージョン:  9
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。