メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能
  • 「Company Administration(会社情報の管理)」では、お使いのDell EMCのサイトや製品、製品レベルでのコンタクト先に関する情報を管理できます。

การรีสตาร์ทเอเจนต์การจัดการใน VMware ESXi เพื่อแก้ไขการสร้างเครื่องเสมือนอาจล้มเหลวเนื่องจากเอเจนต์ไม่สามารถดึงตัวเลือกการสร้าง VM จากโฮสต์ได้

概要: คําแนะนําทีละขั้นตอนเพื่อแก้ไข "VMware ESXi เพื่อแก้ไขการสร้างเครื่องเสมือนอาจล้มเหลวเนื่องจากเอเจนต์ไม่สามารถดึงตัวเลือกการสร้าง VM จากโฮสต์" เมื่อผู้ดูแลระบบไม่สามารถเชื่อมต่อโดยตรงกับโฮสต์ ESXi หรือจัดการภายใต้เซิร์ฟเวอร์ vCenter ...

この記事は次に適用されます:   この記事は次には適用されません: 

現象

เซิร์ฟเวอร์ vCenter แสดงข้อผิดพลาด:

Virtual machine creation may fail because agent is unable to retrieve VM creation options from the host.
คำเตือน: ถ้า LACP ถูกกําหนดค่าบนเครือข่าย vSAN อย่ารีสตาร์ทเอเจนต์การจัดการบนโฮสต์ ESXi ที่รัน vSAN
  • การรีสตาร์ทตัวแทนการจัดการอาจส่งผลกระทบต่องานใด ๆ ที่กําลังทํางานบนโฮสต์ ESXi ในขณะที่รีสตาร์ท
  • ตรวจสอบปัญหาการจัดเก็บใด ๆ ก่อนที่จะเริ่มบริการ daemon hostd โฮสต์หรือ services.sh.

原因

ตัวแทนหรือบริการบนโฮสต์ ESXi อาจหยุดทํางาน

解決方法

รีสตาร์ทตัวแทนการจัดการใน ESXi โดยใช้ Direct Console User Interface (DCUI)

  1. เชื่อมต่อกับ คอนโซลของโฮสต์ ESXi ของคุณ
  2. กด F2 เพื่อปรับแต่งระบบ
  3. เข้าสู่ระบบ เป็นราก
  4. ใช้ลูกศรขึ้นและลงเพื่อไปที่ ตัวเลือกการแก้ไขปัญหา แล้วเลือก รีสตาร์ทตัวแทนการจัดการ
  5. กด Enter
  6. กด F11 เพื่อเริ่มบริการใหม่
  7. เมื่อบริการรีสตาร์ท ให้กด Enter
  8. กด Esc เพื่อออกจากระบบ
หมายเหตุ: คุณยังสามารถเริ่มบริการใหม่โดยใช้โฮสต์ไคลเอ็นต์ ใน Host Client ให้เลือก Host จากนั้นเลือก Manage จากนั้น Services จากนั้นเลือก Service เพื่อรีสตาร์ท


รีสตาร์ทตัวแทนการจัดการใน ESXi โดยใช้ ESXi Shell หรือ SSH

  1. เข้าสู่ระบบ ESXi Shell หรือ SSH เป็น root สําหรับการเปิดใช้งาน ESXi Shell หรือ SSH โปรดดูที่ การใช้ ESXi Shell ใน ESXi 6.x, 7.x และ 8.x (2004746)ไฮเปอร์ลิงก์นี้จะนําคุณไปยังเว็บไซต์ภายนอก Dell Technologies
  2. รีสตาร์ท บริการ ESXi host daemon และ vCenter Agent โดยใช้คําสั่งเหล่านี้:
/etc/init.d/hostd restart
/etc/init.d/vpxa restart
ข้อควรระวัง:
  • หากเปิดใช้งานและกําหนดค่า LACP อย่าเริ่มบริการการจัดการใหม่โดยใช้ services.sh คําสั่ง รีสตาร์ทบริการอิสระโดยใช้ /etc/init.d/module restart คําสั่งแทน
  • หากปัญหาไม่ได้รับการแก้ไขและคุณกําลังรีสตาร์ทบริการทั้งหมดที่เป็นส่วนหนึ่งของ services.sh สคริปต์ให้หยุดทํางานก่อนที่จะดําเนินการกับสคริปต์
  • ถ้า NSX ถูกกําหนดค่าในสภาพแวดล้อม อย่าเรียกใช้ /sbin/services.sh restart คําสั่งเนื่องจากการดําเนินการนี้จะรีสตาร์ทบริการทั้งหมดบนโฮสต์ ESXi
  • หากคุณต้องรีสตาร์ทตัวแทนการจัดการบนโฮสต์ ESXi ให้รีสตาร์ท vpxahost.dและfdmทีละรายการ
  • หากคุณต้องเรียกใช้ /sbin/services.sh restart คําสั่งเนื่องจากการรีสตาร์ทเอเจนต์การจัดการแต่ละรายการไม่ทํางานให้ย้าย VM ทั้งหมดออกจากโฮสต์ ESXi และทําให้โฮสต์อยู่ในโหมดการบํารุงรักษาหากเป็นไปได้
  • หากคุณไม่แน่ใจว่ามีการติดตั้ง NSX for vSphere บนโฮสต์ ESXi ให้เรียกใช้คําสั่งนี้เพื่อตรวจสอบ:
    • esxcli software vib list --rebooting-image | grep esx-*
  • ค้นหา VIBs ต่อไปนี้เพื่อตรวจสอบว่ามีการติดตั้ง NSX บนโฮสต์ ESXi หรือไม่:
vsip-esx
esx-vxlan
  • หากใช้กราฟิกที่ใช้ร่วมกันในสภาพแวดล้อมมุมมอง (VGPU, vDGA, vSGA) อย่าใช้services.sh การดําเนินการนี้จะปิด xorg บริการที่รับผิดชอบกราฟิกในระดับระบบปฏิบัติการแขก ด้วยการริปกราฟิกออกจากระบบปฏิบัติการ Guest คุณจะทําให้เกิดความผิดพลาดของปริมาณงาน VDI ของคุณโดยใช้กราฟิกที่ใช้ร่วมกัน ตรวจสอบว่า คุณกําลังใช้กราฟิกที่ใช้ร่วมกันเพื่อรีสตาร์ทเท่านั้น hostdและ vpxa ถ้าคุณไม่ได้อยู่ในโหมดการบํารุงรักษา

ดูบทความ VMware KB สําหรับข้อมูลเพิ่มเติม: รีสตาร์ทตัวแทนการจัดการใน ESXi (1003490) ไฮเปอร์ลิงก์นี้จะนําคุณไปยังเว็บไซต์ภายนอก Dell Technologies

その他の情報

แหล่งข้อมูล
ที่เกี่ยวข้อง ต่อไปนี้เป็นแหล่งข้อมูลที่แนะนําเกี่ยวกับหัวข้อนี้ซึ่งอาจเป็นที่สนใจ:

対象製品

VxRail, VxRail Appliance Family

製品

VxRail 460 and 470 Nodes, VxRail G410, VxRail G Series Nodes, VxRail E Series Nodes, VxRail E560, VxRail E560F, VxRail G560, VxRail G560F, VxRail Gen2 Hardware, VxRail P Series Nodes, VxRail P470, VxRail P570, VxRail P570F, VxRail S Series Nodes , VxRail S470, VxRail S570, VxRail Software, VxRail V Series Nodes, VxRail V470, VxRail V570, VxRail V570F ...
文書のプロパティ
文書番号: 000057281
文書の種類: Solution
最終更新: 16 2月 2024
バージョン:  9
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。
文書のプロパティ
文書番号: 000057281
文書の種類: Solution
最終更新: 16 2月 2024
バージョン:  9
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。