Passer au contenu principal
  • Passer des commandes rapidement et facilement
  • Afficher les commandes et suivre l’état de votre expédition
  • Créez et accédez à une liste de vos produits

Diagnostisere og løse vanlige minneproblemer på en stasjonær Dell-PC

Résumé: Denne artikkelen inneholder informasjon om hvilke minneproblemer som kan oppstå, og hvordan du feilsøker dem på en stasjonær Dell-DATAMASKIN.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Cause

Årsakinformasjon er ikke tilgjengelig.

Résolution

Feilsøke minnet på stasjonær PC

Denne veiledningen omhandler minneproblemer på stasjonære PC-er og hvordan du feilsøker og løser minneproblemer. Feilsøking av minne er vanligvis inndelt i tre deler:

  • Diagnostikk
  • Maskinvare
  • Programvare

De vanligste minneproblemene du ser, er følgende:

  • Ingen POST med minnefeilkoder.

Diagnostikklamper cypher

(Figur 1 Fire LED-lamper)

Lamper

(Figur 2 Fargede LED-lamper for strømtilstand)

  • Datamaskinen er treg, er ikke tilgjengelig eller svarer ikke, for eksempel blåskjermfeil.

NMI-paritetsfeil

(Figur 3 Blåskjermfeil: NMI-paritetsfeil)

  • Feilmelding på skjermen om minneproblemer med stans, overkjøring, størrelse eller lesing.

Svchost-applikasjonsfeil

(Figur 4 Applikasjonsfeil)

Ikke mer minne

(Figur 5 Intern feil)

VMemory-feil

(Figur 6 Applet-feil)

  • Problemer med å installere programvare eller operativsystemer (OS).

Mesteparten av denne feilsøkingen utføres som en del av en spesifikk feilsøkingsveiledning for en bestemt feil. Denne artikkelen er en generell oversikt som kan være mer detaljert enn det du vanligvis ser.

Tilbake til toppen


Diagnostikk

Disse artiklene veileder deg gjennom diagnoselampene og -kodene for de ulike modellene.

  1. Det første du må gjøre er å sjekke at Pre-Boot System Assessment-diagnostikken (PSA) kan kjøre.

    Når datamaskinen er slått av, holder du nede Fn-tasten og strømknappen samtidig. Du kan også trykke raskt på F12-tasten når datamaskinen starter opp, og velge Diagnostics (Diagnostikk ) fra minnet som vises. Meldingen Diagnostic Boot Selected (Diagnostikkoppstart valgt) skal vises øverst til høyre på skjermen.

    Merknader:
    • Når du kan koble til Internett, kan du kjøre minnespesifikk diagnostikk. Gå til siden for nettbasert minnediagnostikk.
      Merknader:
      • Testen starter automatisk.
      • Du kan bli bedt om å installere eller oppdatere SupportAssist-programmet. I så fall følger du instruksjonene.
      • Testen kan ta 10–15 minutter, avhengig av maskinvaren i datamaskinen din.
    • Du kan også kjøre diagnostikk fra nettstedet vårt for kundestøtte.
      • "Hurtigtest" – Denne maskinvaretesten kan ta 10–15 minutter, avhengig av maskinvaren på datamaskinen.
      • "Full test" – Dette er en dyptgående test. Dette kan ta 40 minutter eller mer, avhengig av maskinvaren på datamaskinen.
      • Custom Component Test (Tilpasset komponenttest) – Velg én eller flere spesifikke maskinvaretester du vil kjøre.

        Utfør følgende trinn for å kjøre en bestemt test.

        1. Gå til Dell Support-nettstedet.
        2. Du får tre alternativer for å identifisere datamaskinen.

          Gjør ett av følgende:

          • Klikk på oppføringen for datamaskinen din under DENNE PC-EN.
            Merk: Hvis det ikke finnes en oppføring for datamaskinen din under DENNE PC-en, trykker eller klikker du på Last ned og installer SupportAssist, som automatisk identifiserer datamaskinen for deg. Følg instruksjonene for å laste ned og installere SupportAssist.
          • Angi service-ID, Dell EMC-produkt-ID eller modell. Klikk deretter på Søk-knappen, og velg datamaskinen din fra listen.
          • Rør eller klikk på Bla gjennom alle produkter: Du må velge hvilken type enhet du har, merkevarenavn og produktmodell.
            Merk: Hvis du vil ha mer informasjon, kan du se følgende artikkel i Dells kunnskapsbase: Slik finner du produktmodellen til Dell-datamaskinen din.
        3. Klikk på fanen DIAGNOSTICS (Diagnostikk).
        4. Klikk på Select individual components (Velg individuelle komponenter) under Custom Component Test (Egendefinert komponenttest).
        5. Merk av i boksen ved siden av én eller flere komponenter du vil teste.
        6. Trykk eller klikk på Kjør testen, og følg instruksjonene.
  2. Datamaskinen kjører maskinvarekontroller i ca. 15–20 minutter. Når disse er fullført, blir du spurt om du vil kjøre ytterligere minnetester som kan ta ytterligere 30 minutter+ Hvis PSA-ene bestås, kjører du ytterligere minnetester:

    1. Hvis alle testene bestås, kan du bla gjennom feilsøkingen av programvaren.

    2. Hvis de mislykkes, noterer du feilkoden og går videre til neste trinn.

  3. Når du har en feilkode, kan du se veiledningen for å se om du kan kjøre nyere, avansert diagnostikk på datamaskinen. Nyere diagnostikk identifiserer feilen i en minne-DIMM eller et spor på datamaskinen:

    1. Hvis diagnostikken er mulig og tilgjengelig på datamaskinen, kontakter du kundestøtten med resultatene av diagnostikken for å ta dette videre.

    2. Hvis diagnostikken ikke er mulig for datamaskinen, eller hvis du ikke kan oppdatere til dem, bør du gå til den harde feilsøkingen.

    Merk: Du kan sende inn Service-ID, ePSA-feil og valideringskode på siden SupportAssist systemytelsessjekk før oppstart (på engelsk) for å finne ut hva du skal gjøre videre.

Tilbake til toppen


Feilsøke maskinvare

Konseptet bak feilsøking av maskinvareminne er enkelt. Det dreier seg om utskifting av deler og tilgang til deler som du vet fungerer.

Alle stasjonære PC-er har tilgang til minnet fra et tilgangspanel eller deksel. Du finner den spesifikke metoden for datamaskinen i brukerveiledningen.

  1. Hvis du opplever en ingen POST-situasjon, er det første trinnet å fjerne minnet helt fra datamaskinen. Endres feilen?

    1. Hvis den gjør det, går du til trinn 2.

    2. Hvis den ikke gjør det, følger du veiledningen for ingen POST nedenfor.

  2. Har du en fungerende, lignende datamaskin eller et fungerende minne du kan sette inn i denne datamaskinen?

    1. Hvis svaret er ja, kan du bytte ut minnet fra denne enheten med det fungerende minnet og se hvor feilen går. Ta kontakt med kundestøtte for å ta saken videre med dem.

    2. Hvis svaret er nei, går du videre til neste trinn.

  3. De fleste stasjonære datamaskiner leveres for øyeblikket med én eller to minnemoduler. Vanligvis er det to fordi de fleste minner er utformet for å fungere bedre i par. Det neste trinnet er det samme uavhengig av hvor mange moduler du har. Ta én DIMM, og test den i alle minnekontakter/-spor. De fleste av våre stasjonære PC-er har fire minnekontakter/-spor fordelt på par som kalles banker. Noter resultatet, og gjør det samme med den andre DIMM-en hvis du har en. Gjenta dette trinnet for hver DIMM som er installert på datamaskinen. Endres problemet avhengig av hvilken DIMM eller kontakt som brukes?

    1. Ja. Hvis feilen følger en DIMM, eller hvis den holder seg i et bestemt spor på hovedkortet, har du identifisert feilen. Den gode nyheten er at du kan kjøre maskinen med redusert minne til du har meldt fra om feilen til teknisk støtte.

    2. Nei. Feilen er den samme uansett hvilken DIMM eller hvilket spor minnet er montert på. Feilen skyldes ikke minnet, eller både minnet og sporene er defekte. Derfor foreslår vi at du utfører trinn 2. Jeg anbefaler at du tar kontakt med teknisk støtte for å ta saken videre.

Tilbake til toppen


Feilsøke programvare

Feilsøking av minneproblemer i programvare tar relativt kort tid, og tar for det meste for seg virtuelt minne i stedet for fysisk minne.

  1. Du kan kjøre ytterligere minnediagnose i Windows. Du kan velge mellom flere velkjente tester, for eksempel Memtest. Vi vil sannsynligvis ta utgangspunkt i resultatene som allerede er kjørt i PSA-diagnostikken. Spesielt siden PSA-diagnostikken bruker Memtest-diagnostikk i testene sine. Hvis du får en feilmelding fra tredjepartsdiagnostikk, må vi kontrollere at de er kompatible, og at nøkkelen til feilkodene er tilgjengelig. Du bør hoppe over dette trinnet og gå videre til neste trinn.

  2. Hvis du vil utelukke feil med det virtuelle minnet, anbefaler jeg at du sjekker et par ting på PC-en din. Den første er å bekrefte at Windows håndterer det virtuelle minnet. Gå til kontrollpanel og ytelse i maskinvarevinduet, og kontroller innstillingene. Tilbakestill dem om nødvendig. Bekreft hvilken partisjon som det virtuelle minnet er tildelt fra? Datamaskinen tildeler plass på harddisken for å bytte minne fra det fysiske minnet. Informasjonen er på samme sted som du bekrefter at PC-en håndterer minnet. Kontroller partisjonen og sørg for at den har minst 6–10 GB ledig. De fleste sidevekslingsfiler er bare på 2–4 GB, men hvis PC-en håndterer dette, kan den endre størrelsen ved behov. Når du har angitt dette, tester du datamaskinen for å se om feilen vender tilbake. Hvis den gjør det, går du til neste trinn.

    Det virtuelle minnet kombinerer fysisk RAM med midlertidig plass på harddisken. Når det er lite RAM, flytter det virtuelle minnet data fra RAM til et område som kalles en sidevekslingsfil. Når data flyttes til og fra sidevekslingsfilen, får RAM nok kapasitet til å fullføre arbeidet.

    Jo mer RAM datamaskinen din har, jo raskere kjører programmene. Hvis mangelen på RAM reduserer hastigheten til datamaskinen, kan du bli fristet til å kompensere ved å øke det virtuelle minnet. Datamaskinen kan imidlertid lese data fra RAM mye raskere enn fra en harddisk, så du bør helle legge til mer RAM.

    Virtuelt minne

    Hvis datamaskinen mangler ram (Random Access Memory) som trengs for å kjøre et program eller en operasjon, bruker Windows virtuelt minne for å kompensere.

  3. Du kan overvåke bruken av minne via Oppgavebehandling og hendelsesloggunntak. Dette gjør det mulig å spore eventuelle programmer, prosesser eller enheter som sammenfaller med feilene. Er minnebruken høy? Hvis du kommer deg inn i Windows-miljøet for å overvåke disse, reduserer dette antallet problemer du må undersøke. Jeg har inkludert en kobling nedenfor til en startside med brukerveiledninger om disse metodene for hvert av de ulike operativsystemene.

    1. Oppgavebehandling viser høy minnebruk. Du trenger kanskje bare mer minne enn det som er installert for å gjøre alt arbeidet du ønsker å gjøre på datamaskinen. Dette innebærer å erstatte det opprinnelige minnet med større DIMM-er som du har kjøpt.

    2. Oppgavebehandling viser at problemet ligger i operativsystemet, et program eller en prosess. Det kan være lurt å kjøre en kostnadsfri tredjepartskontroll for skadelig programvare, for eksempel Malwarebytes. Hvis problemet vedvarer, gjenoppretter eller reinstallerer du operativsystemets versjon for å løse problemet.

Du kan kontakte kundestøtte på Internett via chat, Twitter og e-post, eller ringe til din lokale kundestøtte. Sørg for at nettstedet er satt til ditt sted hvis du går til nettstedet vårt for kundestøtte. Du kan klikke på koblingen «Contact US» (Kontakt OSS) for å få den nyeste informasjonen om hvordan du tar kontakt.

Tilbake til toppen

Informations supplémentaires

Produits concernés

Chromebox, Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, Fixed Workstations
Propriétés de l’article
Numéro d’article: 000126068
Type d’article: Solution
Dernière modification: 10 Oct 2024
Version:  10
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.