Passer au contenu principal
  • Passer des commandes rapidement et facilement
  • Afficher les commandes et suivre l’état de votre expédition
  • Créez et accédez à une liste de vos produits

Soporte para el módulo de servicio Dell iDRAC

Résumé: iDRAC Service Module (iSM) es un servicio de software ligero que integra mejor las funciones del sistema operativo (SO) con iDRAC y se puede instalar en los servidores PowerEdge de 12.ª generación y más recientes de Dell. El iSM proporciona información relacionada con el sistema operativo a la iDRAC y agrega funcionalidades como la replicación de eventos del registro del ciclo de vida (LC) en el registro del sistema operativo, la compatibilidad con WMI (incluido el almacenamiento), las alertas SNMP de iDRAC mediante el sistema operativo, el restablecimiento forzado remoto de iDRAC y el ciclo de apagado y encendido completo. En esta guía, se proporciona una descripción general de las funciones, cómo descargarlas e instalarlas, y recursos adicionales. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Módulo de servicio Dell EMC iDRAC

Módulo de servicio de Integrated Dell Remote Access Controller

  • Expande la administración de iDRAC en sistemas operativos del host compatibles
  • Proporciona al iDRAC información relacionada con el SO
  • Servicio ligero de software con espacio físico de host mínimo

El módulo de servicio de Integrated Dell Remote Access Controller (iDRAC) (iSM) es una aplicación de software ligera y opcional que se puede instalar en servidores PowerEdge. El iDRAC Service Module complementa las interfaces de iDRAC: Interfaz de usuario (IU), CLI de RACADM, Redfish y administración de servicios web (WS-MAN) con datos de supervisión adicionales La arquitectura del módulo de servicio de iDRAC utiliza la comunicación por conector IP y proporciona datos adicionales de administración de sistemas (SO/controlador de dispositivo) a iDRAC y presenta consolas de una a muchas con acceso a los datos de administración de sistemas a través de interfaces estándar del SO.

 
 

Características del módulo de servicio de iDRAC

Información del sistema operativo

Server Administrator comparte la información del sistema operativo y el nombre de host con iDRAC. El iSM proporciona información similar, como el nombre del SO host, información sobre la dirección IP del host del servidor, la versión del SO y el nombre de dominio calificado (FQDN) con iDRAC. También se muestran las interfaces de red en el SO host. De forma predeterminada, esta función de monitoreo está activada. Esta función está disponible incluso si Server Administrator está instalado en el SO host.

Replicación de registros de Lifecycle Controller en el sistema operativo

Replica los registros de Lifecycle Controller (LC) en los registros del SO. Todos los eventos que tienen la opción Registro del sistema operativo como destino (en la página Alertas o en las interfaces equivalentes RACADM o WSMAN) se replican en el registro del SO mediante iSM. Este proceso es similar a la replicación del registro de eventos del sistema (SEL) que ejecuta Server Administrator.

El conjunto predeterminado de registros que se incluirá en los registros del sistema operativo es el mismo que los registros configurados para las capturas/alertas de SNMP. Solo los eventos registrados en el registro de LC después de la instalación de iSM se replican en el registro del SO. Si Server Administrator está instalado, la función de monitoreo se desactiva para evitar la duplicación de entradas de SEL en el registro del SO.

Función de recuperación automática del sistema

La función de recuperación automática del sistema es un temporizador basado en hardware que se utiliza para restablecer el servidor si hay una falla de hardware. La función puede realizar operaciones de recuperación automática del sistema, como reiniciar, hacer un ciclo de encendido o apagado, o apagar después de un intervalo de tiempo especificado. Esta función se activa solo cuando el temporizador guardián del sistema operativo está desactivado. Si Server Administrator está instalado, la función de monitoreo se desactiva para evitar la duplicación de temporizadores guardianes.

Proveedores del Instrumental de administración de Windows

Los proveedores del Instrumental de administración de Windows disponibles con iSM exponen datos de hardware a través del Instrumental de administración de Windows (WMI). WMI es una extensión del modelo de controlador de Windows que proporciona una interfaz de sistema operativo a través de la cual los componentes del instrumento proporcionan información y notificaciones. WMI es una implementación Microsoft de los estándares Gestión Empresarial Basada en Web (WBEM) y Modelo de Información Común (CIM) desde la Fuerza de Tareas de Administración Distribuida (DMTF) para administrar el hardware del servidor, los sistemas operativos y las aplicaciones. Los proveedores de WMI ayudan con la integración en consolas de administración de sistemas, como Microsoft System Center, y permiten la administración de servidores de Microsoft Windows mediante scripts.

Recopilación de SupportAssist

La función de recopilación de SupportAssist en iDRAC recopila información sobre el hardware, el sistema operativo y los datos de las aplicaciones pertinentes, y comprime esta información. Con iSM 2.0 o versiones posteriores, la herramienta OS Collector recopila automáticamente información pertinente del sistema operativo y del hardware, pero debe hacerlo de forma manual. 

Soporte para la extracción de dispositivos SSD PCIe NVMe

Extracción de un dispositivo de estado sólido (SSD) Non-Volatile Memory Express (NVMe) Peripheral Component Interconnect Express (PCIE) sin apagar ni reiniciar el sistema. Cuando extrae un dispositivo, se deben detener todas las actividades asociadas con el dispositivo para evitar la pérdida de datos. Para evitar la pérdida de datos, utilice la opción Preparar para extraer, la cual detiene todas las actividades en segundo plano asociadas con el dispositivo, después de lo cual puede extraer el SSD PCIe NVMe.

Restablecimiento forzado remoto de iDRAC

Utilice iDRAC para monitorear los servidores compatibles y ver problemas críticos de hardware, firmware o software del sistema. Con poca frecuencia, es posible que una iDRAC deje de responder. Anteriormente, un cliente debía apagar el servidor desconectando la alimentación del servidor. Ahora, mediante la función Restablecimiento forzado remoto de iDRAC, si un iDRAC deja de responder, realice una operación remota de restablecimiento de iDRAC sin necesidad de apagar el servidor. Se necesitan privilegios de administrador en el SO del host para usar esta función. De manera predeterminada, la función Restablecimiento forzado remoto de iDRAC está activada.

Acceso a iDRAC mediante el sistema operativo host

Utilice los servidores Dell PowerEdge para administrar el hardware o firmware de un dispositivo mediante iDRAC configurando una red dedicada de iDRAC. A través del puerto de red dedicado, acceda a las interfaces de iDRAC, como la interfaz de usuario, WSMAN, RACADM y el cliente Redfish.

Como requisito previo para administrar el hardware o firmware, debe tener una conexión dedicada entre un dispositivo y la interfaz de iDRAC compatible. El acceso a iDRAC mediante la función del sistema operativo host permite conectarse a una interfaz de iDRAC desde una IP o host del sistema operativo, independientemente de la conexión, entre un dispositivo y una red dedicada de iDRAC. Esta función le permite monitorear el hardware o firmware, incluso si iDRAC no está conectado a los servidores.

Compatibilidad dentro de banda para las alertas SNMP de iDRAC

Mediante iDRAC, una herramienta de monitoreo y administración de servidores fuera de banda, las capturas/alertas de SNMP se pueden registrar en el registro. Sin embargo, desde la perspectiva de una administración de sistemas del SO host que utiliza un agente dentro de banda, se suele preferir más la alerta SNMP recibida desde el SO host que las capturas recibidas desde iDRAC. Cuando se recibe una alerta SNMP desde iDRAC, es difícil determinar el origen de la alerta, ya que proviene de la IP de un iDRAC y no de la IP del sistema.

A partir de iSM 2.3, puede recibir alertas SNMP desde el sistema operativo host, que es similar a las alertas de iDRAC.

Habilitar WSMAN de forma remota

Con la función de información de WMI, puede conectarse al espacio de nombres de WMI de Microsoft Windows del host para supervisar el hardware del sistema. La interfaz WMI en el host está habilitada de manera predeterminada y se puede acceder a ella de manera remota. Sin embargo, si desea acceder a las interfaces WMI mediante el adaptador WMI de WINRM, debe habilitarlo manualmente, ya que no está habilitado de manera predeterminada. Con esta función, puede acceder de manera remota a los espacios de nombres WMI de WINRM habilitándolos durante la instalación.

Nota: System Management no agregará ninguna característica nueva a WSMAN.

Instalación de fábrica del módulo de servicio iDRAC para Microsoft Windows (opcional para el cliente)

iSM ahora se puede instalar de fábrica para el sistema operativo Microsoft Windows. Al tener iSM preinstalado, puede acceder rápidamente a registros críticos y documentos de soporte. Cuando se selecciona una instalación de fábrica del sistema operativo Microsoft Windows, puede optar por instalar el iSM entre las opciones disponibles.

  • iSM - Habilitado: proporciona la instalación de fábrica de iSM en el sistema operativo Windows
  • iSM - Deshabilitado - Los clientes que no deseen tener iSM instalado en el SO deben seleccionar esta opción

Monitoreo S.M.A.R.T

La función Monitoreo S.M.A.R.T es compatible con unidades de disco duro habilitadas con SATA en modo AHCI. Tiene la funcionalidad integrada de monitorear las alertas S.M.A.R.T a través de los métodos de auditoría compatibles con iDRAC para discos duros en la controladora de chipset SATA. Anteriormente, cualquier utilidad de código abierto monitoreaba las alertas, a fin de monitorear las unidades de disco duro configuradas en el modo RAID.

FullPowerCycle

La función FullPowerCycle proporciona una manera para restablecer la alimentación auxiliar del servidor. Una cantidad cada vez mayor de hardware del servidor utiliza alimentación auxiliar del servidor. Para solucionar algunos problemas del servidor, debe desconectar físicamente el cable de alimentación del servidor para restablecer el hardware que utiliza alimentación auxiliar. Esto hace que alguien tenga que desenchufar/enchufar físicamente los cables de alimentación, lo que genera un costo y molestias significativos para los clientes y el personal de soporte. La función FullPowerCycle permite que el administrador conecte o desconecte la alimentación auxiliar de forma remota sin visitar el centro de datos. Esta función es compatible con iDRAC9.

 

Correlación de eventos de software con fallas de hardware para Microsoft S2D

El registro de eventos para los eventos o las alertas del pool de almacenamiento de hardware se monitorea a través del iSM con la función de correlación de almacenamiento del servidor. El subsistema de almacenamiento del servidor se supervisa cuando se utilizan las controladoras de almacenamiento de Dell en modo RAID. Sin embargo, en Storage Spaces (SS) o Storage Space Direct (S2D), el subsistema de almacenamiento del servidor se monitorea en un modo de paso o el chipset SATA se utiliza para crear el pool de almacenamiento. Con esta función, las alertas definidas por hardware cubiertas por el registro de Lifecycle y las alertas definidas por software cubiertas por los registros del sistema operativo se fusionan y las alertas se registran en los registros de iDRAC Lifecycle. Esta función se instala con el paquete del módulo de servicio de iDRAC y está activada de manera predeterminada. El usuario puede cambiar las preferencias en la configuración de iDRAC. Como parte del monitoreo, el iSM audita los registros en busca de posibles fallas y advertencias. iSM incorpora los eventos de correlación de SS en el host a un evento de LC equivalente.

Despacho automático de disco SupportAssist de iSM

Como parte de las alertas predictivas, si el servidor coincide con uno de los siguientes eventos de SNMP: PDR16 y PDR63, se envía una recomendación desde el soporte de Dell por correo electrónico sobre la orden de trabajo de la falla predictiva o un bloque de disco dañado, como SSD, sujeto a los términos y condiciones de licenciamiento vigentes. Para realizar pedidos de trabajo, se requiere una dirección de servicio al soporte de Dell. Esta función solo está disponible en los sistemas operativos Windows y Linux.

Iniciador de interfaz de usuario de iDRAC

Inicie la interfaz de usuario de iDRAC desde el sistema local; para ello, haga doble clic en el icono del iniciador de la interfaz de usuario de iDRAC. La página de inicio de sesión de la interfaz de usuario de iDRAC se abre en el navegador predeterminado y las credenciales de iDRAC se pueden utilizar para iniciar sesión en la página de inicio de iDRAC. Esto solo se admite en los sistemas operativos Microsoft Windows.

Inicio de sesión único (SSO) en la interfaz de usuario de iDRAC desde el escritorio de los administradores del sistema operativo host

La función de inicio de sesión único (SSO, por sus siglas en inglés) permite que un administrador de sistemas operativos autenticado acceda de forma directa a la interfaz web de iDRAC sin necesidad de iniciar sesión con credenciales de administrador de iDRAC independientes.

Comunicación entre iSM y iDRAC con seguridad mejorada mediante el protocolo TLS

A partir de iSM 3.4, la comunicación de datos entre iSM y iDRAC se produce a través de conectores INET USBNIC protegidos por TLS. Esto garantiza la protección de todos los datos que viajan desde iDRAC a iSM mediante USBNIC. iSM y iDRAC usan certificados autofirmados para controlar la autenticación. Los certificados autofirmados tienen 10 años de validez. Se generan certificados autofirmados nuevos cada vez que instala iSM.

 



Panel de iDRAC9

Mejoras en Dell iDRAC Service Module

Dell mejora constantemente su Dell iDRAC Service Module.


Plataformas
El módulo de servicio del iDRAC 5.4.0.0 es compatible con los siguientes servidores PowerEdge 14G, 15G y 16G en todos los sistemas operativos compatibles.







Nuevas funciones de Dell iDRAC Service Module 5.4.0.0

  • La configuración de RAID de software admite el cambio de nombre, la reconfiguración y la visualización del tamaño máximo para reconfigurar el disco virtual.
  • Compatibilidad con nuevos SO: Ubuntu Server 24.04


Características nuevas y mejoradas

Área funcional Descripción de la función Resumen de los beneficios
RAID de software Configuración de RAID de software Mejora para soporte de las funciones de Get y Traps de SNMP en banda en el entorno de contenedor de iSM.


Hipervisores y sistemas operativos Enterprise de 64 bits compatibles:

  • Windows Server 2022
  • Windows Server 2019
  • Red Hat Enterprise Linux 8.10
  • Red Hat Enterprise Linux 9.4
  • SUSE Linux Enterprise Server 15SP6
  • VMware vSphere (ESXi) 8.0 U3
  • VMware vSphere (ESXi) 7.0 U3
  • Ubuntu Server 24.04
  • Compatibilidad con la comunidad Debian 11
     


RTOS compatibles en servidores PowerEdge R650, PowerEdge R660, PowerEdge R750, PowerEdge R760, PowerEdge XR11, PowerEdge XR12, PowerEdge XR5610 y PowerEdge XR8000:

  • Red Hat Enterprise Linux 8.10
  • Red Hat Enterprise Linux 9.4
  • SUSE Linux Enterprise Server 15 SP6


Sistemas operativos cliente soportados en Precision R7920 y Precision R7960:

  • Microsoft Windows 10 22H2
  • Microsoft Windows 11 21H2/22H2/23H2
  • Red Hat Enterprise Linux 98.6
  • Ubuntu Desktop 24.04


Consulte la versión más reciente de las Notas de la versión del módulo de servicio de Dell EMC iDRAC para obtener la lista completa de las mejoras y limitaciones, los problemas resueltos y los problemas conocidos.

Consulte el Módulo de servicio de iDRAC de Dell Technologies para obtener la lista completa de todas las versiones de iSM.

Cause


Configuración de iDRAC9

Descargar e instalar el módulo de servicio Dell iDRAC

Dell iDRAC Service Module se soporta en la mayoría de las versiones de los sistemas operativos Microsoft Windows, Linux y ESXi para los servidores PowerEdge con iDRAC7, iDRAC8 e iDRAC9. Consulte Plataformas soportadas para obtener información adicional sobre las plataformas y los sistemas operativos soportados.

La versión específica de iSM para el sistema varía según el modelo del servidor y el sistema operativo instalado. Para descargar la versión más reciente de iSM:

  • Vaya a Dell.com/support y seleccione el modelo del servidor o ingrese la etiqueta de servicio.
  • Seleccione Controladores y descargas.
  • Seleccione el sistema operativo en Operating System según su sistema
  • Palabra clave: iSM
  • Descargue la revisión más reciente proporcionada para el módulo de servicio Dell iDRAC

Consulte la Guía del usuario de Dell Technologies Service Module para cada versión específica y, a continuación, el tema Instalación de iDRAC Service Module para obtener información sobre los requisitos de software, los requisitos del sistema y los pasos para instalar, actualizar y desinstalar iSM.

 
 

Résolution

Recursos para el módulo de servicio Dell iDRAC

Comunidad

Participe en la comunidad Administración de sistemas para buscar lo siguiente:

  • Paneles para publicar preguntas y respuestas
  • Blogs para leer e ingresar comentarios sobre artículos
  • Intercambios de ideas para mejorar productos y votar por las ideas que publicaron otros miembros de la comunidad
  • Y mucho más…

Documentación

Consulte la documentación más reciente en Dell iDRAC Service Module .

Documentación técnica

Guía de configuración de seguridad del módulo de servicio Dell iDRAC


Guía de configuración de seguridad de 29 páginas de enero de 2022

Este documento describe las configuraciones de seguridad relacionadas con el módulo de servicio de Dell iDRAC (iSM) y su instalación, configuración y funcionalidad en el sistema operativo host.

Leer la guía de configuración de seguridad

Módulo de servicio de iDRAC: funcionalidades basadas en SO para la administración fuera de banda con iDRAC9


Documentación técnica de doce páginas de mayo de 2021

Resumen de las mejoras más recientes que iDRAC Service Module (iSM) proporciona a la administración fuera de banda con iDRAC9 para los clientes en los servidores PowerEdge de Dell 14 y 15.ª generación.

Leer la documentación técnica

Módulo de servicio de iDRAC: acceso de iDRAC a través del sistema operativo del host


Documento técnico de 17 páginas
Enero de 2017
En esta documentación técnica, se proporciona información sobre el uso y la solución de problemas de acceso a iDRAC mediante las funciones del sistema operativo host en iDRAC Service Module v2.3 o posterior.

Lea la documentación técnicaIcono de descarga

Módulo de servicio iDRAC: habilitar alertas SNMP de iDRAC dentro de banda


Enero de 2017
Libro blanco de trece páginas
En esta documentación técnica, se proporciona información sobre el uso, la configuración y la solución de problemas de las alertas SNMP de iDRAC dentro de banda en iDRAC Service Module v2.3 en adelante.

Leer la documentación técnica Icono de descarga

Módulo de servicio de iDRAC: cómo realizar un restablecimiento forzado de CPU en iDRAC


Julio de 2016
Libro blanco de ocho páginas
En esta documentación técnica, se proporciona información acerca del uso y la solución de problemas en la característica Restablecimiento forzado de CPU de iDRAC en iDRAC Service Module v2.3 en adelante.

Leer la documentación técnica Icono de descarga

Módulo de servicio iDRAC 2.1 (mín.) en sistemas operativos Linux Ubuntu y Debian


Septiembre 2015
Libro blanco de diecinueve páginas
En este documento técnico, se proporciona información sobre el uso y la solución de problemas en el módulo de servicio de iDRAC v2.1 en adelante en los sistemas operativos Ubuntu y Debian Linux.

Lea el documento técnicoIcono de descarga

Módulo de servicio iDRAC: Instrumental de administración de Windows


Abril de 2015
Libro blanco de diecisiete páginas
En esta documentación técnica, se aborda el uso del módulo de servicio iDRAC para monitorear los diversos perfiles de hardware a través de las interfaces de cliente del Instrumental de administración de Windows (WMI), como Windows PowerShell, la línea de comandos del Instrumental de administración de Windows, el cliente Windows Remote Management (WINRM) y WBEMTEST.

Lea el documento técnicoIcono de descarga

Videos

Cómo instalar el módulo de servicio del iDRAC mediante la interfaz de usuario del iDRAC

 

Obtenga información sobre cómo instalar el módulo de servicio de iDRAC desde la interfaz de usuario de iDRAC.

Noviembre del 2017

Cómo realizar una recopilación de SupportAssist en el módulo de servicio iDRAC 3.0.1

 

Obtenga información sobre cómo realizar la recopilación de SupportAssist mediante el módulo de servicio de iDRAC 3.0.1.

Noviembre del 2017

Habilitación del acceso a iDRAC mediante el sistema operativo host en Microsoft Windows en iSM 2.4

 

Obtenga información sobre cómo activar y configurar el acceso a iDRAC mediante la función del sistema operativo host en Microsoft Windows.

Julio del 2017

Instalar el módulo de servicio iDRAC en el SO Microsoft Windows Nano

 

Obtenga información sobre cómo instalar el módulo de servicio del iDRAC en sistemas operativos Microsoft Windows Nano.

Julio del 2017

Activación del acceso a iDRAC mediante la característica del sistema operativo host en Linux en iSM 2.4

 

Obtenga información sobre cómo habilitar el acceso iDRAC en banda para sistemas Linux.

Julio del 2017

Visualizar capturas SNMP de iDRAC recibidas desde el SO del host en Linux en iSM 2.4

 

Obtenga información sobre cómo ver las capturas SNMP de iDRAC recibidas desde el SO del host en sistemas operativos Linux.

Julio del 2017

Monitorear servidores Dell a través del módulo de servicio iDRAC mediante WMI

 

Se describe el proceso para monitorear servidores Dell a través del módulo de servicio iDRAC (iSM) mediante el Instrumental de administración de Windows (WMI) para Dell Server Management Pack Suite versión 6.3 en un entorno Microsoft System Center Operations Manager o SCOM.

Octubre 2024

Produits concernés

iDRAC Service Module

Produits

iDRAC7, iDRAC8, iDRAC9, Lifecycle Controllers
Propriétés de l’article
Numéro d’article: 000178050
Type d’article: Solution
Dernière modification: 16 Oct 2024
Version:  21
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.