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Precision or OptiPlex Systems Give "Error Allocating Mem BAR for PCI Device" Errors During POST

Résumé: This article provides information about an error "Error allocating Mem BAR for PCI device" seen during POST on OptiPlex and Precision systems.

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Contenu de l’article


Symptômes

Precision or OptiPlex Systems Give "Error Allocating Mem BAR for PCI Device" Errors During POST

A user may report that they receive an error during the Power On Self-Test (POST) routine on an OptiPlex or Precision system.

The error, "Error allocating Mem BAR for PCI device," occurs when attempting to use multiple PCI cards of the same type, including video, audio, or Network cards. The system is unable to allocate DMA, I/O addresses or IRQs across the multiple PCI\PCIe devices.

Cause

Possible Causes

This issue may be caused by one of the following:

  1. A Faulty Device
  2. A BIOS or NVRAM Issue
  3. Faulty PCI Slot or Chipset on the Motherboard

1. A Faulty Device

One of the PCI cards may be faulty. If possible, replace each card one at a time with a verified working card of the same type.

Also check for Firmware updates for your card, this can usually be found on the Manufacturers website for your particular card.


2. A BIOS or NVRAM Issue

Ensure that your system has the latest version of the BIOS. Check the Dell Support Site and download the latest BIOS version for your system.

Another area which may cause this issue is within the Non-Volatile Random Access Memory (NVRAM) which stores information relating to devices installed on your system. By resetting the NVRAM, this allows the system to search for all devices again and reinitialize the information held in memory.

Note: For further information about clearing the NVRAM and updating the BIOS, see the following article: How to Perform a BIOS or CMOS Reset and Clear the NVRAM on Dell Computers

3. A Faulty PCI Slot or Chipset on the Motherboard

An issue with a faulty PCI slot on the Motherboard or an issue with the Chipset.
Check the Dell Support Site and download the latest chipset version for your system.

To troubleshoot the PCI slot on the Motherboard, proceed as follows:

  1. Remove all PCI cards from the system.

  2. Select one card and install into the first slot and test by powering on the system.

  3. Remove the first card and install into the second slot of the system. Test by powering on the system.

  4. Continue by moving the card into each slot and testing the functionality of the card in each slot.

  5. Perform the above checks with each card.

  6. If the test results are inconclusive, install two cards and move each card into different slots and test after each permutation.

Résolution

If you find one of the PCI slots are indeed faulty. Contact Dell Technical Support with your findings and for advice on how to proceed.

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Propriétés de l’article


Produit concerné

OptiPlex, Fixed Workstations

Dernière date de publication

21 août 2023

Version

6

Type d’article

Solution