Symptômes
Una máquina con Windows que es miembro de un dominio de Active Directory muestra el siguiente error cuando un usuario intenta iniciar sesión en el dominio. A continuación, el usuario regresa al indicador de inicio de sesión, por lo que no es posible iniciar sesión en el dominio.
The trust relationship between this workstation and the primary domain failed.
Cause
Este error se produce cuando se daña el canal seguro entre el equipo afectado y Active Directory. El canal seguro es el mecanismo mediante el cual los equipos unidos a un dominio se comunican de manera segura con las controladoras de dominio y se basa en la contraseña asociada con una cuenta de computadora.
Cada computadora unida a un dominio tiene una cuenta en Active Directory y cada cuenta de computadora tiene una contraseña asociada. Estas contraseñas de cuenta de computadora son independientes de las contraseñas de cuenta de usuario y se administran, sincronizan y actualizan automáticamente sin necesidad de interacción del usuario. Sin embargo, en algunas situaciones, la propia copia de la contraseña en la computadora deja de estar sincronizada con la copia almacenada en Active Directory. Cuando esto sucede, no se puede establecer el canal seguro y se muestra el error anterior cuando un usuario intenta iniciar sesión en el dominio.
Résolution
La manera más rápida de resolver este problema es agregar el equipo afectado a un grupo de trabajo para eliminarlo del dominio y, a continuación, volver a agregarlo al dominio. Esto se puede lograr mediante los siguientes pasos:
Nota: Los siguientes pasos suponen que el equipo afectado se puede eliminar del dominio sin consecuencias adversas. Dependiendo de la función funcional de la máquina y del software instalado en ella, es posible que esto no sea cierto. Además, estos pasos requieren el inicio de sesión en una cuenta administrativa local en el equipo afectado. Si no es posible iniciar sesión en una cuenta administrativa local, es probable que la única opción sea restaurar el sistema desde un respaldo.
- Inicie sesión en una cuenta administrativa local en el equipo afectado.
- Inicie la ventana Propiedades del sistema. Según la versión de Windows que se ejecuta en el equipo, existen varias maneras de lograr esto.
- En Windows Server, inicie el Administrador del servidor, haga clic en Servidor local en el panel izquierdo y haga clic en el nombre del dominio en el panel principal.
- En un cliente de Windows, haga clic en el icono Inicio y comience a escribir configuración avanzada del sistema. Seleccione Ver la configuración avanzada del sistema cuando aparezca la opción.
- En la pestaña Nombre del equipo, haga clic en el botón Cambiar.
- Seleccione Grupo de trabajo y escriba el nombre de un grupo de trabajo. El nombre específico no importa, ya que se trata de un grupo de trabajo temporal. Haga clic en Aceptar.
- Haga clic en Aceptar para confirmar los cuadros de diálogo que se muestran.
- Haga clic en Cerrar para cerrar la ventana Propiedades del sistema. Reinicie la computadora cuando pueda hacerlo.
- Cuando se le solicite iniciar sesión, inicie sesión en la misma cuenta administrativa local que antes.
- Inicie la ventana Propiedades del sistema.
- En la pestaña Nombre del equipo, haga clic en el botón Cambiar.
- Seleccione Dominio y escriba el nombre del dominio de Active Directory. Haga clic en Aceptar.
- Proporcione las credenciales de una cuenta de usuario de dominio que tenga permiso para agregar la computadora al dominio. Haga clic en Aceptar.
- Haga clic en Aceptar para confirmar los cuadros de diálogo que se muestran.
- Haga clic en Cerrar para cerrar la ventana Propiedades del sistema. Reinicie la computadora cuando pueda hacerlo.
- En el mensaje de inicio de sesión, confirme que ahora puede iniciar sesión en una cuenta de dominio sin recibir un error.
Produits concernés
Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2