Passer au contenu principal
  • Passer des commandes rapidement et facilement
  • Afficher les commandes et suivre l’état de votre expédition
  • Créez et accédez à une liste de vos produits

Integrated Dell Remote Access Controller(iDRAC)をリセットする方法

Résumé: この記事では、Integrated Dell Remote Access Controller (iDRAC)をローカルおよびリモートの両方でリセットする方法について説明します。これには、リセット、デフォルトへのリセット、お客様の設定へのリセットが含まれます。

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Integrated Dell Remote Access Controller (iDRAC)は、システム プロファイル設定および帯域外管理を行います。さまざまな理由により、iDRACが応答しなくなることがあります。応答しないiDRACの症状は次のとおりです。

  • RACADMコマンドは、「ERROR: Unable to perform requested operation」を返す
  • iDRACへのSSH/Telnetアクセスなし(接続試行がタイムアウト)
  • iDRACにブラウザでアクセスできない
  • iDRAC IPアドレスへのpingが失敗する

Cause

さまざまな理由により、iDRACが応答しなくなることがあります。Dell Technologiesでは、利用可能な最新のiDRACファームウェアを使用してシステムを最新の状態に保つことをお勧めします。これにより、最高のパフォーマンスと最新のセキュリティ アップデートと修正が保証されます。iDRACのアップデートでは、ホストを再起動する必要はありません。これにより、インプレース アップデートが可能になります。サーバー モデルのiDRACファームウェア バージョンは、iDRACを搭載した他のサーバー モデルとは異なる場合があります。お使いのシステム用の最新のiDRACファームウェアをダウンロードするには、次の手順に従います。

  1. Dellサポート サイトに移動して、サーバー モデルを選択するか、サービス タグを入力します。
  2. [ ドライバーおよびダウンロード ]タブを選択します。
  3. [ iDRAC with Lifecycle Controller ]カテゴリーを選択します。
  4. 必要に応じて、お使いのシステムの オペレーティング システム を選択します。
  5. iDRAC with Lifecycle Controllerファームウェアに提供されている最新バージョンをダウンロードします。
Dell PowerEdgeサーバーのファームウェアとドライバー のアップデートには、iDRACファームウェアをアップデートするための複数の方法のリストが記載されています。

Résolution

iDRACは、 システム識別ボタンiDRAC WebインターフェイスiDRACサービス モジュールRACADMを使用してリセットできます。詳細については、該当するセクションをクリックしてください。

システム識別ボタン

iDRACを搭載したシステムの場合、「 i」と マークされた小さなボタン(図1図2)は通常、システムの前面と背面にあります。このiボタンは、システム識別ボタンです。オペレーティングシステムを再起動せずに iDRAC をリセットするには、 システム識別 ボタンを少なくとも 16 秒間押し続けます。冷却ファンが最大速度で回転を始め、前面LCD(ある場合)が消灯したら、ボタンを離します。これで、保存されている設定を何も変更せずにiDRACがリスタートします。リモート コントローラーが再起動するまで、1分以上かかる場合があります。

PowerEdge R640サーバーのiDRACのiボタン
図1: PowerEdge R640サーバーのiDRAC iボタン

PowerEdge T620サーバーのiDRACのiボタン
図2: PowerEdge T620サーバーのiDRAC iボタン

iDRAC Webインターフェイス

リセットは、 iDRAC9 WebインターフェイスiDRAC7およびiDRAC8 Webインターフェイスで異なる方法で実行されます。詳細については、該当するiDRACをクリックしてください。

iDRAC9 Webインターフェイス

  1. iDRAC Webインターフェイスに接続します。
  2. ユーザー名とパスワードを入力して、インターフェイスにログインします。
  3. Maintenance]タブをクリックします。
  4. Diagnostics]を選択します
  5. [ iDRACのリセット ]をクリックしてiDRACをリセットするか、[ iDRACの再起動 ]をクリックしてiDRACをリセットします。
注:お使いの環境で使用できるリセット ボタンは、iDRACファームウェアのバージョンによって異なる場合があります。

iDRAC9の[iDRACのリセット]ボタン
図3:iDRAC9の[iDRACのリセット]ボタン

iDRACの再起動ボタン
図4:iDRACの再起動ボタン

  1. または、[Reset iDRAC to Default Settings]をクリックして、iDRACをデフォルト設定にリセットします。[Reset iDRAC to Default Settings]をクリックすると、[Reset iDRAC to factory default]ウィンドウが表示されます。このアクションは、iDRACを工場出荷時のデフォルト設定にリセットします。次のオプションのいずれかを選択します。
    • [Preserve user and network settings.]
    • [Discard all settings and reset the users to shipping value (root/shipping value).]
    • [Discard all settings and reset username and password.]
    • [Discard all settings and set to Custom default configuration (Custom configuration file must be uploaded).]
  2. 警告メッセージが表示されます。[ OK ]をクリックして続行します。
注:また、この画面から直接iDRACコマンドラインを入力することもできます。

iDRAC7およびiDRAC8 Webインターフェイス

  1. iDRAC Webインターフェイスに接続します
  2. ユーザー名およびパスワードを入力してインターフェイスにログインします。
  3. 概要画面の右下隅に[クイック起動タスク]が表示されます。
  4. Reset iDRAC]をクリックします。
  5. アクションを確定します。

iDRAC7およびiDRAC8の[Reset iDRAC]オプション
図5:iDRAC7およびiDRAC8の[Reset iDRAC]オプション

Integrated Dell Remote Access Controller(iDRAC)をリセットする方法

再生時間:00:01:24(hh:mm:ss)
使用可能な場合は、このビデオ プレーヤーのCCアイコンを使用して、字幕(字幕)言語設定を選択できます。

iDRACサービス モジュール

iDRAC Service Module (iSM)は、iDRAC7、iDRAC8、およびiDRAC9を実行しているPowerEdgeサーバーにインストールできる軽量のソフトウェア アプリケーションです。iSM 2.3(以降)を使用すると、管理者はiDRACが応答しないときにiDRACをリモートでリセットすることができます。iDRACサービス モジュールを使用したiDRACのリセットは、 WindowsLinuxVMware ESXiオペレーティング システムのいずれを使用する場合でも、実行方法が異なります。詳細については、該当するオペレーティング システムをクリックしてください。

Windows

iDRACサービス モジュールには、WINDOWSオペレーティング システム内からiDRACをリセットできるWMIメソッド、PowerShellメソッドおよびプログラム メニューのショートカット方法が用意されています。詳細については、該当するオペレーティング システムをクリックしてください。

WMIメソッド

これは、Windows Management Instrumentation(WMI)コマンドを使用してローカルまたはリモートで呼び出すことができます。

WMIコマンドを使用してiDRACをリセットする手順は、次のとおりです。

  1. ホスト オペレーティング システムに iDRACサービス モジュール をインストールします。
  2. 管理者権限で コマンド プロンプト を開きます。
  3. ローカル WinRM コマンドまたはリモート WinRM コマンドのいずれかを実行します。
    • ローカルWinRMコマンド: winrm i iDRACHardReset wmi/root/cimv2/dcim/DCIM_iSMService?InstanceID="iSMExportedFunctions"
    • 次のリモートWinRMコマンドを実行します。 winrm i iDRACHardReset wmi/root/cimv2/dcim/dcim_ismservice -u:"admin-username" -p:"password" -r:http://"remote-hostname or IP"/wsman -a:Basic -encoding:utf-8 -skipCACheck -skipCNCheck
注:このWinRMリモート コマンドを使用する場合、WinRMのサーバーまたはリスナーの設定は必須です。リスナーとしてWinRMを構成する場合は、「Windows リモート管理のインストールと構成」を参照してください。
PowerShellを使用する方法

これは、PowerShellコマンドを使用してローカルまたはリモートで呼び出すことができます。

ローカルのPowerShellコマンドを使用してiDRACをリセットする手順は、次のとおりです。

必要条件

  • Microsoft.NET Framework 64ビット バージョン2.x以降が必要です。
  • PowerShellスクリプトを実行するための実行ポリシーは、次のいずれかに設定する必要があります。
    • Set-ExecutionPolicy AllSigned
    • Set-ExecutionPolicy Unrestricted

また、iDRAC Service Moduleでは、iDRACをローカルにリセットするPowerShellコマンドレットも提供されます。PowerShellを使用してiDRACをリセットするには、次の手順を実行します。

  1. 管理者としてWindows PowerShellセッションを開きます。
  2. Invoke-iDRACHardReset 」と入力して、Enterを押します。
注:このオプションを -force 使用すると、スクリプトを使用してiDRACをリセットしたり、確認メッセージなしでiDRACをリセットすることができます。

リモートPowerShellセッションから コマンドを使用 Invoke-iDRACHardReset するには、次の手順を実行します。

注:PS-Remotingの前提条件は、リスナーとしてのWinRM設定です。
  1. 管理ステーションで PowerShell セッションを起動します。
  2. cmdletを使用して リモートPowerShellEnable PS-Remoting 有効にします。
プログラム メニューのショートカット方法

これは、リモート デスクトップ セッションを使用してオペレーティング システムにログインすることで実行できます。次に、プログラム メニューから iDRACリセット オプション を選択します。

Linux

すべてのiSM対応Linuxオペレーティング システムで、iSMはSSHまたは同等のコマンドを使用してオペレーティング システムにログインすることで実行できるコマンドを提供します。

コマンドは次のいずれかです。

  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset
  • $ /opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset -f
注:コマンドと共にforce(-f )オプションを指定するオプションがあります。これは、ユーザーによる確認を待たずに、iDRACのリセット処理を続行します。

VMware ESXiオペレーティング システム

すべてのiDRACサービス モジュールでサポートされているESXiオペレーティング システムiSM 2.3以降では、CMPIメソッド プロバイダーがサポートされています。これにより、WinRMリモート コマンドを使用して、iDRACリセットをリモートで実行できます。Windows(WMIを除く)およびLinuxオペレーティング システムとは異なり、ESXiは、iDRACをリセットする前にユーザーに確認を求めるプロンプトを表示しません。

コマンドは次のとおりです。

  • winrm i iDRACHardReset http://schemas.dell.com/wbem/wscim/1/cim-schema/2/root/cimv2/dcim/DCIM_iSMService?__cimnamespace=root/cimv2/dcim+InstanceID=iSMExportedFunctions -u:"root-username" -p:"password" -r:https://"Host-IP":443/wsman -a:basic -encoding:utf-8 -skipCNCheck -skipCACheck -skipRevocationcheck

操作の結果は、操作の成功または失敗を示す整数値として表示されます。

制限事項:

ESXi 6.0 U1およびESXi 6.0 U2バージョンのESXiでは、iDRACのリセット後にIPMIドライバーが応答しなくなることがあります。特定のVMware ESXiオペレーティング システムでハード リセット操作を実行した後、IPMIドライバーの既存の問題により、IPMIドライバー(ipmi_si_drv )が応答しなくなることがあります。IPMIドライバーが応答しなくなった場合は、IPMIドライバー(ipmi_si_drv )を再ロードします。

を再ロードするには、次の手順を実行します。ipmi_si_drv

  1. /etc/init.d/sfcbd-watchdog stop
    esxcfg-module -u ipmi_si_drv => unload ipmi_si_drv
    esxcfg-module ipmi_si_drv => load ipmi_si_drv
    /etc/init.d/sfcbd-watchdog start
注:また、管理者は、ホスト オペレーティング システムを再起動して問題を解決することもできます。

RACADM

Dell Remote Access Controller Admin(RACADM)ユーティリティは、iDRACを使用したリモートまたはローカル管理を可能にするコマンドラインツールです。RACADMコマンドは、管理ステーションからリモートで実行するか、または管理対象システムでローカルに実行することができます。

すべてのインスタンスで、iDRACのみが再起動し、サーバーは再起動しません。iDRACの再起動は、実行中のオペレーティング システムには影響しません。iDRAC9とiDRAC7またはiDRAC8のコマンドには違いがあります。詳細については、該当するiDRACをクリックしてください。

iDRAC9

リセット - iDRAC 設定を変更せずに iDRAC を再起動します。
例: racadm racreset

リセット(強制) - 任意のiDRACコマンドに追加 -f すると、コマンドが強制的に実行されます。
例: racadm racreset -f

iDRACを工場出荷時のデフォルトにリセットします。これにより、すべての変更が工場出荷時の設定にリセットされますが、ユーザーとネットワークの設定 は保持されます
例: racadm racresetcfg

iDRAC設定をデフォルトにリセットし、ユーザーを出荷時の値にリセットします。
例: racadm racresetcfg -all

iDRAC設定をデフォルトにリセットし、ユーザーを のユーザー名とパスワードにrootcalvinリセットします。
例:racadm racresetcfg -rc

iDRAC設定をカスタム デフォルトにリセットします。
例: racadm racrsetcfg -custom

すべてのiDRAC9リセット コマンドは、 Integrated Dell Remote Access Controller 9(iDRAC9)バージョン3.00.00.00ユーザーズ ガイド |Dell US(249ページ)。

iDRAC7またはiDRAC8

リセット - iDRAC 設定を変更せずに iDRAC を再起動します。
例: racadm racreset

任意のiDRACコマンドに追加 -f すると、コマンドが強制的に実行されます。
例: racadm racreset -f

iDRACを工場出荷時のデフォルトにリセットします。これにより、すべての変更が工場出荷時の設定にリセットされます。これにより、ユーザーとネットワークの設定が 削除されます
例: racadm racresetcfg

すべてのiDRAC7またはiDRAC8リセット コマンドは、『 iDRAC 8/7 v2.81.81.81 RACADM CLI Guide 』(105ページ)に記載されています。

Produits concernés

iDRAC7, iDRAC8, iDRAC9, PowerEdge XR2, PowerEdge C4130, Poweredge C4140, PowerEdge c6320, PowerEdge c6320p, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, Poweredge FC430, Poweredge FC630, PowerEdge FC640 , Poweredge FC830, PowerEdge FD332, PowerEdge FM120x4 (for PE FX2/FX2s), PowerEdge FX2/FX2s, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M420, PowerEdge M520, PowerEdge M520 (for PE VRTX), PowerEdge M620, PowerEdge M620 (for PE VRTX), PowerEdge M630, PowerEdge M630 (for PE VRTX), PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M820, PowerEdge M820 (for PE VRTX), PowerEdge M830, PowerEdge M830 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R220, PowerEdge R230, PowerEdge R240, PowerEdge R250, PowerEdge R320, PowerEdge R330, PowerEdge R340, PowerEdge R350, PowerEdge R420, PowerEdge R420XR, PowerEdge R430, PowerEdge R440, PowerEdge R450, PowerEdge R520, PowerEdge R530, PowerEdge R530xd, PowerEdge R540, PowerEdge R550, PowerEdge R620, PowerEdge R630, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R720, PowerEdge R720XD, PowerEdge R730, PowerEdge R730xd, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R820, PowerEdge R830, PowerEdge R840, PowerEdge R860, PowerEdge R920, PowerEdge R930, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T130, PowerEdge T140, PowerEdge T150, PowerEdge T320, PowerEdge T330, PowerEdge T340, PowerEdge T350, PowerEdge T420, PowerEdge T430, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T620, PowerEdge T630, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9680, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8610t, PowerEdge XR8620t ...

Produits

iDRAC Service Module
Propriétés de l’article
Numéro d’article: 000126703
Type d’article: Solution
Dernière modification: 21 Sept 2023
Version:  17
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.