Omitir para ir al contenido principal
  • Hacer pedidos rápida y fácilmente
  • Ver pedidos y realizar seguimiento al estado del envío
  • Cree y acceda a una lista de sus productos

Windows 11 a Windows 10: Odstraňování problémů s režimem spánku a hibernace v počítači Dell

Summary: Tento článek obsahuje postup odstraňování problémů při řešení problémů s režimem spánku nebo hibernace ve stolním počítači nebo notebooku Dell se systémem Windows 11 a Windows 10.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Potýkáte se v počítači s problémy s režimem spánku nebo hibernace?

Tento článek vás provede řadou postupných kroků. Zjistěte, jak rozpoznat a vyřešit všechny problémy s režimem spánku a hibernace v operačních systémech Windows 11 a Windows 10.

Stavy napájení počítače

  • S1/S2/S3 – Režim spánku: Počítač vypadá, že je vypnutý. Spotřebovává méně energie, než když je počítač zapnutý, ale více energie než v režimu hibernace. Stav S3 spotřebovává méně energie než stav S2 a ten spotřebovává méně energie než stav S1. Počítač obvykle podporuje jeden z těchto 3 stavů. V těchto stavech se dočasná paměť počítače obnovuje tak, aby byl při přechodu do režimu spánku zachován stav počítače. Některé interní komponenty jsou nadále napájeny, aby se počítač mohl probudit pomocí vstupu z klávesnice, sítě LAN nebo zařízení USB. (Je to jako pozastavení a zrušení pozastavení počítače.)
  • S4 – Hibernace: Počítač vypadá, že je vypnutý. Tento režim používá nejnižší úroveň energie, skoro stejnou jako při vypnutí počítače. V tomto stavu počítač ukládá obsah dočasné paměti do souboru hibernace. Účelem je udržovat stav počítače, když přejde do režimu hibernace. Některé interní komponenty jsou nadále napájeny, aby se počítač mohl probudit pomocí vstupu z klávesnice, sítě LAN nebo zařízení USB. Pracovní kontext lze obnovit, pokud byl uložen na stálých médiích. (Je to jako kopírování všech otevřených a spuštěných aplikací na médium, vypnutí a opětovné načtení uložených aplikací a dat při spuštění.)

Další informace o stavech napájení počítače naleznete v následující dokumentaci:

Zpět na začátek


Cause

Nejsou k dispozici žádné informace o příčině.

Resolution

Kroky odstranění problémů

Abyste problém identifikovali a vyřešili, postupujte podle kroků uvedených níže:

Zkontrolujte fyzické nastavení počítače, abyste se ujistili, že nemá vliv na jeho fungování:

  • Zkontrolujte veškeré kabely vedoucí do počítače a z něj. Sedí pevně na svém místě?
  • Zkontrolujte, zda jsou všechna napájená zařízení napájena.
  • Zkontrolujte, zda se při spouštění počítače v žádné čtečce nenachází médium.
  • Zkontrolujte, zda jiné zařízení nebo objekt nemačká nebo neaktivuje vstupní zařízení.
  • Zkontrolujte, zda nedošlo k poškození počítače nebo jeho zařízení nebo jestli na ně nebyla vylita tekutina.
POZNÁMKA: Pro uživatele notebooků je to obzvláště důležité při práci s dokovacími stanicemi, jako jsou například modely WD15 nebo TB16. Je důležité zkontrolovat, zda ke stejnému problému dochází i v případě, kdy je položka připojená nebo odpojená. (Zda je dokovaná, či nikoliv.)

Způsoby probuzení systému z režimu spánku

Obnovení z režimu spánku můžete provést pomocí libovolného vstupního zařízení. Může jít o klepnutí na libovolnou klávesu na klávesnici, kliknutí či pohyb myší nebo stisknutí tlačítka napájení. (Pokud je nastavena funkce Wake-on-LAN, naplánoval se časovač, dotyková podložka, otevření víka nebo stisknutí tlačítka režimu spánku.)

Způsoby probuzení systému z režimu hibernace

Stiskněte blikající tlačítko napájení nebo libovolnou klávesu na klávesnici. (Pokud jste nastavili možnost probuzení z režimu hibernace pomocí stisknutí libovolné klávesy.)

POZNÁMKA: Upozorňujeme, že tento postup se může u jednotlivých počítačů lišit. Pokud si nejste jisti, stiskněte tlačítko napájení, jelikož je to univerzální způsob pro všechny počítače.
  1. Spusťte prohlížeč a přejděte na stránku podpory společnosti Dell.

  2. Zadejte výrobní číslo počítače a dostanete se na stránku, která odpovídá stavu počítače v době dodání od společnosti Dell. (Můžete také vybrat typ počítače ze seznamu produktů a získat tak seznam obecných informací pro váš typ počítače.)

  3. Vlevo vyberte možnost Ovladače a soubory ke stažení.

  4. V rozevírací nabídce pod položkou Kategorie vyberte možnost Basic Input/Output System (BIOS).

  5. Klikněte na tlačítko stahování napravo od souboru BIOS uvedeného v seznamu.

  6. Dvakrát klikněte na stažený soubor a postupujte podle pokynů na obrazovce.

    1. Během tohoto procesu se počítač vypne a restartuje (v průběhu počítač nevypínejte).

    2. Po restartování počítače bude systém BIOS aktualizován na nejnovější verzi.

POZNÁMKA: Nezapomeňte počítač během procesu napájet z elektrické sítě. Ztráta napájení během aktualizace systému BIOS na novou revizi je nežádoucí, jelikož by mohlo dojít k potížím se spuštěním a fungováním počítače.

Aktualizujte čipovou sadu.

  1. Spusťte prohlížeč a přejděte na stránku podpory společnosti Dell.

  2. Zadejte výrobní číslo počítače a dostanete se na stránku, která odpovídá stavu počítače v době dodání od společnosti Dell. (Můžete také vybrat typ počítače ze seznamu produktů a získat tak seznam obecných informací pro váš typ počítače.)

  3. Vlevo vyberte možnost Ovladače a soubory ke stažení.

  4. V rozbalovací nabídce pod položkou Kategorie vyberte možnost Čipová sada.

  5. Klikněte na tlačítko stahování napravo od souboru čipové sady uvedeného v seznamu.

  6. Dvakrát klikněte na stažený soubor a postupujte podle pokynů na obrazovce.

    1. Po dokončení tohoto procesu vás počítač požádá o vypnutí a restart. (Počítač vypněte pouze tehdy, až k tomu budete vyzváni.)

Jak najít a aktualizovat další ovladače v počítači.

Postupujte podle podrobných pokynů v článku znalostní databáze Dell Postup stažení a instalace ovladačů Dell.

  1. Otevřete okno služby Windows Update.

  2. Klikněte na tlačítko Start systému Windows, zadejte výraz Windows update a ze seznamu vyberte položku Nastavení služby Windows Update.

  3. Je v seznamu nalevo uvedena položka Sestavení Preview?

    1. Pokud ano, klikněte na položku Sestavení Preview.

      1. Klikněte na tlačítko Zkontrolovat.

      2. Stáhnětenainstalujte nové sestavení.

    2. Pokud ne, schovává vaše společnost nebo organizace tuto funkci nebo spravuje?

      1. Chcete-li operační systém aktualizovat, obraťte se na svou organizaci nebo firemní oddělení IT.

  1. V Ovládacích panelech otevřete Možnosti napájení.

  2. Pravým tlačítkem myši klikněte na tlačítko nabídky Start a v zobrazené nabídce vyberte položku Možnosti napájení.

  3. Vedle aktuálního schématu napájení klikněte na možnost Změnit nastavení schématu.

  4. Změňte položku Převést počítač do režimu spánku na možnost Nikdy.

  5. Klikněte na tlačítko Uložit změny.

  1. Otevřete příkazový řádek nebo prostředí PowerShelloprávněními správce.

  2. Pravým tlačítkem myši klikněte na tlačítko Start systému Windows a v zobrazené nabídce vyberte patřičnou možnost.

  3. Zadejte následující příkaz a stiskněte Enter: powercfg.exe /h off

  4. Zavřete okno příkazového řádku.

POZNÁMKA: Tuto možnost nedoporučujeme nechávat na notebooku Dell zakázanou. Někdy k vyřešení problémů stačí pouze zakázat rychlé spuštění a hybridní režim spánku.

Přestalo zařízení po obnovení počítače z režimu spánku či hibernace fungovat nebo jej již nelze zjistit? Proveďte níže uvedené kroky odstraňování problémů:

  1. Pokud je zařízení připojeno k externímu zdroji napájení, znovu zapojte napájecí kabel.

  2. Znovu zapojte kabel, pomocí kterého je zařízení připojeno k počítači.

  3. Pokud problém přetrvává, vypněte počítač a znovu jej zapněte.

V systému BIOS

  1. Spusťte systém BIOS. Opakovaným stisknutím klávesy F2 během spouštění se ve většině počítačů Dell dostanete přímo do systému BIOS.

  2. V části Power Management se ujistěte, že je povolena možnost USB Wake Support a možnost Deep Sleep Control je zakázána.

  3. Uložteukončete systém BIOS.

V systému Windows

  1. Otevřete okno Upřesnit možnosti napájení.

  2. Stiskněte současně klávesy Windows + R a otevřete okno Spustit. Zadejte příkaz control.exe powercfg.cpl,,3 a klikněte na tlačítko OK.

  3. V rozbalovacím seznamu vyberte schéma, které používáte.

  4. Klikněte na možnost Obnovit výchozí hodnoty plánu.

  5. Klikněte na tlačítko OK a zavřete okno.

  1. Otevřete okno PowerShell.

  2. Pravým tlačítkem myši klikněte na tlačítko Start systému Windows a vyberte možnost Windows PowerShell (správce) nebo Příkazový řádek (správce) u většiny počítačů se systémem Windows 10.

  3. Zadejte následující příkaz: powercfg /a.

  4. Zobrazí se zpráva:

    The following sleep states are available on this system:

        Standby (S3)

     

    The following sleep states are not available on this system:

        Standby (S1)

            The system firmware does not support this standby state.

     

        Standby (S2)

            The system firmware does not support this standby state.

     

        Hibernate

            Hibernation has not been enabled.

     

        Standby (S0 Low Power Idle)

            The system firmware does not support this standby state.

     

        Hybrid Sleep

            Hibernation is not available.

            The hypervisor does not support this standby state.

     

        Fast Startup

            Hibernation is not available.

Co je hybridní režim spánku?

Hybridní režim spánku – kombinace režimu spánku a hibernace. Všechny otevřené dokumenty a programy se vloží do paměti a pevného disku a počítač se přepne do úsporného režimu. To umožňuje rychle pokračovat v práci. Pokud dojde k výpadku napájení, systém Windows může obnovit vaši práci z pevného disku. To může být užitečné pro stolní počítače, avšak ne tolik pro notebooky. Tato možnost představuje výchozí nastavení pro stolní počítače. U notebooků je to naopak – ty se dodávají se zakázanou možností. (Stolní počítače jsou závislé na napájení ze sítě, zatímco notebooky mají integrované baterie, které problémy s napájením minimalizují.)

Vypnutí hybridního režimu spánku

  1. Otevřete okno Upřesnit možnosti napájení.

  2. Stiskněte současně klávesy Windows + R a otevřete okno Spustit. Zadejte příkaz control.exe powercfg.cpl,,3 a klikněte na tlačítko OK.

  3. V rozbalovacím seznamu vyberte schéma, které používáte.

  4. Projděte schéma a rozbalte možnost Režim spánku (kliknutím na symbol plus).

  5. Rozbalte položku Umožnit hybridní režim spánku.

  6. Ujistěte se, že všechny možnosti v části Umožnit hybridní režim spánku jsou vypnuty (kliknutím na modrý text hodnotu změníte).

  7. Klikněte na tlačítko OK a zavřete okno.

  1. Spusťte Průvodce odstraňováním problémů s napájením.

  2. Klikněte na tlačítko Start systému Windows a zadejte výraz poradce při jiných potížích. Výběrem ikony průvodce odstraňováním problémů jej otevřete.

  3. Projděte možnostmi a vyberte položku Napájení.

  4. Klikněte na tlačítko Spustit poradce při potížích.

  5. Pokuste se problém vyřešit pomocí pokynů na obrazovce.

Vytvoření spuštění holého systému za účelem odstraňování problémů

  1. Otevřete nástroj MsConfig.

  2. Stiskněte současně klávesy Windows + R a otevřete okno Spustit. Zadejte výraz msconfig a klikněte na tlačítko OK.

  3. Přejděte na kartu Obecné.

  4. Klikněte na přepínač Výběrové spuštění.

  5. Zrušte zaškrtnutí políčka Načíst položky Po spuštění.

  6. Přejděte na kartu Služby.

  7. V dolní části okna zaškrtněte políčko Skrýt všechny služby společnosti Microsoft.

  8. Na pravé straně stejné stránky klikněte na možnost Zakázat vše.

  9. Přejděte na kartu Po spuštění a klikněte na odkaz Správce úloh.

  10. Na kartě Po spuštění ve Správci úloh klikněte pravým tlačítkem myši na každou povolenou položku po spuštění a vyberte možnost Zakázat.

  11. Zavřete Správce úloh a přejděte zpět do nástroje MSConfig.

  12. Klikněte na tlačítko OK a potom na tlačítko Restartovat.

Obnovení počítače po spuštění holého systému

  1. Otevřete nástroj MsConfig.

  2. Stiskněte současně klávesy Windows + R a otevřete okno Spustit. Zadejte výraz msconfig a klikněte na tlačítko OK.

  3. Přejděte na kartu Obecné.

  4. Klikněte na přepínač Normální spuštění.

  5. Přejděte na kartu Služby.

  6. V dolní části okna zrušte zaškrtnutí políčka Skrýt všechny služby společnosti Microsoft.

  7. V dolní části stránky klikněte na možnost Povolit vše.

  8. Přejděte na kartu Po spuštění a klikněte na odkaz Správce úloh.

  9. Na kartě Po spuštění v nástroji Správce úloh klikněte pravým tlačítkem myši na každou povolenou položku po spuštění a vyberte možnost Povolit.

  10. Zavřete Správce úloh a přejděte zpět do nástroje MSConfig.

  11. Klikněte na tlačítko OK a potom na tlačítko Restartovat.

Jak obnovit soubor hiberfil.sys

Soubor hiberfil.sys můžete obnovit zakázáním a povolením přepínače. Tím dojde k resetování souboru v případě, že je poškozený:

  1. Otevřete příkazový řádek se zvýšenými oprávněními nebo prostředí PowerShell (klikněte pravým tlačítkem myši na tlačítko Start systému Windows a vyberte možnost Příkazový řádek (správce) nebo Windows PowerShell (správce)).

  2. Zadejte následující příkaz a stisknutím klávesy Enter soubor zakažte: powercfg -h off.

  3. Restartujte počítač a vraťte se do příkazového řádku se zvýšenými oprávněními nebo do prostředí PowerShell.

  4. Zadejte následující příkaz a stisknutím klávesy Enter soubor povolte: powercfg -h on.

Jak zakázat nebo odstranit soubor hiberfil.sys

Chcete-li soubor hiberfil.sys odstranit z počítače, stačí, když jej ponecháte zakázaný:

  1. Otevřete příkazový řádek se zvýšenými oprávněními nebo prostředí PowerShell (klikněte pravým tlačítkem myši na tlačítko Start systému Windows a vyberte možnost Příkazový řádek (správce) nebo Windows PowerShell (správce)).

  2. Zadejte následující příkaz a stisknutím klávesy Enter soubor zakažte: powercfg -h off.

  3. Restartujte počítač a vraťte se do příkazového řádku se zvýšenými oprávněními nebo do prostředí PowerShell.

POZNÁMKA: Mějte na paměti, že pokud nebylo obnovení systému povoleno dříve, než nastal tento problém, nebude vám k užitku. Nebylo možné vytvořit žádné body obnovení. Pokud není obnovení systému už povoleno, měli byste tento krok přeskočit a přejít na další. (Zapnutí obnovení systému byste nejspíš měli probrat se svým oddělením IT.)

Kontrola povolení obnovení systému.

  1. Otevřete Ovládací panely.

  2. Klikněte na tlačítko Start systému Windows, zadejte výraz Ovládací panely a v zobrazeném seznamu klikněte na ikonu Ovládacích panelů.

  3. Dvakrát klikněte na ikonu Systém.

  4. V nabídce na levé straně klikněte na možnost Ochrana systému.

  5. V zobrazeném okně klikněte na kartu Ochrana systému.

  6. V části Nastavení ochrany zkontrolujte, zda je disk počítače uveden jako zapnutý.

    1. Pokud ano, je funkce Obnovení systému povolena. Přejděte k další sadě kroků.

    2. Pokud ne, je funkce Obnovení systému zakázána. Přejděte k další části.

Použití nástroje Obnovení systému k návratu do předchozího kontrolního bodu.

  1. Otevřete Ovládací panely.

  2. Klikněte na tlačítko Start systému Windows, zadejte výraz Ovládací panely a v zobrazeném seznamu klikněte na ikonu Ovládacích panelů.

  3. Dvakrát klikněte na ikonu Systém.

  4. V nabídce na levé straně klikněte na možnost Ochrana systému.

  5. V zobrazeném okně klikněte na kartu Ochrana systému.

  6. V záhlaví Obnovení systému klikněte na tlačítko Obnovení systému.

  7. Podle pokynů na obrazovce vyberte ze seznamu požadovaný bod obnovení (vyberte ten před prvním výskytem problému).

  8. Chcete-li zkontrolovat, které programy budou tímto vrácením dotčeny, klikněte na tlačítko Vyhledat ovlivněné programy.

  9. Chcete-li vrátit počítač do stavu, ve kterém se nacházel ve vybraném datu, klikněte na tlačítko Další.

Spuštění nástroje SFC (System File Check).

  1. Otevřete příkazový řádek nebo prostředí PowerShelloprávněními správce.

  2. Pravým tlačítkem myši klikněte na tlačítko Start systému Windows a v zobrazené nabídce vyberte patřičnou možnost.

  3. Zadejte následující příkaz a stiskněte Enter: SFC /scannow.

  4. Pokud se nástroj SFC nespustil, vyzkoušejte následující sadu kroků a spusťte nástroj DISM.

Spuštění nástroje DISM (Deployment Image and Servicing Management).

  1. Otevřete příkazový řádek nebo prostředí PowerShelloprávněními správce.

  2. Pravým tlačítkem myši klikněte na tlačítko Start systému Windows a v zobrazené nabídce vyberte patřičnou možnost.

  3. Zadejte následující příkaz a stiskněte Enter: DISM /Online /Cleanup-Image /RestoreHealth.

  4. Nástroj DISM zkontroluje, zda v úložišti komponent systému Windows nedošlo k poškození, které případně napraví.

POZNÁMKA: Spuštění nástroje DISM může nějakou dobu trvat. Pokud nástroj nahlásí opravu nebo odstranění poškozených souborů, je nutné restartovat počítač a znovu spustit nástroj SFC.

Můžete zaměnit pevný disk za dvousměrný.

Nejrychlejším a nejjednodušším způsobem, jak vyloučit operační systém, je obousměrná výměna spouštěcího pevného disku. Použijte spouštěcí pevný disk z funkčního stejného modelu počítače.

  • Pokud chyba přetrvává, operační systém je v pořádku a doporučuji kontaktovat technickou podporu společnosti Dell s žádostí o další pomoc.
  • Pokud chyba doprovází pevný disk, jedná se pravděpodobně o chybu s operačním systémem. Přejděte k další sadě kroků.
  • Pokud nemáte k dispozici vhodný počítač pro výměnu dílů, přejděte k další sadě kroků.

Přeinstalování operačního systému do stavu, v jakém byl dodán společností Dell

Následující článek vás provede podrobným procesem přeinstalace operačního systému v počítači:

Zpět na začátek


Additional Information

Doporučené články

Zde je několik doporučených článků týkajících se tohoto tématu, které by vás mohly zajímat.


Pozáruční podpora Záruka vypršela? Žádný problém. Navštivte web Dell.com/support, zadejte výrobní číslo Dell a prohlédněte si naše nabídky.

POZNÁMKA: Nabídky jsou k dispozici pouze pro zákazníky s osobními počítači z USA, Kanady, Spojeného království, Francie, Německa, ČínyJaponska. Server ani úložiště nejsou k dispozici.

Affected Products

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations
Article Properties
Article Number: 000129843
Article Type: Solution
Last Modified: 19 oct 2023
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.