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Soporte para el módulo de servicio Dell iDRAC

Resumen: iDRAC Service Module (iSM) es un servicio de software ligero que integra mejor las funciones del sistema operativo (SO) con iDRAC y se puede instalar en los servidores PowerEdge de 12.ª generación y más recientes de Dell. El iSM proporciona a la iDRAC información relacionada con el sistema operativo y agrega funcionalidades como la replicación de eventos del registro del ciclo de vida (LC) en el registro del sistema operativo, la compatibilidad con el Instrumental de administración de Windows (WMI) (incluido el almacenamiento), las alertas SNMP del iDRAC mediante el sistema operativo, el restablecimiento forzado remoto del iDRAC y el ciclo de apagado y encendido completo. En esta guía, se proporciona una visión general de las características, cómo descargarlas e instalarlas y recursos adicionales. ...

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Módulo de servicio Dell EMC iDRAC

Integrated Dell Remote Access Controller Service Module (iSM)

  • Expande la administración de iDRAC en sistemas operativos del host compatibles
  • iSM proporciona a iDRAC información relacionada con el sistema operativo
  • Servicio ligero de software con espacio físico de host mínimo

El módulo de servicio de Integrated Dell Remote Access Controller (iDRAC) (iSM) es una aplicación de software ligera y opcional que se puede instalar en servidores PowerEdge. El iDRAC Service Module complementa las interfaces de iDRAC: Interfaz de usuario (IU), CLI de RACADM, Redfish y Web Service Management (WS-MAN) con datos de monitoreo adicionales. La arquitectura del iDRAC Service Module utiliza comunicación por conectores de IP, proporciona datos adicionales de administración de sistemas (SO/controlador de dispositivo) a iDRAC y proporciona a las consolas de control general acceso a los datos de administración de sistema mediante interfaces estándar del SO.

 
 

Características del módulo de servicio de iDRAC

Información del sistema operativo

Server Administrator comparte la información del sistema operativo y el nombre de host con iDRAC. El iSM proporciona información similar, como el nombre del SO host, información sobre la dirección IP del host del servidor, la versión del SO y el nombre de dominio calificado (FQDN) con iDRAC. También se muestran las interfaces de red en el SO host. De forma predeterminada, esta función de monitoreo está activada. Esta función está disponible incluso si Server Administrator está instalado en el SO host.

Replicación de registros de Lifecycle Controller en el sistema operativo

El iSM replica los registros de Lifecycle Controller (LC) en los registros del sistema operativo. Todos los eventos que tienen la opción Registro del sistema operativo como destino (en la página Alertas o en las interfaces equivalentes RACADM o WSMAN) se replican en el registro del SO mediante iSM. Este proceso es similar a la replicación del registro de eventos del sistema (SEL) que ejecuta Server Administrator.

El conjunto predeterminado de registros que se incluirá en los registros del sistema operativo es el mismo que los registros configurados para las capturas/alertas de SNMP. Solo los eventos registrados en el registro de LC después de la instalación de iSM se replican en el registro del SO. Si Server Administrator está instalado, la función de monitoreo se desactiva para evitar la duplicación de entradas de SEL en el registro del SO.

Función de recuperación automática del sistema

La característica Recuperación automática del sistema es un temporizador basado en hardware que se utiliza para restablecer el servidor si se produce un error de hardware. La función puede realizar operaciones de recuperación automática del sistema, como reiniciar, hacer un ciclo de encendido o apagado, o apagar después de un intervalo de tiempo especificado. Esta función se activa solo cuando el temporizador guardián del sistema operativo está desactivado. Si Server Administrator está instalado, la función de monitoreo se desactiva para evitar la duplicación de temporizadores guardianes.

Proveedores del Instrumental de administración de Windows

Los proveedores del Instrumental de administración de Windows disponibles con iSM exponen datos de hardware a través del Instrumental de administración de Windows (WMI). WMI es un conjunto de extensiones al modelo de controladores de Windows que proporciona una interfaz de sistema operativo a través de la cual los componentes instrumentalizados proporcionan información y notificaciones. WMI es una implementación Microsoft de los estándares Gestión Empresarial Basada en Web (WBEM) y Modelo de Información Común (CIM) desde la Fuerza de Tareas de Administración Distribuida (DMTF) para administrar el hardware del servidor, los sistemas operativos y las aplicaciones. Los proveedores de WMI ayudan con la integración en consolas de administración de sistemas, como Microsoft System Center, y permiten la administración de servidores de Microsoft Windows mediante scripts.

Recopilación de SupportAssist

La característica Recopilación de SupportAssist de iDRAC recopila información acerca del hardware, el sistema operativo y datos pertinentes de aplicaciones, para luego comprimir esta información. Con iSM 2.0 o versiones posteriores, la herramienta OS Collector recopila automáticamente información pertinente del sistema operativo y del hardware, pero debe hacerlo de forma manual. 

 

Soporte para la extracción de dispositivos SSD PCIe NVMe

Extracción de un dispositivo de estado sólido (SSD) con interconexión de componentes periféricos exprés (PCIE) y memoria no volátil exprés (NVMe) sin apagar o reiniciar el sistema. Todas las actividades asociadas con el dispositivo se deben detener para evitar la pérdida de datos cuando se extrae un dispositivo. Para evitar la pérdida de datos, utilice la opción Preparar para extraer, la cual detiene todas las actividades en segundo plano asociadas con el dispositivo, después de lo cual puede extraer el SSD PCIe NVMe.

Restablecimiento forzado remoto de iDRAC

Utilice iDRAC para monitorear los servidores compatibles y ver problemas críticos de hardware, firmware o software del sistema. En raras ocasiones, es posible que un iDRAC deje de responder. Anteriormente, un cliente debía apagar el servidor desconectando la alimentación del servidor. Mediante la función de restablecimiento forzado remoto de la iDRAC, si una iDRAC deja de responder, realice una operación de restablecimiento remoto de la iDRAC sin necesidad de apagar el servidor. Se necesitan privilegios de administrador en el SO del host para usar esta función. De manera predeterminada, la función Restablecimiento forzado remoto de iDRAC está activada.

Acceso a iDRAC mediante el SO del host

Utilice los servidores Dell PowerEdge para administrar el hardware o firmware de un dispositivo mediante iDRAC configurando una red dedicada de iDRAC. A través del puerto de red dedicado, acceda a las interfaces de iDRAC como IU, WSMAN, RACADM y el cliente Redfish.

Como requisito previo para administrar el hardware o firmware, debe tener una conexión dedicada entre un dispositivo y la interfaz de iDRAC compatible. Para acceder a iDRAC mediante la característica SO del host, conéctese a una interfaz de iDRAC desde un host o una IP del SO, independientemente de la conexión entre un dispositivo y una red dedicada de iDRAC. Esta función le permite monitorear el hardware o firmware, incluso si iDRAC no está conectado a los servidores.

Compatibilidad dentro de banda para las alertas SNMP de iDRAC

Mediante iDRAC, una herramienta de monitoreo y administración de servidores fuera de banda, las capturas/alertas de SNMP se pueden registrar en el registro. Sin embargo, desde la perspectiva de una administración de sistemas del SO host que utiliza un agente dentro de banda, se suele preferir más la alerta SNMP recibida desde el SO host que las capturas recibidas desde iDRAC. Cuando se recibe una alerta SNMP desde iDRAC, es difícil determinar el origen de la alerta, ya que proviene de la IP de un iDRAC y no de la IP del sistema.

A partir de iSM 2.3, puede recibir alertas SNMP desde el SO del host, lo cual es similar a las alertas de iDRAC.

Habilitar WSMAN de forma remota

Con la característica de información de WMI, puede conectarse al host de Microsoft Windows con el espacio de nombres WMI para monitorear el hardware del sistema. La interfaz de WMI en el host está activada de manera predeterminada y puede acceder a ella de manera remota. Si desea acceder a las interfaces WMI mediante el adaptador WMI de WINRM, debe habilitarlo manualmente, ya que no está habilitado de manera predeterminada. Con esta función, puede acceder de manera remota a los espacios de nombres WMI de WINRM habilitándolos durante la instalación.

Nota: System Management no agrega ninguna característica nueva a WSMAN.

Instalación de fábrica del módulo de servicio iDRAC para Microsoft Windows (opcional para el cliente)

iSM ahora puede instalarse de fábrica para el sistema operativo Microsoft Windows. Mediante la instalación previa de iSM, puede acceder rápidamente a registros críticos y documentos de soporte. Cuando se selecciona una instalación de fábrica del sistema operativo Microsoft Windows, puede optar por instalar iSM en las opciones disponibles.

  • iSM activado: proporciona la instalación de fábrica de iSM en el SO Windows
  • iSM desactivado: los clientes que no desean tener iSM instalado en el sistema operativo deben seleccionar esta opción

Monitoreo S.M.A.R.T

La función Monitoreo S.M.A.R.T es compatible con unidades de disco duro habilitadas con SATA en modo AHCI. Tiene la funcionalidad integrada para monitorear las alertas S.M.A.R.T mediante métodos de auditoria soportados con iDRAC para las unidades de disco duro con controladora de chipset SATA. Anteriormente, una utilidad de código abierto supervisaba las alertas a los discos duros configurados en modo RAID.

FullPowerCycle

La función FullPowerCycle proporciona una manera para restablecer la alimentación auxiliar del servidor. Una cantidad cada vez mayor de hardware del servidor utiliza alimentación auxiliar del servidor. Para solucionar algunos problemas del servidor, debe desconectar físicamente el cable de alimentación del servidor para restablecer el hardware que utiliza alimentación auxiliar. Esto significa que alguien debe desconectar/conectar físicamente los cables de alimentación, lo que genera un costo significativo y molestias para los clientes y el personal de soporte. La función FullPowerCycle permite que el administrador conecte o desconecte la alimentación auxiliar de forma remota sin visitar el centro de datos. Esta función es compatible con iDRAC9.

 

Correlación de eventos de software con fallas de hardware para Microsoft S2D

iSM monitorea los registros de eventos en busca de alertas o sucesos del pool de almacenamiento de hardware mediante la característica de correlación de almacenamiento del servidor. El subsistema de almacenamiento del servidor se monitorea cuando se utilizan controladoras de almacenamiento Dell en el modo RAID. Sin embargo, en Storage Spaces (SS) o Storage Space Direct (S2D), el subsistema de almacenamiento del servidor se monitorea en un modo de paso o el chipset SATA se utiliza para crear el pool de almacenamiento. Con esta característica, se fusionan las alertas definidas por hardware cubiertas por el registro de Life Cycle y las alertas definidas por software cubiertas por los registros del sistema operativo; las alertas se registran en los registros de Lifecycle de iDRAC. Esta característica se instala con el paquete del iDRAC Service Module y se habilita de manera predeterminada. El usuario puede cambiar las preferencias en la configuración de iDRAC. Como parte del monitoreo, iSM audita los registros en busca de posibles fallas y advertencias e incorpora los eventos de correlación de SS en el host para un evento de LC equivalente.

Despacho automático de disco SupportAssist de iSM

Como parte de las alertas predictivas, si el servidor alcanza uno de los siguientes eventos SNMP, PDR16 y PDR63, se envía por correo electrónico una recomendación del equipo de soporte de Dell en relación con la orden de trabajo de la falla predictiva o un bloque de disco dañado, como los discos SSD sujetos a los términos y condiciones de licenciamiento que prevalezcan. Se requiere una dirección de servicio al soporte de Dell para realizar un pedido de piezas. Esta función solo está disponible en los sistemas operativos Windows y Linux.

Iniciador de IU de iDRAC

Para iniciar la interfaz de usuario de iDRAC desde el sistema local, haga doble clic en el icono del iniciador de interfaz de usuario de iDRAC. Se abre la página de inicio de sesión de la IU de iDRAC en el navegador predeterminado y se pueden utilizar las credenciales de iDRAC para iniciar sesión en la página de inicio de iDRAC. Esto solo se admite en los sistemas operativos Microsoft Windows.

Single Sign On (SSO) en la IU de iDRAC desde el escritorio de los administradores del SO del host

La función de inicio de sesión único (SSO, por sus siglas en inglés) permite que un administrador de sistemas operativos autenticado acceda de forma directa a la interfaz web de iDRAC sin necesidad de iniciar sesión con credenciales de administrador de iDRAC independientes.

Comunicación entre iSM y iDRAC con seguridad mejorada mediante el protocolo TLS

A partir de iSM 3.4, la comunicación de datos entre iSM y iDRAC se produce a través de conectores INET USBNIC protegidos por TLS. Esto garantiza la protección de todos los datos que viajan desde iDRAC a iSM mediante USBNIC. iSM y iDRAC usan certificados autofirmados para controlar la autenticación. Los certificados autofirmados tienen 10 años de validez. Se generan certificados autofirmados nuevos cada vez que instala iSM.



Panel de iDRAC9

Mejoras al Dell iDRAC Service Module

Dell está mejorando constantemente su Dell iDRAC Service Module.

Módulo de servicio del iDRAC (17.ª generación)

iDRAC Service Module 6.0.1.0 soporta los servidores PowerEdge de 17.ª generación.

Características de Dell iDRAC Service Module 6.0.1.0 (solo 17.ª generación)

  • Información del sistema operativo
  • Replicación de registros de Lifecycle Controller en el sistema operativo
  • Recuperación automática del sistema
  • Preparar para quitar un dispositivo SSD PCIe NVMe.
  • Restablecimiento forzado remoto de iDRAC
  • Compatibilidad dentro de banda para alertas SNMP de iDRAC
  • Asignación de registros de iDRAC Lifecycle a alertas OMSA y OMSS SNMP
  • Actualización automática del iSM
  • FullPowerCycle
  • Aislamiento de la característica independiente de paso del sistema operativo al iDRAC.

Hipervisores y sistemas operativos compatibles

iDRAC Service Module 6.0.1.0 es compatible con los siguientes sistemas operativos en servidores PowerEdge 17G:

  • Windows Server 2022
  • Windows Server 2025
  • Red Hat Enterprise Linux 9.4
  • VMware vSphere ESXi 8.0 U3 

Módulo de servicio del iDRAC (14.ª generación, 15.ª generación, 16.ª generación)

iDRAC Service Module 5.4.0.0 es compatible con los siguientes servidores PowerEdge de 14.ª, 15.ª y 16.ª generación en todos los sistemas operativos compatibles.

Plataformas Dell soportadas
Servidores PowerEdge 14G Servidores PowerEdge 15G Servidores PowerEdge 16G
PowerEdge C4140 PowerEdge C6520 PowerEdge C6600
PowerEdge C6420 PowerEdge C6525 PowerEdge C6615
PowerEdge FC640 PowerEdge MX750c PowerEdge C6620
PowerEdge M640 PowerEdge R250 PowerEdge HS5610
PowerEdge M640p PowerEdge R350 PowerEdge HS5620
PowerEdge MX740c PowerEdge R450 PowerEdge MX760c
PowerEdge MX840c PowerEdge R550 PowerEdge R260
PowerEdge R240 PowerEdge R650 PowerEdge R360
PowerEdge R340 PowerEdge R650xs PowerEdge R660
PowerEdge R440 PowerEdge R750 PowerEdge R660xs
PowerEdge R540 PowerEdge R750xa PowerEdge R760
PowerEdge R640 PowerEdge R750xs PowerEdge R760xa
PowerEdge R740 PowerEdge R6515 PowerEdge R760xd2
PowerEdge R740xd PowerEdge R6525 PowerEdge R760xs
PowerEdge R740xd2 PowerEdge R7515 PowerEdge R860
PowerEdge R840 PowerEdge R7525 PowerEdge R960
PowerEdge R940 PowerEdge T150 PowerEdge R6615
PowerEdge R940xa PowerEdge T350 PowerEdge R6625
PowerEdge R6415 PowerEdge T550 PowerEdge R7615
PowerEdge R7415 PowerEdge XE8545 PowerEdge R7625
PowerEdge R7425 PowerEdge XR11 PowerEdge T160
PowerEdge T140 PowerEdge XR12 PowerEdge T360
PowerEdge T340 PowerEdge XR4510c PowerEdge T560
PowerEdge T440 PowerEdge XR4520c PowerEdge XE8640
PowerEdge T640   PowerEdge XE9640
PowerEdge XE2420   PowerEdge XE9680
PowerEdge XE7420   PowerEdge XR5610
PowerEdge XE7440   PowerEdge XR7620
Precision R7920   PowerEdge XR8000
    PowerEdge XR8610t
    PowerEdge XR8620t
    Precision R7960

 

Características nuevas y mejoradas

Área funcional Descripción de la función Resumen de los beneficios
RAID de software Configuración de RAID de software La configuración de RAID de software soporta el cambio de nombre, la reconfiguración y la visualización del tamaño máximo para reconfigurar el disco virtual.

 

Hipervisores y sistemas operativos compatibles:

  • Windows Server 2025
  • Windows Server 2022
  • Windows Server 2019
  • Red Hat Enterprise Linux 8.10
  • Red Hat Enterprise Linux 9.4
  • SUSE Linux Enterprise Server 15SP6
  • Vmware vSphere (ESXi) 8.0 U3
  • VMware vSphere (ESXi) 7.0 U3
  • Ubuntu Server 24.04
  • Soporte comunitario Debian 11

RTOS soportados en servidores PowerEdge R650, PowerEdge R660, PowerEdge R750, PowerEdge R760, PowerEdge XR11, PowerEdge XR12, PowerEdge XR5610 y PowerEdge XR8000:

  • Red Hat Enterprise Linux 8.10
  • Red Hat Enterprise Linux 9.4
  • SUSE Linux Enterprise Server 15 SP6

Sistemas operativos cliente soportados en Precision R7920 y Precision R7960:

  • Microsoft Windows 10 22H2
  • Microsoft Windows 11 21H2/22H2/23H2
  • Red Hat Enterprise Linux 98.6
  • Ubuntu Desktop 24.04


Consulte la versión más reciente de las Notas de la versión del módulo de servicio de Dell iDRAC para obtener la lista completa de las mejoras y limitaciones, los problemas resueltos y los problemas conocidos.

Consulte el Módulo de servicio de iDRAC de Dell Technologies para obtener la lista completa de todas las versiones de iSM.

Causa


Configuración de iDRAC9

Descargue e instale Dell iDRAC Service Module.

El Dell iDRAC Service Module tiene soporte en la mayoría de las versiones de los sistemas operativos Microsoft Windows, Linux y ESXi para servidores PowerEdge con iDRAC7, iDRAC8 e iDRAC9. Consulte Plataformas soportadas para obtener información adicional acerca de las plataformas y los sistemas operativos soportados.

La versión específica de iSM para el sistema varía según el modelo del servidor y el sistema operativo instalado. Para descargar la versión más reciente de iSM:

  • Vaya a Dell.com/support y seleccione el modelo del servidor o ingrese la etiqueta de servicio.
  • Seleccione Controladores y descargas.
  • Seleccione el sistema operativo en Operating System según su sistema
  • Palabra clave: iSM
  • Descargue la revisión más reciente proporcionada para el módulo de servicio Dell iDRAC

Consulte la Guía del usuario del iDRAC Service Module de Dell Technologies específica de la versión y, a continuación, el tema Instalación del iDRAC Service Module para obtener información sobre los requisitos de software y de sistema, además de los pasos para instalar, actualizar y desinstalar el iSM.

 
 

Resolución

Recursos para el módulo de servicio Dell iDRAC

Comunidad

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Documentación

Consulte Documentación del Dell iDRAC Service Module para obtener la documentación más reciente.

Documentación técnica

Funciones de RAID de software en iDRAC Service Module


Documentación técnica de diciembre de 2024
de 20 páginas
En esta documentación técnica, se proporciona información acerca de la característica de RAID de software en iDRAC Service Module (iSM) y se describen los pasos para realizar la enumeración, la configuración y el monitoreo de las controladoras, los discos físicos y los discos virtuales conectados a los servidores Dell PowerEdge. 

Leer la documentación técnica

Guía de configuración de seguridad del módulo de servicio Dell iDRAC


Guía de configuración de seguridad de 29 páginas
Enero de 2022
Este documento describe las configuraciones de seguridad relacionadas con el módulo de servicio de Dell iDRAC (iSM) y su instalación, configuración y funcionalidad en el sistema operativo host.

Leer la guía de configuración de seguridad

iDRAC Service Module: funciones basadas en el SO para la administración fuera de banda con iDRAC9


Documentación técnica de doce páginas
Mayo de 2021
Resumen de las mejoras más recientes que iDRAC Service Module (iSM) proporciona a la administración fuera de banda con iDRAC9 para los clientes en los servidores PowerEdge de Dell 14 y 15.ª generación.

Leer la documentación técnica

iDRAC Service Module: acceso a iDRAC mediante el sistema operativo del host


Enero de 2017
Libro blanco de diecisiete páginas
En esta documentación técnica, se proporciona información sobre el uso y la solución de problemas del acceso a iDRAC mediante las características del sistema operativo del host en iDRAC Service Module v2.3 o posteriores.

Leer la documentación técnica

Módulo de servicio iDRAC: habilitar alertas SNMP de iDRAC dentro de banda


Documentación técnica de trece páginas
Enero de 2017
En esta documentación técnica, se proporciona información sobre el uso, la configuración y la solución de problemas de las alertas SNMP de iDRAC dentro de banda en iDRAC Service Module v2.3 en adelante.

Leer la documentación técnica

Módulo de servicio de iDRAC: cómo realizar un restablecimiento forzado de CPU en iDRAC


Documentación técnica de ocho páginas
Julio de 2016
En esta documentación técnica, se proporciona información acerca del uso y la solución de problemas en la característica Restablecimiento forzado de CPU de iDRAC en iDRAC Service Module v2.3 en adelante.

Leer la documentación técnica

Módulo de servicio iDRAC 2.1 (mín.) en sistemas operativos Linux Ubuntu y Debian


Documentación técnica de diecinueve páginas
Septiembre de 2015
En este documento técnico, se proporciona información sobre el uso y la solución de problemas en el módulo de servicio de iDRAC v2.1 en adelante en los sistemas operativos Ubuntu y Debian Linux.

Lea el documento técnico

Módulo de servicio iDRAC: Instrumental de administración de Windows


Documentación técnica de diecisiete páginas
Abril del 2015
En esta documentación técnica, se aborda el uso del módulo de servicio iDRAC para monitorear los diversos perfiles de hardware a través de las interfaces de cliente del Instrumental de administración de Windows (WMI), como Windows PowerShell, la línea de comandos del Instrumental de administración de Windows, el cliente Windows Remote Management (WINRM) y WBEMTEST.

Lea el documento técnico

Videos

Instalación inicial: iDRAC Service Module

 

Obtenga información sobre cómo instalar el iDRAC Service Module desde la interfaz de usuario de iDRAC.

Noviembre del 2017

Recopilación de SupportAssist en el iDRAC Service Module 3.0.1

 

Obtenga información sobre cómo realizar una recopilación de SupportAssist mediante el iDRAC Service Module 3.0.1.

Noviembre del 2017

Habilitación de la característica "Acceso a iDRAC mediante el sistema operativo host" en Microsoft Windows en el módulo de servicio de iDRAC 2.4

 

Obtenga información sobre cómo habilitar y configurar el acceso a iDRAC a través de la característica de SO del host en Microsoft Windows.

Julio del 2017

Instalar el módulo de servicio iDRAC en el SO Microsoft Windows Nano


Obtenga información sobre cómo instalar el iDRAC Service Module en sistemas operativos Microsoft Windows Nano.

Julio del 2017

Habilitación del acceso a iDRAC a través de la característica del SO del host en Linux en iSM 2.4

 

Obtenga información sobre cómo habilitar el acceso iDRAC en banda para sistemas Linux.

Julio del 2017

Visualizar capturas SNMP de iDRAC recibidas desde el SO del host en Linux en iSM 2.4

 

Obtenga información sobre cómo ver las capturas SNMP de iDRAC recibidas desde el SO del host en sistemas operativos Linux.

Julio del 2017

Monitorear servidores Dell a través del módulo de servicio iDRAC mediante WMI

 

Se describe el proceso para monitorear servidores Dell a través del módulo de servicio iDRAC (iSM) mediante el Instrumental de administración de Windows (WMI) para Dell Server Management Pack Suite versión 6.3 en un entorno Microsoft System Center Operations Manager o SCOM.

Octubre de 2024

Productos afectados

iDRAC Service Module

Productos

iDRAC7, iDRAC8, iDRAC9, Lifecycle Controllers
Propiedades del artículo
Número de artículo: 000178050
Tipo de artículo: Solution
Última modificación: 02 abr 2025
Versión:  28
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