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Suporte para o Dell iDRAC Service Module

Resumen: iDRAC Service Module (iSM) é um serviço leve de software que faz a melhor integração dos recursos do sistema operacional (SO) ao iDRAC e pode ser instalado na 12ª geração ou posterior dos servidores PowerEdge da Dell. O iSM apresenta ao iDRAC informações relacionadas ao SO e adiciona recursos, como replicação de eventos de log do LifeCycle (LC) no log do SO, suporte a WMI (inclusive armazenamento), alertas SNMP do iDRAC usando o SO, reinicialização forçada remota do iDRAC e ciclo de energia completo. Este guia apresenta uma visão geral dos recursos, instruções de download e instalação e recursos adicionais. ...

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Dell EMC iDRAC Service Module

Integrated Dell Remote Access Controller Service Module

  • Expande o gerenciamento do iDRAC em sistemas operacionais do host com suporte
  • Fornece informações relacionadas ao sistema operacional para o iDRAC
  • Serviço de software leve com espaço de ocupação mínimo do host

O Integrated Dell Remote Access Controller (iDRAC) Service Module (iSM) é um aplicativo de software opcional leve que pode ser instalado em servidores PowerEdge. O iDRAC Service Module complementa as interfaces do iDRAC: Interface do usuário (IU), CLI do RACADM, Redfish e Web Service Management (WS-MAN) com dados adicionais de gerenciamento. A arquitetura do iDRAC Service Module usa a comunicação de soquete IP, oferece dados adicionais de gerenciamento de sistemas (SO/driver de dispositivos) ao iDRAC e apresenta consoles de um para muitos com acesso aos dados de gerenciamento de sistema por meio de interfaces padrão do SO.

 
 

Recursos do iDRAC Service Module

Informações do sistema operacional

O Server Administrator compartilha informações do sistema operacional e o nome do host com o iDRAC. O iSM fornece informações semelhantes com o iDRAC, como nome do sistema operacional do host, informações de endereço IP do host do servidor, versão do sistema operacional e Nome do domínio totalmente qualificado (FQDN). As interfaces de rede no sistema operacional do host também são exibidas. Por padrão, esse recurso de monitoramento é ativado. Esse recurso está disponível mesmo se o Server Administrator estiver instalado no sistema operacional do host.

Replicação do registro do Lifecycle Controller no sistema operacional

Replica os registros do Lifecycle Controller (LC) nos registros do sistema operacional. Todos os eventos que têm a opção de registro do sistema operacional como o destino (na página Alertas ou nas interfaces RACADM ou WSMAN equivalentes) são replicados no registro do sistema operacional usando o iSM. Esse processo é semelhante à replicação de Registro de eventos do sistema (SEL) realizada pelo Server Administrator.

O conjunto padrão de logs que estarão nos logs do sistema operacional é o mesmo que os logs configurados para alertas/traps SNMP. Somente os eventos gravados no registro do LC após a instalação do iSM são replicados no registro do sistema operacional. Se o Server Administrator estiver instalado, o recurso de monitoramento será desativado para evitar entradas duplicadas do SEL no registro do sistema operacional.

Recurso de recuperação automática do sistema

O recurso Automatic System Recovery é um temporizador baseado em hardware usado para reiniciar o servidor em caso de falha de hardware. O recurso pode executar operações de recuperação automática do sistema, como reinicialização, ciclo de energia ou desligamento após um intervalo de tempo especificado. Esse recurso é ativado somente quando o temporizador do watchdog do sistema operacional é desativado. Se o Server Administrator estiver instalado, o recurso de monitoramento será desativado para evitar a duplicação de temporizadores do watchdog.

Provedores da Instrumentação de Gerenciamento do Windows

Os provedores da Instrumentação de Gerenciamento do Windows disponíveis com o iSM expõem dados de hardware por meio da Instrumentação de Gerenciamento do Windows (WMI). WMI é uma extensão do modelo de driver do Windows que oferece uma interface de sistema operacional pela qual os componentes de instrumentos apresentam informações e notificações. A WMI é a implementação da Microsoft do Gerenciamento empresarial baseado na Web (WBEM) e dos padrões do Modelo comum de informações (CIM) pela Força-tarefa de gerenciamento distribuída (DMTF) para gerenciar hardware de servidor, sistemas operacionais e aplicativos. Os provedores de WMI ajudam a fazer a integração com consoles de gerenciamento de sistemas, como o Microsoft System Center, e permitem que os scripts gerenciem servidores Microsoft Windows.

Coleta do SupportAssist

O recurso de coleta do SupportAssist no iDRAC reúne informações sobre o hardware, o SO e os dados relevantes de aplicativo e compacta essas informações. Ao usar o iSM 2.0 ou versões posteriores, a ferramenta OS Collector coletará automaticamente informações relevantes sobre o sistema operacional e o hardware, mas você deve fazer isso manualmente. 

 

Suporte à remoção do dispositivo SSD PCIe NVMe

Realiza a remoção de um dispositivo de estado sólido (SSD) de Peripheral Component Interconnect Express (PCIE) com Memória expressa não volátil (NVMe) sem desligar nem reinicializar o sistema. Quando estiver removendo um dispositivo, todas as atividades associadas a ele deverão ser interrompidas para evitar perda de dados. Para evitar perda de dados, use a opção Preparar para remover, que interrompe todas as atividades em segundo plano associadas ao dispositivo. Em seguida, você pode remover a SSD PCIe NVMe fisicamente.

Reinicialização forçada remota do iDRAC

Por meio do iDRAC, é possível monitorar os servidores compatíveis para identificar problemas críticos de sistema, hardware, firmware ou software. Em casos raros, um iDRAC pode deixar de responder. Antes, um cliente teria que desconectar o servidor da energia para desligá-lo. Agora, usando o recurso de reinicialização forçada remota do iDRAC, se um iDRAC parar de responder, execute uma operação de redefinição remota do iDRAC sem precisar desligar o servidor. Para usar esse recurso, é necessário ter privilégios de administrador no sistema operacional do host. Por padrão, o recurso de reinicialização forçada remota do iDRAC está ativado.

Acesso ao iDRAC usando o SO de host

Ao usar servidores PowerEdge da Dell, é possível configurar uma rede do iDRAC dedicada para gerenciar o hardware ou o firmware de um dispositivo por meio do iDRAC. Por meio da porta de rede dedicada, é possível acessar as interfaces do iDRAC, como IU, WSMAN, RACADM e client Redfish.

O pré-requisito para gerenciar o hardware ou o firmware é ter uma conexão dedicada entre um dispositivo e a interface do iDRAC compatível. Ao usar o recurso de acesso ao iDRAC usando o SO de host, é possível se conectar a uma interface do iDRAC a partir de um IP ou host do SO, independentemente da conexão entre um dispositivo e uma rede dedicada do iDRAC. Esse recurso monitora o hardware ou o firmware, mesmo se o iDRAC não estiver conectado aos servidores.

Suporte em banda para alertas SNMP do iDRAC

Ao usar o iDRAC, uma ferramenta de gerenciamento e monitoramento de servidor fora de banda, os traps/alertas SNMP podem ser gravados no registro. No entanto, pela perspectiva do agente em banda, em um gerenciamento de sistema operacional do host, a preferência é do alerta SNMP recebido do sistema operacional do host em vez dos traps recebidos do iDRAC. Quando um alerta SNMP é recebido do iDRAC, é difícil determinar a origem do alerta, pois se trata de um IP do iDRAC, e não do IP do sistema.

Ao iniciar o iSM 2.3, você poderá receber alertas SNMP do SO de host que são semelhantes aos alertas do iDRAC.

Ativar o WSMAN remotamente

Com o recurso de informações da WMI, você pode se conectar ao namespace da Microsoft Windows WMI do host para monitorar o hardware do sistema. A interface da WMI no host é ativada por padrão, e é possível acessá-la remotamente. No entanto, se você quiser acessar as interfaces da WMI usando o adaptador de WMI do WINRM, é necessário ativá-las manualmente, pois não são ativadas por padrão. Ao usar esse recurso, você poderá ativar os namespaces da WMI do WINRM remotamente habilitando-os durante a instalação.

Nota: O Gerenciamento de sistema não adiciona novos recursos ao WSMAN.

Instalação de fábrica do iDRAC Service Module para o sistema operacional Microsoft Windows (opção do cliente)

Agora, o iSM pode ser instalado de fábrica para o sistema operacional Microsoft Windows. Com o iSM pré-instalado, é possível acessar rapidamente os documentos de suporte e os log essenciais. Ao selecionar uma instalação de fábrica do sistema operacional Microsoft Windows, é possível optar por instalar o iSM a partir das opções disponíveis.

  • iSM - Enabled — oferece a instalação de fábrica do iSM no SO Windows
  • iSM - Disabled — os clientes que não desejam ter o iSM instalado no SO devem selecionar essa opção

Monitoramento S.M.A.R.T.

O recurso de monitoramento S.M.A.R.T é compatível com discos rígidos habilitados com SATA no modo AHCI. Ele tem capacidade integrada para monitorar alertas S.M.A.R.T por meio de métodos de auditoria compatíveis com iDRAC para discos rígidos no controlador de chipset SATA. Anteriormente, um utilitário de código aberto monitorava os alertas para os discos rígidos definidos no modo RAID.

FullPowerCycle

O recurso FullPowerCycle fornece uma maneira de reiniciar a alimentação auxiliar do servidor. Uma quantidade cada vez maior de hardware de servidor é executada na alimentação auxiliar do servidor, e a solução de problemas de alguns servidores requer que você desconecte fisicamente o cabo de alimentação do servidor para reiniciar o hardware que está operando na alimentação auxiliar. Isso faz com que seja necessário desconectar/conectar fisicamente os cabos de alimentação, o que gera custo e inconveniência significativos para os clientes e a equipe de suporte. O recurso FullPowerCycle permite que o administrador conecte ou desconecte a alimentação auxiliar remotamente, sem a necessidade de estar presente no data center. Este recurso é compatível com o iDRAC9.

 

Correlação de eventos de software com falhas de hardware no Microsoft S2D.

O iSM monitora os logs de eventos para alertas ou eventos do pool de armazenamento de hardware com o recurso de correlação de armazenamento do servidor. O subsistema de armazenamento do servidor é monitorado quando os controladores de armazenamento Dell são usados no modo RAID. No entanto, em espaços de armazenamento (SS) ou Storage Space Direct (S2D), o subsistema de armazenamento do servidor é monitorado em um modo de passagem ou o chipset SATA é usado para criar o pool de armazenamento. Com esse recurso, os alertas definidos por hardware abrangidos pelo log do LifeCycle, os alertas definidos por software abrangidos pelos logs do SO são mesclados e os alertas são registrados nos logs do iDRAC Lifecycle. Esse recurso é instalado com o pacote do iDRAC Service Module e é ativado por padrão. O usuário pode alterar as preferências nas configurações do iDRAC. Como parte do monitoramento, o iSM realizará auditoria nos logs para identificar possíveis falhas e avisos. O iSM incorpora os eventos de correlação do SS do host a um evento equivalente do LC.

Despacho automático de disco do SupportAssist no iSM

Como parte da emissão de alertas preditivos, se o servidor apresentar um dos seguintes eventos SNMP: PDR16 e PDR63, o Suporte Dell enviará uma recomendação por e-mail em relação à ordem de serviço da falha preditiva ou de um bloco de disco danificado, como SSDs sujeitas aos termos e condições predominantes de licenciamento. Para criar a ordem de serviço de peças, é necessário informar um endereço de serviço ao Suporte Dell. Este recurso está disponível apenas em sistemas operacionais Windows e Linux.

Iniciador da IU do iDRAC

Inicie a interface do usuário do iDRAC a partir do sistema local, clicando duas vezes no ícone de inicialização dela. A página de log-in da IU do iDRAC é aberta no navegador padrão, e é possível usar as credenciais do iDRAC para fazer log-in na página inicial do iDRAC. Isso só é compatível nos sistemas operacionais Microsoft Windows.

Log-on único (SSO) na IU do iDRAC pela área de trabalho dos administradores do SO do host

O recurso de logon único (SSO) permite que um administrador autenticado do sistema operacional acesse diretamente a interface Web do iDRAC sem a necessidade de fazer login usando credenciais separadas de administrador do iDRAC.

Maior segurança entre a comunicação do iSM e do iDRAC usando o protocolo TLS

Ao iniciar o iSM 3.4, a comunicação de dados entre o iSM e o iDRAC ocorre por meio de soquetes USBNIC INET protegidos por TLS. Isso garante a proteção de todos os dados que são transportados do iDRAC para o iSM por meio do USBNIC. O iSM e o iDRAC usam certificados autoassinados para controlar a autenticação. Os certificados autoassinados têm 10 anos de validade. Novos certificados autoassinados são sempre gerados durante a instalação do iSM.



Painel de indicadores do iDRAC9

Aprimoramentos do Dell iDRAC Service Module

A Dell está constantemente aprimorando o Dell iDRAC Service Module.


Plataformas

O iDRAC Service Module 5.4.0.0 oferece suporte aos servidores PowerEdge 14G, 15G e 16G abaixo em todos os sistemas operacionais compatíveis.

 

 

 

 


 

Plataformas Suporte Dell
Servidores PowerEdge 14G Servidores PowerEdge 15G Servidores PowerEdge 16G
PowerEdge C4140 PowerEdge C6520 PowerEdge C6600
PowerEdge C6420 PowerEdge C6525 PowerEdge C6615
PowerEdge FC640 PowerEdge MX750c PowerEdge C6620
PowerEdge M640 PowerEdge R250 PowerEdge HS5610
PowerEdge M640p PowerEdge R350 PowerEdge HS5620
PowerEdge MX740c PowerEdge R450 PowerEdge MX760c
PowerEdge MX840c PowerEdge R550 PowerEdge R260
PowerEdge R240 PowerEdge R650 PowerEdge R360
PowerEdge R340 PowerEdge R650xs PowerEdge R660
PowerEdge R440 PowerEdge R750 PowerEdge R660xs
PowerEdge R540 PowerEdge R750xa PowerEdge R760
PowerEdge R640 PowerEdge R750xs PowerEdge R760xa
PowerEdge R740 PowerEdge R6515 PowerEdge R760xd2
PowerEdge R740xd PowerEdge R6525 PowerEdge R760xs
PowerEdge R740xd2 PowerEdge R7515 PowerEdge R860
PowerEdge R840 PowerEdge R7525 PowerEdge R960
PowerEdge R940 PowerEdge T150 PowerEdge R6615
PowerEdge R940xa PowerEdge T350 PowerEdge R6625
PowerEdge R6415 PowerEdge T550 PowerEdge R7615
PowerEdge R7415 PowerEdge XE8545 PowerEdge R7625
PowerEdge R7425 PowerEdge XR11 PowerEdge T160
PowerEdge T140 PowerEdge XR12 PowerEdge T360
PowerEdge T340 PowerEdge XR4510c PowerEdge T560
PowerEdge T440 PowerEdge XR4520c PowerEdge XE8640
PowerEdge T640   PowerEdge XE9640
PowerEdge XE2420   PowerEdge XE9680
PowerEdge XE7420   PowerEdge XR5610
PowerEdge XE7440   PowerEdge XR7620
Precision R7920   PowerEdge XR8000
    PowerEdge XR8610t
    PowerEdge XR8620t
    Precision R7960

 

Novos recursos do Dell iDRAC Service Module 5.4.0.0

  • A configuração do RAID de software oferece suporte à renomeação, à reconfiguração e à visualização do tamanho máximo para reconfigurar o disco virtual.
  • Novo suporte a SO: Ubuntu Server 24.04​, Windows Server 2025
 
 


Recursos novos e aprimorados

Área funcional Descrição do recurso Resumo dos benefícios
RAID de software Configuração de RAID de software A configuração do RAID de software oferece suporte à renomeação, à reconfiguração e à visualização do tamanho máximo para reconfigurar o disco virtual.

 

Hypervisores e sistemas operacionais empresariais de 64 bits compatíveis:

  • Windows Server 2025
  • Windows Server 2022
  • Windows Server 2019
  • Red Hat Enterprise Linux 8.10
  • Red Hat Enterprise Linux 9.4
  • SUSE Linux Enterprise Server 15SP6
  • VMware vSphere (ESXi) 8.0 U3
  • VMware vSphere (ESXi) 7.0 U3
  • Ubuntu Server 24.04
  • Suporte da comunidade ao Debian 11

 

RTOS compatível com servidores PowerEdge R650, PowerEdge R660, PowerEdge R750, PowerEdge R760, PowerEdge XR11, PowerEdge XR12, PowerEdge XR5610 e PowerEdge XR8000:

  • Red Hat Enterprise Linux 8.10
  • Red Hat Enterprise Linux 9.4
  • SUSE Linux Enterprise Server 15 SP6

 

Sistemas operacionais de client compatíveis com Precision R7920 e Precision R7960:

  • Microsoft Windows 10 22H2
  • Microsoft Windows 11 21H2/22H2/23H2
  • Red Hat Enterprise Linux 98.6
  • Ubuntu Desktop 24.04


Consulte a versão mais recente das Notas da versão do Dell iDRAC Service Module para obter a lista completa dos aprimoramentos, das limitações, dos problemas corrigidos e das falhas conhecidas.

Consulte o Dell Technologies iDRAC Service Module para obter a lista completa de todas as versões do iSM.

Causa


Configurações de iDRAC9

Download e instalação do Dell iDRAC Service Module.

O Dell iDRAC Service Module é compatível com a maioria das versões dos sistemas operacionais Microsoft Windows, Linux e ESXi para servidores PowerEdge com iDRAC7, iDRAC8 e iDRAC9. Consulte as Plataformas compatíveis (em inglês) para obter informações adicionais sobre as plataformas e os sistemas operacionais compatíveis.

A versão específica iSM para seu sistema varia de acordo com o modelo de servidor e do sistema operacional instalado. Para fazer download da versão mais recente do iSM:

  • Navegue até Dell.com/support e selecione seu modelo do servidor ou insira a etiqueta de serviço.
  • Selecione Drivers e downloads
  • Selecione o sistema operacional de seu sistema
  • Palavra-chave iSM
  • Faça download da versão mais recente fornecida para o Dell iDRAC Service Module

Consulte o Guia do usuário do iDRAC Service Module da Dell Technologies específico para sua versão e, em seguida, o tópico "Instalando o iDRAC Service Module" para obter informações sobre os requisitos de software, os requisitos do sistema e as etapas para instalar, fazer upgrade e desinstalar o iSM.

 
 

Resolución

Recursos do Dell iDRAC Service Module

Comunidade

Participe da comunidade de Gerenciamento de Sistemas para encontrar:

  • Quadros para publicar perguntas e respostas
  • Blogs para ler e comentar sobre artigos
  • Trocas de ideias para melhorar os produtos e votar em ideias publicadas por outros membros da comunidade
  • E muito mais.


Documentação

Para obter a documentação mais recente, consulte a Documentação do Dell iDRAC Service Module.


White papers

Recursos de RAID de software no iDRAC Service Module


White paper de 20 páginas de dezembro de 2024

Este white paper técnico apresenta informações sobre o recurso RAID de software no iDRAC Service Module (iSM) e orienta você pelas etapas para realizar a enumeração, a configuração e o monitoramento de controladores, discos físicos e discos virtuais conectados aos servidores Dell PowerEdge. 

Leia o white paper

Guia de configuração de segurança do Dell iDRAC Service Module


Janeiro de 2022
Guia de configuração de segurança com 29 páginas
Este documento descreve as configurações de segurança relacionadas ao Dell iDRAC Service Module (iSM), bem como sua instalação, configuração e funcionalidade no sistema operacional do host.

Leia o guia de configuração de segurança

IDRAC Service Module — recursos baseados em SO para gerenciamento fora de banda com iDRAC9


Maio de 2021
White paper com 12 páginas
Resumo dos aprimoramentos mais recentes que o iDRAC Service Module (iSM) oferece ao gerenciamento fora de banda com o iDRAC9 para os clientes nos servidores Dell PowerEdge de 14ª e 15ª geração.

Leia o white paper

iDRAC Service Module — acesso ao iDRAC por meio do sistema operacional do host


White paper de janeiro de 2017
de dezessete páginas
Este white paper apresenta informações sobre o uso e a solução de problemas dos recursos de acesso ao iDRAC usando o sistema operacional do host no iDRAC Service Module v2.3 ou posterior.

Leia o white paper

iDRAC Service Module: ativar alertas SNMP do iDRAC em banda


Janeiro de 2017
White paper de 13 páginas
Este white paper apresenta informações sobre o uso, a configuração e a solução de problemas de alertas SNMP em banda do iDRAC no iDRAC Service Module v2.3 ou posterior.

Leia o white paper

iDRAC Service Module: como executar a reinicialização forçada da CPU com iDRAC


Julho de 2016
White paper com oito páginas
Este white paper apresenta informações sobre o uso e a solução de problemas do recurso de reinicialização forçada da CPU do iDRAC no iDRAC Service Module v2.3 ou posterior.

Leia o white paper

iDRAC Service Module 2.1 (mín.) nos sistemas operacionais Ubuntu e Debian Linux


Setembro de 2015
White paper com 19 páginas
Este white paper apresenta informações sobre o uso e a solução de problemas do iDRAC Service Module v2.1 ou posterior nos sistemas operacionais Ubuntu e Debian Linux.

Leia o white paper

iDRAC Service Module: Instrumentação de Gerenciamento do Windows


Abril de 2015
White paper com 17 páginas
Este white paper explica como usar o iDRAC Service Module para monitorar os vários perfis de hardware por meio das interfaces do client da Instrumentação de Gerenciamento do Windows (WMI), como Windows PowerShell, linha de comando da Instrumentação de Gerenciamento do Windows, client de Gerenciamento Remoto do Windows (WINRM) e WBEMTEST.

Leia o white paper

Vídeos

Instalação inicial — iDRAC Service Module

 

Aprenda a instalar o iDRAC Service Module pela IU do iDRAC.

Novembro de 2017

Coleta do SupportAssist no iDRAC Service Module 3.0.1

 

Aprenda a realizar a coleta do SupportAssist usando o iDRAC Service Module 3.0.1.

Novembro de 2017

Habilitando o recurso "acesso ao iDRAC usando o sistema operacional do host" no Microsoft Windows no iDRAC Service Module 2.4

 

Aprenda a ativar e configurar o recurso de acesso ao iDRAC usando o SO de host do Microsoft Windows.

Julho de 2017

Instalar o iDRAC Service Module no sistema operacional Microsoft Windows Nano


Aprenda a instalar o iDRAC Service Module nos sistemas operacionais Microsoft Windows Nano.

Julho de 2017

Ativando o recurso de acesso ao iDRAC usando o SO de host do Linux no iSM 2.4

 

Saiba como habilitar o acesso do iDRAC em banda nos sistemas Linux.

Julho de 2017

Como exibir traps SNMP do iDRAC recebidas do sistema operacional do host no Linux no iSM 2.4

 

Saiba como visualizar as traps SNMP do iDRAC recebidas do sistema operacional do host nos sistemas operacionais Linux.

Julho de 2017

Como monitorar servidores Dell por meio do iDRAC Service Module usando WMI

 

Fala sobre o processo de monitoramento de servidores Dell por meio do iDRAC Service Module (iSM) usando a Instrumentação de Gerenciamento do Windows (WMI) para o Dell Server Management Pack Suite versão 6.3 em um ambiente do Microsoft System Center Operations Manager (SCOM).

Outubro de 2024

Productos afectados

iDRAC Service Module

Productos

iDRAC7, iDRAC8, iDRAC9, Lifecycle Controllers
Propiedades del artículo
Número de artículo: 000178050
Tipo de artículo: Solution
Última modificación: 02 ene 2025
Versión:  26
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