Omitir para ir al contenido principal
  • Hacer pedidos rápida y fácilmente
  • Ver pedidos y realizar seguimiento al estado del envío
  • Cree y acceda a una lista de sus productos
Es posible que algunos números de artículo hayan cambiado. Si esto no es lo que está buscando, intente buscar todos los artículos. Buscar artículos

How to Troubleshoot Touch Screen or Touch Panel Issues

Resumen: This article provides information about how to troubleshoot touch screen issues on touch-enabled Dell all-in-one desktops, laptops, and Dell monitors.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

The touch-enabled display or screen on Dell All-in-One desktops, laptops, and monitors can experience symptoms like:

  • Touch screen not working.
  • Touch screen not working intermittently.
  • Touch screen does not respond or responds inaccurately.

Causa

Touch screens can stop working or responding accurately because the display is not touch-capable, driver incompatibility, calibration issues, and so on.

Follow the troubleshooting steps mentioned below in the sequence to resolve touch screen issues.

Resolución

In Microsoft Windows
  1. In Windows, search for and open View pen and touch info
  2. Under Device Specifications, if the Pen and touch section reads No pen or touch input is available for this display, the computer does not have a touch screen.
System configuration

Check the original system configuration or monitor specifications on the Dell.com/support website.

NOTE: For technical specifications of a third-party or non-Dell monitor, see the device manufacturer's website.
NOTE: For touch-enabled Dell monitors, verify that the USB cable is connected from the monitor to the computer to enable the touch screen feature. To learn more about how to connect the USB cable between the monitor and the computer, see the documentation of the Dell monitor.

If the touch screen issue persists, go to the next step.

A simple reboot can resolve many issues almost immediately. Restarting the computer is an effective way to clear the memory (RAM) and ensure that any errant processes and services that have started are shut down.

Restarting the computer closes all the applications and software that are running on the computer. This includes applications running on the taskbar and services that are running in the background.

WARNING: Before restarting the computer, ensure to bookmark open web pages, save open documents, spreadsheets, or other unsaved work, and so on.

If the touch screen issue persists, go to the next step.

  1. Turn off the computer and disconnect the power cable.
    1. Dell All-in-One desktops - Disconnect the power cable or the AC adapter cable from the computer.
    2. Dell laptops - Disconnect the AC adapter from the computer.
    3. Dell monitors - Disconnect the power cable from the monitor.
  2. Use an anti-static brush and gently brush the dust or dirt particles away from the LCD screen.
  3. Use a soft and clean microfiber cloth that is lightly dampened with water to clean the monitor. Avoid using detergents of any kind as they can leave a milky film on the monitor.
  4. To clean the anti-static screen, we recommend using a special screen-cleaning tissue or solution that is suitable for the anti-static coating on LCD panels.
  5. Let the LCD screen dry thoroughly before you plug in the power cable and turn it back on.
NOTE: Sometimes, the screen protector or screen guard may prevent the touch screen from registering that you are touching the screen and must be removed (this may occur if it is not designed for a capacitive touch screen or if it has air bubbles in it).
NOTE: Using a non-standard or unsupported digital pen, stylus, or regular pen to write can damage the touch screen. Select Dell 2-in-1 laptops are compatible with digital pens like the Dell Active Pen. See the documentation of the Dell 2-in-1 laptop or Dell Active Pen for more information.

If the touch screen issue persists, go to the next step.

The touch screen of the computer may not respond because it is disabled or it must be reinstalled. Use Windows Device Manager to enable or reinstall the touch screen driver.

NOTE: For touch-enabled Dell monitors, verify that the USB cable is connected from the monitor to the computer to enable the touch screen feature. To learn more about how to connect the USB cable between the monitor and the computer, see the documentation of the Dell monitor.

To reinstall or enable the touch screen driver:

  1. Press Windows key + R to open the Run dialog box.
  2. In the Run dialog box, type devmgmt.msc and click OK.
  3. In the Device Manager window, expand Human Interface Devices.
  4. Right-click the HID-compliant touch screen and select Enable.
  5. Test the touch screen. If the touch screen fails to respond, go to the next step.
  6. Right-click the HID-compliant touch screen and select Uninstall.
  7. In the Uninstall Device window, click Uninstall to confirm.
  8. Restart the computer.
NOTE: The touch screen drivers are built in to the latest operating systems such as Windows 11 and 10. Windows Update helps download the latest touch screen driver that is applicable to your computer (if required).

If the touch screen issue persists, go to the next step.

How to calibrate the touch screen in Windows 11 an 10?
  1. Open Control Panel
  2. Click Hardware and Sound.
  3. Under Tablet PC Settings, click the Calibrate the screen for pen or touch input.
  4. Under Display options, select the display (if applicable).
  5. In the Tablet PC Settings windows, click the Calibrate.
  6. Select Touch input.
  7. In the white screen, tap the crosshair each time it appears on the screen, and do not change the resolution during this process.
  8. Click Yes when you are prompted to save the calibration data.
  9. Click OK to confirm.
NOTE: Using a non-standard or unsupported digital pen, stylus, or a regular pen to write can damage the touch screen. Select Dell 2-in-1 laptops are compatible with digital pens such as the Dell Active Pen. See the documentation of the Dell 2-in-1 laptop or Dell Active Pen for more information.

If the touch screen issue persists, go to the next step.

Windows updates can support your Windows operating system in many ways. Windows updates can solve specific problems, provide protection from malicious attacks, or even add new features to the operating system.

How to run Windows Updates on Microsoft Windows 11 and 10?
  1. Right-click Start and click Settings.
  2. In the Settings panel, click Update & Security.
  3. In the left panel, select Windows Update.
  4. In the right panel, click Check for updates.
  5. Restart the computer after downloading and installing the updates.

If the touch screen issue persists, go to the next step.

  1. Browse to the Dell.com/support website.
  2. Identify your Dell computer:
    1. Enter the model number or Service Tag of the computer, and then click Search.
    2. Or, click Browse all products and select your Dell computer from the catalog.
  3. Click the Diagnostics tab.
  4. Under Custom Component Test, click Select individual components.
  5. Under Monitor & screen, select Touch screen.
  6. Click Run Your Test and follow the on-screen instructions.
  7. If the diagnostic test passes, but the touch screen still does not respond, go to the next step.
  8. If the diagnostic test fails, contact Dell Technical Support for repair options.
NOTE: If Dell SupportAssist is not installed on your computer, you are prompted to complete the installation to run the diagnostic test. Follow the on-screen instructions to complete the installation process of Dell SupportAssist.

If the touch screen issue persists, go to the next step.

Power settings can cause the touch screen to stop working after waking the computer from sleep mode. Change the power settings so that the touch screen stays active while the computer is in sleep mode.

  1. Press Windows key + R to open the Run dialog box.
  2. In the Run dialog box, type devmgmt.msc and click OK.
  3. In the Device Manager window, expand Human Interface Devices.
  4. Right-click the HID-compliant touch screen and select Properties.
  5. Under the Power Management tab, clear Allow the computer to turn off this device to save power, and then click OK.

If the touch screen issue persists, go to the next step.

Dell Technologies recommends updating the device drivers and BIOS as part of your scheduled update cycle. These device drivers and BIOS updates may contain feature enhancements or changes that help keep your system software current and compatible with other system modules (hardware and software) as well as increased stability.

It is essential to update the following device drivers for optimal touch screen performance and to resolve common touch screen issues:

  • BIOS
  • Video card (GPU) driver
  • Dell monitor driver (if applicable)
  • Touch screen or touch panel firmware (if applicable)
NOTE: The touch screen or touch panel firmware drivers are not available for all Dell laptops or monitors. Update the firmware only if available.

Learn How to Download and Install Dell Drivers.

NOTE: To download drivers for a third-party or non-Dell monitor, see the device manufacturer's website.

If the touch screen issue persists, go to the next step.

System Restore is an integrated Windows tool that is designed to protect and repair the operating system. When something goes wrong with your computer, System Restore must be used before restoring the computer to factory defaults.

Learn How to Use System Restore in Microsoft Windows.

If the touch screen issue persists, go to the next step.

Dell computers are built with a small amount of hard disk space that is reserved for reinstalling the operating system. This method is the easiest way to restore your Dell computer to factory condition. The restoration process deletes all user data from the computer, so be sure to back up all your files before starting this process.

Learn how to Restore your Computer Using SupportAssist OS Recovery.

If the touch screen issue persists, contact Dell Technical Support.

Información adicional

Productos afectados

Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Latitude, Vostro, XPS, Legacy Laptop Models, Fixed Workstations, Mobile Workstations, Dell C5518QT, Dell C5522QT, Dell C6522QT, Dell C7017T , Dell C7520QT, Dell C8618QT, Dell C8621QT, Dell E157FPT, Dell E2014T, Dell P2314T, Dell P2418HT, Dell P2714T, Dell S2240T 21.5 Multi-Touch Monitor with LED, Dell S2340T, Dell ST2220T, Dell SX2210T ...
Propiedades del artículo
Número del artículo: 000132121
Tipo de artículo: Solution
Última modificación: 22 nov 2024
Versión:  12
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.