Symptoms
The hard drive where the Avamar client writes log files may become full. This causes subsequent backups to fail due to inability to write new log files.
Disk space on the Windows client where the Avamar client software is installed (usually C drive) is running out due to paging cache files (named f_cache2.dat) growing increasing larger.
Cause
Starting in Avamar v7.0, a new client cache (demand-paging cache) format has been introduced. To minimize RAM requirements, the client loads small parts of the demand-paging cache to RAM depending on the directory currently being processed by the backup.
The cache will adjust its size automatically in relation to the type and amount of data which the client backs up.
The size of the demand-paging cache on the disk is around 20 times higher than the size of the monolithic cache (file and hash cache).
The size of the demand-paging file cache is about 1 GB per 10 million of files on the client * 16 consecutive backups that are kept in the cache for the client.
The approximate size of the demand-paging file cache can be calculated using the following formula: (# of millions of files)/10 * 1 GB * 16 = (# of GB required for demand-paging file cache)
Resolution
Create an avtar.cmd file in the avs\var directory and add the following flag:
--vardir=<<drive volume and var folder>>
Example:
--vardir=D:\avs\var
This flag re-directs the cache files and logs to the specified drive and folder.
Create the var directory on the alternate drive and then copy the existing cache files to the new folder before the next scheduled backup.
Also be aware of the following KB articles:
Affected Products
Avamar Client
Products
Avamar Client