Dell NativeEdge: Virtual Machine issues with Serial Passthrough

Summary: This article outlines the steps to take if a guest Virtual Machine (VM) with a serial passthrough appears to stop responding on boot.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A Linux based VM with serial passthrough may fail to boot fully.
 

Cause

The guest VM with serial passthrough as the guest VM is using ttys0 for boot console as this causes a conflict with the serial passthrough from the NativeEdge Endpoint, when serial passthrough is active.

Resolution

This issue is resolved in NativeEdge 2.2.0.0.
 

Workaround:

For cloud image customizations NativeEdge Engineering recommends the following:

  1. Check the kernel command line for console=ttyS0
cat /proc/cmdline
  1. Edit the grub configuration
vi /etc/default/grub.d/50-cloudimg-settings.cfg
  1. Remove console=ttyS0 or replace it with a virtual tty for example, tty2.
    • Note: tty[n] are virtual consoles, ttyS[n] are physical ports during serial passthrough.
  2. Regenerate grub configuration files
update-grub
  1. Shutdown or reboot the VM

Additional Information

The following are examples of possible occurrences of this issue:
  • Telit_DeviceWISE_Edge_Gateway_for_NativeEdge_Endpoint_2.0.0
  • Litmus_Edge_for_NativeEdge_Endpoint_2.0.0
  • Custom blueprint with Serial Passthrough and Ubuntu image

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000225442
Article Type: Solution
Last Modified: 07 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.