Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Dell Unity: El cliente NFS de RHEL no puede montar el recurso compartido NFS de Unity; se recibió el error "NFS4ERR_MINOR_VERS_MISMATCH"

Summary: Rojo Si el cliente Enterprise Linux no pudo montar el recurso compartido NFS del servidor NAS de Unity. Recepción de NFS4ERR_MINOR_VERS_MISMATCH de error. (Corregible por el usuario)

This article applies to   This article does not apply to 

Symptoms

El usuario estaba realizando una "prueba de validación de interrupción de enlace de red". Después de que el usuario restauraba el acceso de conectividad de red, todos los clientes NFS, excepto un cliente Red Had Enterprise Linux, podían reanudar el acceso de NFS a los recursos compartidos NFS de Unity.

 

Los seguimientos de red tomados simultáneamente entre Unity y el cliente Red Had Enterprise Linux muestran que el cliente Red Had Enterprise Linux intentaba montar el recurso compartido NFS de Unity mediante NFSv4.2.

NFS V4 Call (Reply In 13) EXCHANGE_ID
NFS V4 Reply (Call In 12) Status: NFS4ERR_MINOR_VERS_MISMATCH

 

Cause

Los seguimientos capturaron al cliente NFSv4 que emite una solicitud de EXCHANGE_ID con una versión secundaria "2" que recibe una respuesta de Unity de NFS4ERR_MINOR_VERS_MISMATCH (10021), lo que indica que esta versión secundaria no es compatible con Unity.

 

Resolution

Después de NFS4ERR_MINOR_VERS_MISMATCH respuesta (10021), el cliente NFSv4 tiene la responsabilidad de revertir la versión secundaria de "2" a "1" o a "0" (o utilizar NFSv3) recae en el cliente.

Se recomienda un "Reinicio" del host NFSv4. A continuación, el host intenta negociar con una versión secundaria compatible.

 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000216055
Article Type: Solution
Last Modified: 27 May 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.