Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

PowerVault ME5: 관리 인터페이스에 액세스할 수 없거나 응답하지 않습니다.

Summary: 관리자가 PowerVault Manager에 액세스할 수 없거나, SSH 세션을 열 수 없거나, 직렬 세션에 로그인할 수 없다고 보고할 수 있습니다. 스토리지 컨트롤러는 연결된 프런트엔드 호스트에 데이터를 계속 제공합니다. 컨트롤러 펌웨어를 버전 ME5.1.2.1.0 이상으로 업그레이드합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

MC(Management Controller) 및 SC(Storage Controller)는 ME Series 어레이의 개별 하위 시스템입니다. 어레이는 계속해서 I/O를 처리하지만 모든 관리 인터페이스(UI, SSH, 직렬, SNMP 또는 REST API)가 응답하지 않습니다.

참고: 원래 문서에서는 ME5.1.2.0.1 이상으로 업그레이드할 것을 권장했습니다. 이 문서는 컨트롤러 펌웨어 ME5.1.2.1.0 이상으로 업그레이드하도록 업데이트되었습니다. 여기에는 SNMP 또는 REST API 호출을 사용하는 외부 관리 애플리케이션의 프로브에서 관리 컨트롤러가 재시작되지 않도록 하는 추가 수정 사항이 포함되어 있습니다.

일반적인 증상:

  • PowerVault Manager UI에 액세스할 수 없습니다.
  • 하나 또는 두 관리 인터페이스 모두에 대한 SSH 세션을 열 수 없습니다.
  • 직렬 세션 CLI 포트에 로그인할 수 없음
  • 어레이가 외부 관리 애플리케이션(SNMP 또는 REST API)에 응답하지 않거나 외부 관리 애플리케이션에서 사라집니다.

나중에 이벤트 로그를 검토할 때는 아래의 해결 단계를 참조하십시오. 진행 중인 펌웨어 업그레이드가 없는 경우에도 관리자는 이벤트 내역 로그에 다음 항목을 볼 수 있습니다.

...
B849       2023-08-08 01:08:16  152   WARNING        The Storage Controller is not receiving data from the Management Controller. (This is normal during firmware update.)
...

 

Cause

메모리 부족 상태가 발생하면 관리 애플리케이션 프로세스가 종료됩니다. 외부 관리 애플리케이션이 SNMP 또는 REST API를 사용하여 관리 인터페이스를 폴링하는 환경에서는 이러한 문제가 더 자주 발생할 수 있습니다.

ME5 릴리스 노트:
FMW-65056 응답하지 않는 CLI 및 사용자 인터페이스를 초래할 수 있는 조건을 해결합니다.

영향을 받을 수 있는 시스템은 무엇입니까?

제품(및 버전) 다음과 같은 Dell PowerVault ME5 Series 스토리지 시스템
  • PowerVault ME5012
  • PowerVault ME5024
  • PowerVault ME5084
이 핵심 소프트웨어 실행 여부
(운영 체제 또는 운영 환경)
PowerVault ME5 컨트롤러 펌웨어 버전 ME5.1.2.0.1 미만

 

Resolution

  1. 가능한 경우 각 컨트롤러 관리 인터페이스에 대한 SSH 세션 또는 USB 직렬 연결을 열고 관리 컨트롤러 서비스를 다시 시작해 보십시오. 이 작업이 성공하면 컨트롤러 펌웨어를 업그레이드합니다.
  2. SSH 또는 USB 직렬을 사용하여 로그인할 수 없는 경우 영향을 받는 컨트롤러 모듈 중 하나를 물리적으로 다시 장착해야 합니다. 이 컨트롤러에서 관리 제어가 복구되면 피어 컨트롤러를 재시작합니다. 단일 컨트롤러 모듈이 있거나 경로 이중화가 없는 호스트가 구성된 어레이에서는 유지 보수 기간을 정하고 호스트를 종료한 다음 어레이의 전원을 꺼야 합니다.
  3. 두 컨트롤러 모듈에 대한 관리 액세스가 다시 설정되면 컨트롤러 모듈 펌웨어를 버전 ME5.1.2.1.0 이상으로 업그레이드합니다.

절차:

1단계: 두 컨트롤러 모두에서 관리 서비스를 재시작해 봅니다.

  • 일부 상황에서는 이 단계가 가능하지 않을 수 있습니다. 관리 컨트롤러를 재시작해도 운영에는 영향을 주지 않습니다.
  • 이 단계를 수행하면 관리 세션이 종료되고 약 2-3분 후에 서비스가 재시작되면 관리 액세스가 복원됩니다.
  • 두 컨트롤러 모듈 모두에서 관리 서비스를 성공적으로 재시작할 수 있는 경우 3단계로 이동합니다. 컨트롤러 모듈 펌웨어를 ME5.1.2.1.0 이상으로 업그레이드합니다.
  1. 각 컨트롤러의 관리 인터페이스에 대한 SSH 세션을 열고 관리 또는 관리자 수준의 사용자로 로그인합니다. 또는 관리자가 각 컨트롤러에 대해 USB 직렬 연결을 시도할 수 있습니다. SSH 또는 직렬 연결을 사용하여 로그인할 수 없는 경우 2단계로 이동합니다. 1개의 컨트롤러 모듈을 물리적으로 다시 장착하거나 어레이의 전원을 끕니다.

  2. 로그인에 성공하면 다음 명령을 사용하여 각각에서 관리 컨트롤러를 다시 시작합니다.

    restart mc full
    
    # restart mc full
    During the restart process you will briefly lose communication with the specified Management Controller(s).
    Do you want to continue? (y/n) y
    
    Info: Restarting the local MC (A)...
    Success: Command completed successfully. (2023-08-24 05:34:01)
    # Killed

2단계: 1개의 컨트롤러 모듈을 물리적으로 다시 장착하거나 어레이의 전원을 끕니다.

주의: 컨트롤러를 제거하면 데이터에 대한 호스트 액세스가 중단될 수 있으며 경우에 따라 예상치 못한 운영 중단이나 잠재적인 데이터 손실을 방지하기 위해 호스트 I/O를 미리 중지해야 합니다.

시나리오 1: 이중화 경로 호스트 구성
이 있는 이중 컨트롤러이러한 단계는 유지 관리 기간 없이 구현할 수 있습니다.

다음 조건이 충족되어야 합니다.

  • 호스트에는 컨트롤러 A 및 B에 대한 연결 경로가 있어야 합니다.
  • 호스트에는 다중 경로 지원이 구성되고 활성화되어 있어야 합니다.
  • 모든 호스트 이니시에이터를 볼륨에 매핑해야 합니다.

지침은 Dell PowerVault ME5 Series 스토리지 시스템 소유자 매뉴얼모듈 제거 및 교체>고객 교체 가능 부품 섹션을 참조하십시오.

  1. 컨트롤러 모듈 B를 해당 슬롯에서 약 5cm 또는 약 2인치 앞으로 물리적으로 당긴 다음 30초 후에 컨트롤러 모듈을 다시 장착합니다.

  2. 컨트롤러 B가 부팅과 펌웨어 로드를 완료하는 데 약 2-3분 정도 소요합니다.

  3. 컨트롤러 B 관리 IP 주소에 대한 SSH 세션을 열고 관리 또는 관리자 수준 사용자로 로그인합니다.

  4. 피어 스토리지 컨트롤러 A를 재시작합니다. 다음 명령을 입력합니다.

    restart sc a
    
    # restart sc a  While a Storage Controller is restarting, communication will temporarily be lost with the corresponding Management Controller, and also may cause a temporary loss of data availability. Do you want to continue? (y/n) y Success: Command completed successfully. - The command to restart SC A completed successfully. The controller will restart in approximately 30 seconds. (2023-08-24 07:08:39)
  5. 피어 컨트롤러가 온라인 상태이면 PowerVault Manager에 로그인하고 3단계로 이동합니다. 컨트롤러 모듈 펌웨어를 ME5.1.2.1.0 이상으로 업그레이드합니다.

시나리오 2: 싱글 컨트롤러 모듈 또는 비이중화 호스트 경로 구성
유지 보수 기간이 필요합니다. 데이터에 대한 단일 경로를 예기치 않게 제거하면 호스트가 데이터에 액세스할 수 없게 되고 응답이 중지됩니다.

지침은 Dell PowerVault ME5 Series 스토리지 시스템 소유자 매뉴얼모듈 제거 및 교체>고객 교체 가능 부품 섹션을 참조하십시오.

  1. 사용자에게 운영 중단을 알리고 호스트 운영 체제 사용자 가이드에 따라 연결된 호스트를 유지 보수 모드로 전환하거나 호스트를 종료합니다.

  2. 어레이 후면에서 두 전원 공급 장치의 전원을 약 60초 간 끈 다음 다시 켭니다.

  3. 컨트롤러가 부팅을 완료하고 펌웨어를 로드하는 데 약 3분이 소요됩니다.

  4. PowerVault Manager에 로그인하고 3단계로 이동합니다. 컨트롤러 모듈 펌웨어를 ME5.1.2.1.0 이상으로 업그레이드합니다.

3단계: 컨트롤러 모듈 펌웨어를 ME5.1.2.1.0 이상으로 업그레이드합니다.

Dell PowerVault ME5 Series 관리자 가이드시스템 펌웨어 업데이트 섹션을 참조하십시오.

  • 컨트롤러 펌웨어 업데이트를 다운로드합니다. 웹 브라우저에서 Dell 지원을 엽니다.
  • PowerVault ME 서비스 태그를 입력하거나 PowerVault ME 모델을 선택합니다.
  • Documentation 아래에서 Dell PowerVault ME5 Storage System Release Notes를 선택합니다.
  • 드라이브 및 다운로드 탭에서 Dell PowerVault ME5 Series 스토리지 컨트롤러 펌웨어를 다운로드합니다
  • .zip 파일에서 펌웨어 바이너리를 추출합니다.
  • Dell PowerVault Manager를 사용하는 것입니다. MaintenanceFirmware>System> 으로 이동하여 펌웨어 바이너리 파일을 업로드합니다.
  • MaintenanceFirmware>System> 으로 이동하고 Activate this Version 링크를 클릭하여 대화 상자를 표시합니다.
  • 화면의 지시에 따라 활성화를 시작합니다.

업그레이드 후 동작:

ME5 컨트롤러 펌웨어 버전 ME5.1.2.0.1 이상을 사용하는 관리자는 경우에 따라 다음과 같은 정보 알림을 받을 수 있습니다.
정보 알림
그림 1 : 정보 알림

The Management Controller entered a memory exhaustion state and will reboot to recover. Data access will not be interrupted.

MC(Management Controller)는 시스템을 모니터링하고 구성하기 위한 관리 UI 및 CLI 인터페이스를 제공합니다. 관리 서비스를 재시작해도 컨트롤러가 재부팅되거나 I/O가 중단되지 않습니다. 재시작하면 2분 동안 관리 인터페이스에 액세스할 수 없습니다. 이 정보 알림을 자주 받는 경우 원인을 규명하기 위해 추가 조사가 필요할 수 있습니다.

참고: 시스템 관리자는 네트워크 스위치의 브로드캐스트 스톰 또는 스패닝 트리 루프, 보안 취약성 테스트 제품군 또는 REST API를 사용하는 외부 스크립트와 같이 서비스 거부를 생성하는 이더넷 스위치 장애 조건을 주의해야 하며, 이 상태에서는 여러 세션을 생성하고 매초 어레이를 폴링하여 관리 인터페이스에 연결할 수 없는 동일한 증상이 발생할 수 있습니다.

 

Affected Products

ME Series, PowerVault ME5012, PowerVault ME5024, PowerVault ME5084
Article Properties
Article Number: 000215402
Article Type: Solution
Last Modified: 24 Oct 2024
Version:  16
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.