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PowerVault ME5 : L’interface de gestion est inaccessible ou ne répond pas

Summary: Les administrateurs peuvent signaler qu’ils ne peuvent pas accéder à PowerVault Manager, qu’ils ne peuvent pas ouvrir une session SSH ou se connecter à une session série. Le contrôleur de stockage continue de servir des données aux hôtes front-end connectés. Mettez à jour le firmware du contrôleur vers la version ME5.1.2.1.0 ou supérieure. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le contrôleur de gestion (MC) et le contrôleur de stockage (SC) sont des sous-systèmes distincts sur les baies de la série ME. La baie continue à servir les E/S, mais toutes les interfaces de gestion (interface utilisateur, SSH, série, SNMP ou API REST) ne répondent pas.

Remarque : L’article d’origine recommandait une mise à niveau vers ME5.1.2.0.1 ou une version ultérieure. Cet article a été mis à jour pour recommander la mise à niveau du firmware du contrôleur vers la version ME5.1.2.1.0 ou ultérieure. Cette version contient des correctifs supplémentaires pour empêcher le contrôleur de gestion de redémarrer lors d’envois-test d’applications de gestion externes qui utilisent SNMP ou des appels d’API REST.

Symptômes typiques :

  • L’interface utilisateur de PowerVault Manager est inaccessible.
  • Impossible d’ouvrir une session SSH vers une ou les deux interfaces de gestion.
  • Connexion au port CLI de la session série impossible
  • La baie ne répond pas ou a disparu des applications de gestion externes (SNMP ou API REST).

Lors de la vérification ultérieure des journaux d’événements, reportez-vous aux étapes de résolution ci-dessous. Les administrateurs peuvent voir l’entrée suivante dans le journal de l’historique des événements, même si aucune mise à niveau du firmware n’est en cours.

...
B849       2023-08-08 01:08:16  152   WARNING        The Storage Controller is not receiving data from the Management Controller. (This is normal during firmware update.)
...

 

Cause

Mémoire insuffisante entraînant l’arrêt des processus d’application de gestion. Les implications peuvent être plus fréquentes dans les environnements où les applications de gestion externes interrogent les interfaces de gestion à l’aide de SNMP ou de l’API REST.

Notes de mise à jour ME5 :
FMW-65056 Résout une condition susceptible d’éviter les problèmes de non-réponse de la CLI et de l’interface utilisateur.

Quels systèmes peuvent être concernés ?

Produit (et version) Les systèmes de stockage Dell PowerVault série ME5 suivants
  • PowerVault ME5012
  • PowerVault ME5024
  • PowerVault ME5084
Exécution de ce logiciel principal
(Système d'exploitation ou environnement d'exploitation)
Version du firmware du contrôleur PowerVault ME5 ANTÉRIEURE À la version ME5.1.2.0.1.

 

Resolution

  1. Si possible, essayez d’ouvrir une session SSH ou une connexion série USB sur chaque interface de gestion de contrôleur et redémarrez les services de contrôleur de gestion. Si cette opération réussit, mettez à niveau le firmware du contrôleur.
  2. Dans les cas où il n’est pas possible de se connecter à l’aide de SSH ou d’une connexion série USB, il est nécessaire de réinstaller physiquement l’un des modules de contrôleur concernés. Une fois le contrôle de gestion rétabli sur ce contrôleur, redémarrez son contrôleur homologue. Sur une baie qui dispose d’un seul module de contrôleur ou de configurations qui ont des hôtes sans redondance de chemin, il est nécessaire d’organiser une fenêtre de maintenance, d’arrêter les hôtes, puis de mettre la baie hors tension.
  3. Une fois que l’accès au contrôle des modules de contrôleur a été rétabli, mettez à jour le firmware des modules de contrôleur vers la version ME5.1.2.1.0 ou une version ultérieure.

Procédure :

Étape 1 : Essayez de redémarrer les services de gestion sur les deux contrôleurs.

  • Cette étape peut ne pas être possible dans toutes les circonstances. Le redémarrage du contrôleur de gestion n’impacte pas la production.
  • Cette étape met fin à la session de gestion, et l’accès de gestion est restauré après environ deux ou trois minutes lorsque les services sont redémarrés.
  • Si les services de gestion peuvent être redémarrés avec succès sur les deux modules de contrôleur, passez à l’étape 3 : Mise à niveau du firmware du module de contrôleur vers ME5.1.2.1.0 ou une version ultérieure.
  1. Ouvrez une session SSH sur l’interface de gestion de chaque contrôleur et connectez-vous en tant qu’utilisateur de niveau gestion ou administrateur. Un administrateur peut aussi tenter de se connecter en utilisant une connexion série USB sur chacun des contrôleurs. S’il n’est pas possible de se connecter à l’aide de SSH ou d’une connexion série, passez à l’étape 2 : Réinstallation physique d’un module de contrôleur ou mise hors tension d’une baie.

  2. Si la connexion réussit, redémarrez le contrôleur de gestion à l’aide de la commande suivante :

    restart mc full
    
    # restart mc full
    During the restart process you will briefly lose communication with the specified Management Controller(s).
    Do you want to continue? (y/n) y
    
    Info: Restarting the local MC (A)...
    Success: Command completed successfully. (2023-08-24 05:34:01)
    # Killed

Étape 2 : Réinstallation physique d’un module de contrôleur ou mise hors tension d’une baie.

ATTENTION : La suppression des contrôleurs peut perturber l’accès de l’hôte aux données et, dans certaines circonstances, nécessite l’arrêt préalable des E/S de l’hôte pour éviter une panne inattendue ou une perte potentielle de données.

Scénario 1 : Double contrôleur avec configuration hôte de chemin redondant
Ces étapes peuvent être mises en œuvre sans fenêtre de maintenance.

Les conditions suivantes doivent être réunies :

  • Les hôtes doivent disposer d’un chemin de connexion aux contrôleurs A et B.
  • La prise en charge du multipath doit être configurée et activée sur les hôtes.
  • Tous les initiateurs hôtes doivent être mappés aux volumes.

Pour obtenir des conseils, voir la section Retrait et remplacement des modules > Modules remplaçables par l’utilisateur dans le Manuel du propriétaire du système de stockage de la série Dell PowerVault ME5.

  1. Tirez physiquement le module de contrôleur B vers l’avant dans son logement d’environ cinq centimètres, puis réinstallez le module de contrôleur après 30 secondes.

  2. Prenez entre deux et trois minutes pour que le contrôleur B termine son processus de démarrage et de chargement du firmware.

  3. Ouvrez une session SSH vers l’adresse IP de gestion du contrôleur B et connectez-vous en tant qu’utilisateur de niveau gestion ou administrateur.

  4. Redémarrez le contrôleur de stockage homologue A. Saisissez la commande :

    restart sc a
    
    # restart sc a  While a Storage Controller is restarting, communication will temporarily be lost with the corresponding Management Controller, and also may cause a temporary loss of data availability. Do you want to continue? (y/n) y Success: Command completed successfully. - The command to restart SC A completed successfully. The controller will restart in approximately 30 seconds. (2023-08-24 07:08:39)
  5. Lorsque le contrôleur homologue est en ligne, connectez-vous à PowerVault Manager et passez à l’étape 3 : Mise à niveau du firmware du module de contrôleur vers ME5.1.2.1.0 ou une version ultérieure.

Scénario 2 : Module de contrôle unique ou configuration de chemin d’accès à l’hôte non redondante
Une fenêtre de maintenance est requise. Supprimer sans préavis le seul chemin d’accès aux données entraîne la perte de l’accès à celles-ci par l’hôte, qui cesse alors de répondre.

Pour obtenir des conseils, voir la section Retrait et remplacement des modules > Modules remplaçables par l’utilisateur dans le Manuel du propriétaire du système de stockage de la série Dell PowerVault ME5.

  1. Avertissez les utilisateurs de la panne et suivez le guide de l’utilisateur du système d’exploitation hôte pour mettre l’hôte connecté en mode maintenance ou arrêter les hôtes.

  2. À l’arrière de la baie, éteignez les deux blocs d’alimentation pendant environ 60 secondes avant de les remettre sous tension.

  3. Donnez aux contrôleurs environ trois minutes pour achever leur démarrage et charger leur firmware.

  4. Connectez-vous à PowerVault Manager et passez à l’étape 3 : Mise à niveau du firmware du module de contrôleur vers ME5.1.2.1.0 ou une version ultérieure.

Étape 3 : Mise à niveau du firmware du module de contrôleur vers ME5.1.2.1.0 ou une version ultérieure.

Voir la section Mise à jour du firmware du système dans le Guide de l’administrateur de la série Dell PowerVault ME5.

  • Téléchargez la mise à jour du firmware du contrôleur. Dans un navigateur Web, ouvrez le site de support Dell
  • Saisissez l’étiquette de service PowerVault ME ou sélectionnez le modèle PowerVault ME.
  • Sous Documentation, sélectionnez Dell PowerVault ME5 Storage System Release Notes.
  • Sous l’onglet Drives and Downloads, téléchargez le Dell PowerVault ME5 Series Storage Controller Firmware
  • Extrayez le fichier binaire du firmware à partir du fichier .zip.
  • Avec Dell PowerVault Manager : Accédez à Maintenance > Firmware > System et téléchargez le fichier binaire du firmware.
  • Accédez à Maintenance > Firmware > System et cliquez sur le lien Activate this Version afin d’afficher la boîte de dialogue.
  • Suivez les indications à l’écran pour commencer l’activation.

Comportement après la mise à niveau :

Avec la version ME5.1.2.0.1 ou supérieure du firmware du contrôleur ME5, les administrateurs peuvent parfois recevoir l’alerte d’informations suivante.
alerte d’information
Figure 1 : Alerte d’information

The Management Controller entered a memory exhaustion state and will reboot to recover. Data access will not be interrupted.

Le contrôleur de gestion (MC) fournit l’interface utilisateur de gestion et l’interface CLI pour surveiller et configurer le système. Le redémarrage des services de gestion ne redémarre pas les contrôleurs et n’interrompt pas les E/S. L’effet du redémarrage est une incapacité à accéder à l’interface de gestion pendant deux minutes. Si vous recevez fréquemment cette alerte d’information, une enquête plus approfondie peut être nécessaire pour en établir la cause.

Remarque : Les administrateurs système doivent se méfier des conditions de défaillance des commutateurs Ethernet qui créent un déni de service, telles que les tempêtes de diffusion ou les boucles Spanning Tree sur les commutateurs réseau, les suites de tests de failles de sécurité ou les scripts externes utilisant l’API REST qui s’exécutent en boucle constante créant plusieurs sessions et interrogeant la baie toutes les secondes, ce qui peut entraîner les mêmes symptômes, l’interface de gestion devenant inaccessible.

 

Affected Products

ME Series, PowerVault ME5012, PowerVault ME5024, PowerVault ME5084
Article Properties
Article Number: 000215402
Article Type: Solution
Last Modified: 24 Oct 2024
Version:  16
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