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PowerVault ME5 : L’interface de gestion est inaccessible ou ne répond pas

Summary: Les administrateurs peuvent signaler qu’ils ne peuvent pas accéder à PowerVault Manager, ouvrir une session SSH ou se connecter à une session série. Le contrôleur de stockage continue de servir les données aux hôtes front-end connectés. Mettez à niveau le firmware du contrôleur vers la version ME5.1.2.1.0 ou ultérieure. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le contrôleur de gestion (MC) et le contrôleur de stockage (SC) sont des sous-systèmes distincts sur les baies de la série ME. La baie continue de traiter les E/S, mais toutes les interfaces de gestion (interface utilisateur, SSH, série, SNMP ou API REST) ne répondent pas.

Remarque : L’article original conseillait d’effectuer une mise à niveau vers ME5.1.2.0.1 ou une version ultérieure. Cet article a été mis à jour pour conseiller la mise à niveau vers le firmware du contrôleur ME5.1.2.1.0 ou une version ultérieure. Il contient des correctifs supplémentaires pour empêcher le contrôleur de gestion de redémarrer sous les explorations à partir d’applications de gestion externes qui utilisent des appels d’API SNMP ou REST.

Symptômes typiques :

  • L’interface utilisateur de PowerVault Manager est inaccessible.
  • Impossible d’ouvrir une session SSH sur l’une ou les deux interfaces de gestion.
  • Impossible de se connecter au port CLI de la session série
  • La baie ne répond pas ou a disparu des applications de gestion externes (SNMP ou API REST).

Lorsque les journaux d’événements sont examinés par la suite, reportez-vous aux étapes de résolution ci-dessous. Les administrateurs peuvent voir l’entrée suivante dans le journal de l’historique des événements, même si aucune mise à niveau du firmware n’est en cours.

...
B849       2023-08-08 01:08:16  152   WARNING        The Storage Controller is not receiving data from the Management Controller. (This is normal during firmware update.)
...

 

Cause

Une condition de mémoire insuffisante entraîne l’arrêt des processus de l’application de gestion. Les incidents peuvent être plus fréquents dans les environnements où des applications de gestion externes interrogent les interfaces de gestion à l’aide de SNMP ou d’une API REST.

Notes de mise à jour de ME5 :
FMW-65056 : résout une condition susceptible d’entraîner l’absence de réponse de l’interface de ligne de commande et de l’interface utilisateur.

Quels systèmes peuvent être concernés ?

Produit (et version) Les systèmes de stockage Dell PowerVault série ME5 suivants
  • PowerVault ME5012
  • PowerVault ME5024
  • PowerVault ME5084
Exécution de ce logiciel principal
(Système d'exploitation ou environnement d'exploitation)
Firmware du contrôleur PowerVault ME5 INFÉRIEUR À la version ME5.1.2.0.1

 

Resolution

  1. Si possible, essayez d’ouvrir une session SSH ou une connexion série USB sur chaque interface de gestion du contrôleur, puis redémarrez les services du contrôleur de gestion. Si cela réussit, mettez à niveau le firmware du contrôleur.
  2. Dans les cas où il n’est pas possible de se connecter à l’aide de SSH ou USB série, il est nécessaire de réinstaller physiquement l’un des modules de contrôleur concernés, et une fois le contrôle de gestion repris sur ce contrôleur, de redémarrer son contrôleur homologue. Sur une baie dotée d’un module de contrôleur unique ou de configurations avec des hôtes sans redondance de chemin, il est nécessaire d’organiser une fenêtre de maintenance, d’arrêter les hôtes, puis de mettre la baie hors tension.
  3. Une fois l’accès de gestion rétabli sur les deux modules de contrôleur, mettez à niveau le firmware du module de contrôleur vers la version ME5.1.2.1.0 ou une version ultérieure.

Procédure :

Étape 1 : Essayez de redémarrer les services de gestion sur les deux contrôleurs.

  • Cette étape peut ne pas être possible dans toutes les circonstances. Le redémarrage du contrôleur de gestion n’a pas d’impact sur la production.
  • Cette étape met fin à la session de gestion et l’accès de gestion est restauré après environ deux ou trois minutes lors du redémarrage des services.
  • Si les services de gestion peuvent être redémarrés avec succès sur les deux modules de contrôleur, passez à l’étape 3 : Mettez à niveau le firmware du module de contrôleur vers la version ME5.1.2.1.0 ou une version ultérieure.
  1. Ouvrez une session SSH sur l’interface de gestion de chaque contrôleur, puis connectez-vous en tant qu’utilisateur de niveau gestionnaire ou administrateur. Un administrateur peut également essayer d’établir une connexion série USB à chaque contrôleur. S’il n’est pas possible de se connecter à l’aide d’une connexion SSH ou série, passez à l’étape 2 : Réinstallez physiquement un module de contrôleur ou éteignez la baie.

  2. Si la connexion est établie, redémarrez le contrôleur de gestion sur chaque à l’aide de la commande suivante :

    restart mc full
    
    # restart mc full
    During the restart process you will briefly lose communication with the specified Management Controller(s).
    Do you want to continue? (y/n) y
    
    Info: Restarting the local MC (A)...
    Success: Command completed successfully. (2023-08-24 05:34:01)
    # Killed

Étape 2 : Réinstallez physiquement un module de contrôleur ou éteignez la baie.

ATTENTION : Le retrait des contrôleurs peut perturber l’accès de l’hôte aux données et, dans certaines circonstances, nécessite l’arrêt préalable des E/S de l’hôte afin d’éviter une panne inattendue ou une perte potentielle de données.

Scénario 1 : Double contrôleur avec configuration hôte
à chemin redondantCes étapes peuvent être implémentées sans fenêtre de maintenance.

Les conditions suivantes doivent être remplies :

  • Les hôtes doivent disposer d’un chemin de connexion vers les contrôleurs A et B
  • La prise en charge multipathing doit être configurée et activée sur les hôtes.
  • Tous les initiateurs hôtes doivent être mappés aux volumes.

Pour obtenir des conseils, reportez-vous à la section Retrait et remplacement des>modules des composants remplaçables par l’utilisateur dans le Manuel du propriétaire du système de stockage Dell PowerVault Série ME5.

  1. Tirez physiquement le module de contrôleur B vers l’avant dans son logement d’environ cinq centimètres ou environ deux pouces, puis réinstallez le module de contrôleur après 30 secondes.

  2. Attendez environ deux ou trois minutes que le contrôleur B termine le démarrage et le chargement du firmware.

  3. Ouvrez une session SSH sur l’adresse IP de gestion du contrôleur B et connectez-vous en tant qu’utilisateur de gestion ou de niveau administrateur.

  4. Redémarrez le contrôleur de stockage homologue A. Saisissez la commande :

    restart sc a
    
    # restart sc a  While a Storage Controller is restarting, communication will temporarily be lost with the corresponding Management Controller, and also may cause a temporary loss of data availability. Do you want to continue? (y/n) y Success: Command completed successfully. - The command to restart SC A completed successfully. The controller will restart in approximately 30 seconds. (2023-08-24 07:08:39)
  5. Lorsque le contrôleur homologue est en ligne, connectez-vous à PowerVault Manager et passez à l’étape 3 : Mettez à niveau le firmware du module de contrôleur vers la version ME5.1.2.1.0 ou une version ultérieure.

Scénario 2 : Module à un seul contrôleur ou configuration de chemin d’hôte non redondant
Une fenêtre de maintenance est requise. La suppression inattendue du chemin d’accès unique aux données signifie que l’hôte perd l’accès aux données et cesse de répondre !

Pour obtenir des conseils, reportez-vous à la section Retrait et remplacement des>modules des composants remplaçables par l’utilisateur dans le Manuel du propriétaire du système de stockage Dell PowerVault Série ME5.

  1. Informez les utilisateurs de la panne et suivez le guide de l’utilisateur du système d’exploitation hôte pour mettre l’hôte connecté en mode maintenance ou arrêter les hôtes.

  2. À l’arrière de la baie, éteignez les deux blocs d’alimentation pendant environ 60 secondes avant de les rallumer.

  3. Attendez environ trois minutes que les contrôleurs terminent le démarrage et le chargement du firmware.

  4. Connectez-vous à PowerVault Manager et passez à l’étape 3 : Mettez à niveau le firmware du module de contrôleur vers la version ME5.1.2.1.0 ou une version ultérieure.

Étape 3 : Mettez à niveau le firmware du module de contrôleur vers la version ME5.1.2.1.0 ou une version ultérieure.

Reportez-vous à la section Mise à jour du firmware du système dans le Guide de l’administrateur Dell PowerVault Série ME5.

  • Téléchargez la mise à jour du firmware du contrôleur. Dans un navigateur Web, ouvrez le site Web de support Dell.
  • Saisissez le numéro de série PowerVault ME ou sélectionnez le modèle PowerVault ME.
  • Sous Documentation, sélectionnez les Notes de mise à jour du système de stockage Dell PowerVault ME5.
  • Sous l’onglet Lecteurs et téléchargements , téléchargez le firmware du contrôleur de stockage Dell PowerVault série ME5
  • Extrayez le fichier binaire du firmware à partir du fichier .zip.
  • Utilisation de Dell PowerVault Manager. Accédez à Maintenance>Firmware>System et téléchargez le fichier binaire du firmware.
  • Accédez à Maintenance>Firmware>System et cliquez sur le lien Activate this Version pour afficher la boîte de dialogue.
  • Suivez les indications à l’écran pour commencer l’activation.

Comportement après la mise à niveau :

Avec le firmware du contrôleur ME5.1.2.0.1 ou version ultérieure, les administrateurs peuvent recevoir occasionnellement l’alerte d’information suivante.
Alerte d’information
Graphique 1 : Alerte d’information

The Management Controller entered a memory exhaustion state and will reboot to recover. Data access will not be interrupted.

Le contrôleur de gestion (MC) fournit l’interface utilisateur de gestion et l’interface CLI pour surveiller et configurer le système. Le redémarrage des services de gestion ne redémarre pas les contrôleurs et n’interrompt pas les E/S. Le redémarrage entraîne une impossibilité d’accéder à l’interface de gestion pendant deux minutes. Si vous recevez fréquemment cette alerte, une enquête plus approfondie peut être nécessaire pour établir la cause.

Remarque : Les administrateurs système doivent se méfier des conditions de défaillance des commutateurs Ethernet qui créent un déni de service, telles que les tempêtes de diffusion ou les boucles spanning tree sur les commutateurs réseau, les suites de tests de vulnérabilité de sécurité ou les scripts externes utilisant l’API REST qui s’exécutent en boucle constante en créant plusieurs sessions et en interrogeant la baie toutes les secondes, ce qui peut entraîner les mêmes symptômes que l’interface de gestion devient inaccessible.

 

Affected Products

ME Series, PowerVault ME5012, PowerVault ME5024, PowerVault ME5084
Article Properties
Article Number: 000215402
Article Type: Solution
Last Modified: 24 Oct 2024
Version:  16
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