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PowerStore: PowerStore Laufwerksfirmwareupgrades und häufig gestellte Fragen (FAQ)

Summary: Dell Technologies hat ein Laufwerksfirmwarepaket für die PowerStore-Produktreihe veröffentlicht. In diesem Artikel werden häufig gestellte Fragen im Zusammenhang mit dem Laufwerksfirmwarepaket und der Version beantwortet. ...

This article applies to   This article does not apply to 

Symptoms

KundInnen haben eventuell Fragen, nachdem sie die Support-Website besuchen und das PowerStore Laufwerksfirmwareupgrade heruntergeladen oder angesehen oder die Versionshinweise gelesen haben.

 

Cause

Es gibt offene Fragen, die in den Versionshinweisen nicht beantwortet werden.

 

Resolution

(Aktualisiert: 31. Mai 2024)

Ist das Upgrade der Laufwerksfirmware mit der neu veröffentlichten PowerStoreOS-Version 4.0.0.0 kompatibel?
Nein. Das aktuelle Laufwerksfirmwarepaket ist mit PowerStoreOS v3.2.1.x bis PowerStoreOS v3.6.x kompatibel.


Wird die Laufwerksfirmware auf einem PowerStoreOS v4.0.0.0-Cluster installiert?
Nein. Das aktuelle Laufwerksfirmwarepaket wird nicht auf einem PowerStore-Cluster mit PowerStoreOS v4.0.0.0 installiert.


Wird es ein neues Laufwerksfirmwarepaket für PowerStoreOS v4.x geben?
Ja, es befindet sich ein neues PowerStoreOS v4.x-Laufwerksfirmwarepaket in der Entwicklung und in Tests.


Wann veröffentlicht Dell Technologies ein neues Firmwarepaket für PowerStoreOS v4.x?
Ein Datum für das neue Laufwerksfirmwarepaket wurde noch nicht bekannt gegeben.


Warum sollte ich Laufwerksfirmware auf meinen Cluster anwenden?
Im Allgemeinen verbessert das Upgrade der Laufwerksfirmware die Sicherheit und Zuverlässigkeit der Laufwerke. Informationen zu Fixes nach Laufwerksteilenummer finden Sie in den Versionshinweisen des PowerStore-Laufwerksfirmwarepakets.


Welche Versionen von PowerStoreOS sind mit dem Laufwerksfirmwareupgrade kompatibel?

Tabelle 1: PowerStore-Laufwerksfirmwareupgrade – PowerStoreOS – Kompatibilität

  v1.x v2.x v3.0.x v3.2.0.x v3.2.1.x bis v3.6.x.x  v4.0.0.0
Kompatibel Nein Nein Nein Nein Ja Nein



Sollte das PowerStore-Laufwerksfirmwareupgrade vor oder nach einem PowerStoreOS-Firmwareupgrade ausgeführt werden?
Dell empfiehlt, das Laufwerksfirmwarepaket nach dem PowerStoreOS-Paket zu installieren.


Ist für das PowerStore-Laufwerksfirmwareupgrade ein Neustart erforderlich?
Für das Upgrade der Laufwerksfirmware ist kein Neustart des Node, der Appliance oder des Clusters erforderlich.


Wie finde ich das PowerStore-Laufwerksfirmwareupgradepaket?
Führen Sie die folgenden Schritte aus, um das Laufwerksfirmwarepaket herunterzuladen:

  • Navigieren Sie zu https://support.dell.com
  • Melden Sie sich bei Ihrem Geschäftskonto an.
  • Wählen Sie Support aus.
  • Wählen sie die Support-Startseite aus.
  • Geben Sie Ihr Service-Tag in die Produkterkennung ein und suchen Sie danach.
  • Navigieren Sie unter „Treiber und Downloads“ zu PowerStore Drive Firmware Package 3.2.1.0 (Veröffentlichungsdatum 20. Juli 2023) oder suchen Sie mit dem Schlüsselwort Firmware.
  • Direkter Link: PowerStore Drive Firmware Package 3.2.1.0 (Anmeldung erforderlich bei https://support.dell.com)



Wie finde ich die Versionshinweise zum PowerStore-Laufwerksfirmwareupgrade?
Führen Sie die folgenden Schritte aus, um die Versionshinweise herunterzuladen: ​​​​​

  • Navigieren Sie zu https://support.dell.com
  • Melden Sie sich bei Ihrem Geschäftskonto an.
  • Wählen Sie Support aus.
  • Wählen sie die Support-Startseite aus.
  • Geben Sie Ihr Service-Tag in die Produkterkennung ein und suchen Sie danach.
  • Rufen Sie in der Dokumentation den Punkt Handbücher und Dokumente auf und suchen Sie nach den Versionshinweisen zu Dell PowerStore Drive Firmware Package 3.2.1.0.
  • Direkter Link: Versionshinweise zu Dell PowerStore Drive Firmware Package 3.2.1.0 (Anmeldung erforderlich bei https://support.dell.com)



Sollte ich die Funktion „Supportbenachrichtigungen deaktivieren“ (Wartungsfenster) während des Upgrades der Festplattenfirmware verwenden?  
Ja, Dell empfiehlt, die Funktion „Wartungsfenster“ während des Laufwerkupgrades zu aktivieren. Ein Wartungsfenster kann verhindern, dass eine unnötige Warnmeldung an den technischen Support von Dell gesendet wird. Dell empfiehlt, einen Zeitraum zu wählen, der länger ist als der erwartete Zeitraum für das Upgrade der Laufwerksfirmware. 

Standardmäßig aktiviert das PowerStore-Laufwerksfirmwareupgrade automatisch ein Wartungszeitfenster von 8 Stunden. Das standardmäßige Wartungsfenster wird intern festgelegt und wird in der PowerStore-Benutzeroberfläche (UI) nicht angezeigt. Informationen dazu, wie lange das Upgrade der Laufwerksfirmware dauern kann, finden Sie unten.

Wenn Fehler über das Upgrade hinaus bestehen bleiben (siehe unten), wenden Sie sich an den Support. 


Wie richte ich ein Wartungszeitfenster von mehr als 8 Stunden ein?
Wenn NutzerInnen der Ansicht sind, dass das Upgrade der Laufwerksfirmware länger als 8 Stunden dauert, kann über die Benutzeroberfläche ein Wartungsfenster festgelegt werden.

Gehen Sie in der PowerStore-Benutzeroberfläche wie folgt vor:
  • Navigieren Sie zu Einstellungen
  • Wählen Sie unter Support die Option Supportbenachrichtigungen deaktivieren aus.
  • Aktivieren Sie das Kontrollkästchen neben allen Appliances.
  • Wählen Sie MODIFY aus.
  • Aktivieren Sie Enable Maintenance Mode und wählen Sie ein Wartungszeitfenster aus, das länger als die erwartete Aktualisierungszeit ist.
Wenn das Update abgeschlossen ist, sollten NutzerInnen den Wartungsmodus manuell beenden. 
HINWEIS: Dies ist nur erforderlich, wenn NutzerInnen der Meinung sind, dass die Aktualisierung länger als 8 Stunden dauert.



Wie lange dauert das Upgrade der PowerStore-Laufwerksfirmware?
Upgrades der Laufwerksfirmware dauern unterschiedlich lange. Die Upgradezeiten hängen von der I/O-Aktivität, den Typen der Laufwerke, der Anzahl der Laufwerke und dem Layout des RAID-Ausfallsicherheitssatzes ab. Die Laufwerke müssen seriell aktualisiert werden, um eine hohe Verfügbarkeit aufrechtzuerhalten.

Internen Tests zufolge dauerten die Upgrades der Laufwerksfirmware bei einem minimal konfigurierten PowerStore im Leerlauf nur 30 Minuten. Eine vollständig bestückte einzelne PowerStore-Appliance ohne externe Gehäuse, die mit hoher I/O-Aktivität ausgeführt wird, kann bis zu 6 bis 10 Stunden dauern.
 

HINWEIS: Die ersten 4 Minuten des Upgrades der Laufwerksfirmware sind Teil des Overheads für das Entpacken des Pakets und die Vorverarbeitung. Bei der Schätzung der Zeit, die das Upgrade in Anspruch nimmt, sollten diese ersten 4 Minuten nicht Teil der Berechnung sein.



Gibt der Name des Laufwerksfirmwarepakets mit der Build-Nummer die Reihenfolge der Installation bei der Aktualisierung der PowerStoreOS- und der PowerStore-Laufwerksfirmware an?
Nein, die Versionsnomenklatur gibt an, wann die Software erstellt wurde, nicht die Installationsreihenfolge der Dateien. Informationen zur spezifischen Kompatibilität finden Sie in den Versionshinweisen.


Gibt es Versionshinweise für das PowerStore-Laufwerksfirmwareupgrade?
Ja, die neueste Version der Versionshinweise finden Sie auf Ihrer Produktsupportseite.


Das Upgrade der Laufwerksfirmware wurde ausgeführt und dauerte weniger als fünf Minuten. Es wird angegeben, dass das Upgrade der Laufwerksfirmware erfolgreich ausgeführt wurde. Muss ich mir Sorgen machen?
Die Laufwerksfirmware aktualisiert (wie vorgesehen) keine Laufwerke auf PowerStoreOS v.3.0.x und 3.2.0.x. Das Upgrade-Dienstprogramm bereitet ein Upgrade der Laufwerksfirmware vor, überprüft dann die PowerStoreOS-Version und wird beendet. 

Der Prozess des Entpackens und Ausführens der Software war erfolgreich, aber es wurde kein Firmwareupgrade durchgeführt. Sie müssen ein Upgrade von PowerStoreOS auf eine Version durchführen, die das Upgrade unterstützt, und es erneut versuchen. 

Weitere Informationen finden Sie in den Versionshinweisen.


Warum dauert das Upgrade der Laufwerksfirmware lange?
Viele Faktoren beeinflussen die Zeit, die für das Upgrade der Firmware eines Laufwerks erforderlich ist. Zu diesen Faktoren gehören unter anderem: Die Anzahl der Laufwerke im RAID-Ausfallsicherheitssatz, einfache oder doppelte Parität, die Priorität des erneuten Aufbaus, die Laufwerksleistung und insbesondere die I/O-Aktivität während des Upgrades der Laufwerksfirmware. Hohe I/O-Auslastung während eines Onlineupgrades der Laufwerksfirmware kann die normale Aktivität des schnellen Wiederherstellungsprozesses verlangsamen.   


Ich habe das Upgrade der Laufwerksfirmware bereits ausgeführt. Ein Laufwerk wird in der PowerStore-Appliance ersetzt. Muss ich das Upgrade der Laufwerksfirmware erneut ausführen?
Auf Ersatzlaufwerken, die von Ersatzteillagern geliefert werden, wird möglicherweise nicht die neueste Version der Laufwerksfirmware ausgeführt. Es wird empfohlen, das Upgrade der Laufwerksfirmware nach dem Austausch von Laufwerken im System erneut auszuführen. Dadurch wird sichergestellt, dass die neueste Version des Laufwerksfirmwarecodes auf das Ersatzlaufwerk geladen wird.


Wo kann ich in der PowerStore-Benutzeroberfläche (UI) die Laufwerksfirmwareversion überprüfen?
In der PowerStore-Benutzeroberfläche befinden sich Laufwerke unter Hardware > Appliance > Components Drives>.

Abbildung 1: Beispiel für eine Überprüfung der Laufwerksfirmware in der PowerStore-Benutzeroberfläche
Überprüfen der Laufwerksfirmware in der PowerStore-Benutzeroberfläche


Ich habe während des Upgrades der PowerStore-Laufwerksfirmware Warnmeldungen erhalten. Sollte ich mir Sorgen machen?
Die folgenden Warnmeldungen werden in der PowerStore-Benutzeroberfläche während des Upgrades der Laufwerksfirmware angezeigt. Dies gilt als normal (es sei denn, sie bleiben mehr als 5 Minuten nach Abschluss des Upgrades der PowerStore-Laufwerksfirmware bestehen).

 

  • 0x00201201 – Severity Critical – Der Schreibcache ist heruntergestuft. Ein NVRAM-Gerät wurde entfernt oder ist offline.
  • 0x00307203 - Severity: Major – Firmwareversion des Laufwerks in Bus x-Gehäuse x ist nicht kompatibel
  • 0x00307204 - Severity: Minor – Firmware-Version des Laufwerks in Bus x Gehäuse x Steckplatz xx ist veraltet.
  • 0x00307104 - Severity: Major – Laufwerk in Bus x Gehäuse x Steckplatz xx wurde entfernt.
  • 0x00307108 - Severity: Minor – Laufwerk in Bus x Gehäuse x Steckplatz xx muss nach dem Upgrade der Laufwerksfirmware zurückgesetzt werden.
 
Abbildung 2: Beispiel für einen vorübergehenden Satz von Warnmeldungen, die während des Upgrades der Laufwerksfirmware erwartet werden
Beispiel für einen vorübergehenden Satz von Warnmeldungen, die während des Upgrades der Laufwerksfirmware erwartet werden


Führt die Laufwerksfirmware ein Upgrade für alle passenden Laufwerke im PowerStore-Cluster durch?
Das Upgrade-Kit aktualisiert alle passenden Laufwerke. Weitere Informationen zu den spezifischen Modellen und Versionen von Laufwerken finden Sie in den Versionshinweisen. 

In seltenen Fällen muss das Upgrade der Laufwerksfirmware mehrmals durchgeführt werden, um sicherzustellen, dass alle Laufwerke die erforderlichen Upgrades erhalten. Wenn das Upgrade der Laufwerksfirmware nach 8 Stunden fehlschlägt, finden Sie weitere Informationen unter KB 000216935 – PowerStore: Upgrade der Laufwerksfirmware auf die Paketversion: 3.2.1.0-198710-retail schlägt nach 8 Stunden fehl.

 
Auf welche Version der Laufwerksfirmware werden die Laufwerke aktualisiert?
Weitere Informationen finden Sie in den Versionshinweisen zu den jeweiligen Laufwerksfirmwareversionen.


Was bewirkt dieses Upgrade der Laufwerksfirmware?
Dies hängt von der Marke und dem Modell des Laufwerks ab. Einzelheiten finden Sie in den Versionshinweisen.


Wird diese Laufwerksfirmware mein Laufwerk auf die FIPS-Compliance (Federal Information Processing Standard) aktualisieren?
Dies hängt von der Marke und dem Modell des Laufwerks ab. Einige Laufwerke erhalten FIPS-Sicherheitsmaßnahmen als Teil dieses Upgrades der Laufwerksfirmware. Einzelheiten finden Sie in den Versionshinweisen.

PowerStoreOS bereitet sich ca. 4 Minuten lang auf das Laufwerkupgrade vor und beginnt dann mit dem Upgrade der Laufwerke. Möglicherweise können Sie die Zeit abschätzen, sobald NutzerInnen sehen, wie lange ein Upgrade eines einzelnen Laufwerks in Ihrer Umgebung dauert. Multiplizieren Sie die sich aus der Upgradezeit eines einzelnen Laufwerks ergebende Zeit mit der Anzahl der Laufwerke in Ihrer PowerStore-Konfiguration.


Sollte ich das ältere Laufwerksupgradepaket „PowerStore-disk_firmware-2?1.0.0-1519794“ anwenden?
Nein, das ältere Laufwerksfirmwarepaket „PowerStore-disk_firmware-2.1.0.0-1519794“  sollte nicht auf das PowerStore-System angewendet werden. Es wurde von der Website entfernt. 
 
 
 
 

Affected Products

PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000T

Products

PowerStore 9000X
Article Properties
Article Number: 000214519
Article Type: Solution
Last Modified: 01 Aug 2024
Version:  14
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