Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NetWorker:NMC UI“无法启动应用程序”,未签名的应用程序请求不受限制地访问系统

Summary: 启动 NetWorker Management Console (NMC) 时,UI 无法启动,并显示“无法启动应用程序”错误。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 启动 NetWorker Management Console (NMC) 时,用户界面无法启动,并显示“无法启动应用程序”。
无法启动应用程序消息
  • Details选项卡报告以下错误:
错误:请求不受限制地访问系统的
未签名应用程序 未签名资源 https://< NMC 服务器>:9000/LGTOnmc/java/comtsk.jar
  Java - 更多信息

Cause

从 Java 8 Update 131 发行版开始,使用 MD5withRSA 或 MD5withDSA 算法签名的应用程序被视为未签名。

Resolution

1.编辑 NRE 安装安全路径下的 java.security 文件。
对于 NRE,文件的完整路径为 C:\Program Files\NRE\java\<jre version>\lib\security\java.security。

2.注释掉以“jdk.jar”开头的行,如下例所示 -
 
# jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
#     DSA keySize < 1024, include jdk.disabled.namedCurves
3.保存更改。
4.启动 NMC UI。

Affected Products

NetWorker, NetWorker Management Console

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000210820
Article Type: Solution
Last Modified: 28 May 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.