Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NetWorker:NMC UI 「無法啟動應用程式」,未簽署的應用程式要求不受限制的系統存取

Summary: 啟動 NetWorker Management Console (NMC) 時,UI 無法啟動,並顯示「無法啟動應用程式」錯誤。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 啟動 NetWorker Management Console (NMC) 時,使用者介面無法啟動,並顯示「無法啟動應用程式」。
無法啟動應用程式訊息
  • “詳細資訊”選項卡報告以下錯誤:
Error: 要求不受限制存取系統的
未簽署應用程式 https://< NMC 伺服器>的未簽署資源:9000/LGTOnmc/java/comtsk.jar
  Java - 更多資訊

Cause

從 Java 8 Update 131 版本開始,使用 MD5withRSA 或 MD5withDSA 演算法簽署的應用程式會被視為未簽署。

Resolution

1.編輯 NRE 安裝安全性路徑下的 java.security 檔案。
若為 NRE,檔案的完整路徑為 C:\Program Files\NRE\java\<jre version>\lib\security\java.security。

2.註釋掉以「jdk.jar」開頭的行,如下例所示-
 
# jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
#     DSA keySize < 1024, include jdk.disabled.namedCurves
3.儲存變更。
4.啟動 NMC UI。

Affected Products

NetWorker, NetWorker Management Console

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000210820
Article Type: Solution
Last Modified: 28 May 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.