Skip to main content
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

PowerFlex Issue when upgrading CloudLink with PowerFlex Manager

Summary: Issues can occur when upgrading CloudLink with PowerFlex Manager 3.8 that will cause the service upgrade to fail.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Service being upgraded will fail on an SDS node upgrade. The SDS node has CloudLink agent upgraded, but will still be in maintenance mode. 

Cause

CloudLink 7.0, 7.02, 7.1.0, 7.1.1 does not add a required sleep timer in /opt/emc/extra/pre_run.sh.  If it is added manually, PowerFlex Manager 3.8 removes the sleep timer when doing a service upgrade on SDS nodes.   Without the sleep timer, the PowerFlex service starts before CloudLink has unlocked the drives.  This causes some or all the drives to be in an error state. 

Resolution

This is fixed in PowerFlex Manager 3.8.3.   

There is a PowerFlex Manager 3.8.2 patch to ensure that the sleep timer is present. 

For PowerFlex Manager 3.8.0 and 3.8.1, use the following method to perform service upgrades that have CloudLink encryption.

 

Upgrade CloudLink resource with RCM to the wanted release. 

 1. Log in to PowerFlex Manager.

2. Go to the Resources tab and select All Resources, and then select a CloudLink Center to upgrade. You must only upgrade a single node of a CloudLink Center cluster. The remaining nodes are upgraded automatically.

3. Click Update Resources.

4. Choose Allow PowerFlex Manager to perform firmware and software updates now or Schedule firmware and software updates.

5. Click Apply and click Yes to confirm.

Auto upgrade all the agents.  

Log in to CloudLink Center

The SDS nodes will each have an alarm indicating that the CloudLink agent has not been upgraded yet.

Set the Machine Agent Upgrade policy to Auto for the machine group that contains the SDS nodes that are being upgraded (This will trigger an upgrade of the CloudLink agent on all SDS nodes): 

Agents > Machine Groups > Action > Modify Group > Machine Agent Upgrade.

Wait several minutes for CloudLink to upgrade all the CloudLink agents on the SDS nodes to the new version. Ensure CloudLink agent alarms on the SDS nodes have cleared.

Update the /opt/emc/extra/pre_run.sh.

On each SDS node that was upgraded, check the /opt/emc/extra/pre_run.sh.

If it does not exist using 'vi' , create  the file with all the commands shown below.

If it does exist, using 'vi', add the "sleep 60" timer as shown below.

/opt/emc/extra/pre_run.sh:

#!/bin/bash -f

if [ -f /sbin/svm ]; then
  echo svm is installed $(date) >> /var/log/svm-sds
  /sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid &
  end=$((SECONDS+300))
  sleep 60
  while [ $SECONDS -lt $end ]; do
    /sbin/svm unlocked > /dev/null && break
    sleep 5
  done
fi

  4. Change the permissions on the pre_run.sh file "chmod 755 /opt/emc/extra/pre_run.sh"  

 Reboot nodes and clear errors (optional):

  • Put an SDS node in protected maintenance mode.
  • Record drive letters in use (for example, sda-sdk or sdb - sdl)
  • Reboot node.
  • Once reboot is complete, ensure that there are no PowerFlex errors in the PowerFlex UI.   If there are, then clear the errors.
  • Check /opt/emc/extra/pre_run.sh still contains the "sleep 60"  timer. If not, add the "sleep 60" timer and repeat from step 3.   
  • Check the drive letter order.  If the drives have reordered, then reset the drives using scli commands:
scli --query_all_sds
scli --query_sds -sds_id   
scli --update_sds_original_paths -sds_id  

7. If there were PowerFlex errors on the first reboot, the repeat steps 3-6.

8. Take the node out of protected maintenance mode.

9. Repeat steps 1-8 for all the other SDS nodes to confirm that pre_run.sh is set up correctly.   

  Start service upgrade

  • 1.  Inventory all nodes in PFxM and confirm that CloudLink is compliant with the new RCM on all SDS nodes.
  • 2. Perform the RCM upgrade on the service.

 

 For PowerFlex Manager 3.8.2, apply the attached patch prior to service upgrades that have CloudLink encryption:

Prior to starting the RCM upgrade, apply the PowerFlex Manager 3.8.2 patch:  

Take a snapshot of the PowerFlex Manager appliance.  (remove the snapshot when completed.)

Download the .zip file attached to this KB and unzip.   

Copy the Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm file to the /var/tmp directory on the PowerFlex Manager appliance.

ssh to PowerFlex Manager appliance.

Ensure that no jobs are running on PFxM.

Run the following commands on the PowerFlex Manager appliance to apply the patch:

cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm
sudo shutdown -r now 

The RCM upgrade can now be performed and there should not be any SDS errors on the encrypted drives when the nodes are rebooted.   

Affected Products

PowerFlex rack

Products

PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625, PowerFlex custom node , PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex custom node R860, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000202412
Article Type: Solution
Last Modified: 24 Dec 2024
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.