Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Problème lors de la mise à niveau de CloudLink avec PowerFlex Manager

Summary: Des problèmes peuvent se produire lors de la mise à niveau de CloudLink avec PowerFlex Manager 3.8, ce qui entraîne l’échec de la mise à niveau du service.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le service en cours de mise à niveau échoue lors d’une mise à niveau du nœud SDS.   L’agent CloudLink est mis à niveau sur le nœud SDS, mais reste en mode maintenance. 

Cause

CloudLink 7.0, 7.02, 7.1.0, 7.1.1 n’ajoute pas de minuteur de veille requis dans /opt/emc/extra/pre_run.sh.  S’il est ajouté manuellement, PowerFlex Manager 3.8 supprime le minuteur de veille lors de la mise à niveau du service sur les nœuds SDS.   Sans le minuteur de veille, le service PowerFlex démarre avant que CloudLink n’ait déverrouillé les disques.  Cela entraîne l’état d’erreur de certains ou de tous les disques. 

Resolution

Ce problème sera corrigé dans PowerFlex Manager 3.8.3.   Il existe un correctif PowerFlex Manager 3.8.2 pour s’assurer que le minuteur de veille est présent. 

Pour PowerFlex Manager 3.8.0 et 3.8.1, utilisez la méthode suivante pour effectuer des mises à niveau de service avec chiffrement CloudLink.

Mettez à niveau la ressource CloudLink avec RCM vers la version souhaitée. 
1. Connectez-vous à PowerFlex Manager.
2. Accédez à l’onglet Ressources , sélectionnez Toutes les ressources, puis sélectionnez un CloudLink Center à mettre à niveau. Vous n’avez besoin de mettre à niveau qu’un seul nœud d’un cluster CloudLink Center. Les nœuds restants sont mis à niveau automatiquement.
3. Cliquez sur Mettre à jour les ressources.
4. Choisissez Allow PowerFlex Manager to perform firmware and software updates now ou Schedule firmware and software updates.
5. Cliquez sur Appliquer , puis sur Oui pour confirmer.

Mettez à niveau automatiquement tous les agents.  
  1. Connectez-vous à CloudLink Center.
  2. Les nœuds SDS auront chacun une alarme indiquant que l’agent CloudLink n’a pas encore été mis à niveau.
  3. Définissez la règle Machine Agent Upgrade sur Auto pour le groupe de machines qui contient les nœuds SDS en cours de mise à niveau (cela déclenchera une mise à niveau de l’agent CloudLink sur tous les nœuds SDS): 
    • Agents > groupes de machines > action > Modifier le groupe > mise à niveau de l’agent machine
  4.  Patientez plusieurs minutes pour que CloudLink effectue la mise à niveau de tous les agents CloudLink sur les nœuds SDS vers la nouvelle version.  Assurez-vous que les alarmes de l’agent CloudLink sur les nœuds SDS ont été effacées.

Mettez à jour le fichier /opt/emc/extra/pre_run.sh
  1. Sur chaque nœud SDS qui a été mis à niveau, vérifiez le fichier /opt/emc/extra/pre_run.sh
  2. S’il n’existe pas à l’aide de « vi », créez le fichier avec toutes les commandes indiquées ci-dessous.
  3. S’il existe déjà, à l’aide de « vi », ajoutez le minuteur « sleep 60 » comme indiqué ci-dessous.
/opt/emc/extra/pre_run.sh:
#!/bin/bash -f

si [ -f /sbin/svm ];
echo svm est installé $(date) >> /var/log/svm-sds
/sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid &
end=$(SECONDES + 300))
veille 60
tandis que [ $SECONDS -lt $end ]; ne
/sbin/svm déverrouillé > /dev/null &> break
veille 5
Fait

Fi
 
4. Modifiez les autorisations du fichier pre_run.sh « chmod 755 /opt/emc/extra/pre_run.sh »
 
Redémarrez les nœuds et effacez les erreurs (facultatif):
1. Placez un nœud SDS en mode de maintenance protégé.
2. Lettres de lecteur d’enregistrement en cours d’utilisation (par exemple,  sda-sdk ou sdb – sdl)
3. Redémarrez le nœud.
4.  Une fois le redémarrage terminé, assurez-vous qu’il n’y a pas d’erreurs PowerFlex dans l’interface graphique PowerFlex.   Si c’est le cas, effacez les erreurs.
5.  Vérifiez que /opt/emc/extra/pre_run.sh contient toujours le minuteur de veille 60. Si ce n’est pas le cas, ajoutez le minuteur de veille 60 et répétez l’étape 3.   
6.  Vérifiez l’ordre des lettres de lecteur.  Si les disques ont été réorganisés, réinitialisez les disques à l’aide des commandes scli:
scli- query_all_sds
scli --query_sds -sds_id
scli --update_sds_original_paths -sds_id

7. En cas d’erreurs PowerFlex lors du premier redémarrage, répétez les étapes 3 à 6.
8. Retirer le nœud du mode
de maintenance protégé9. Répétez les étapes 1 à 8 pour tous les autres nœuds SDS pour confirmer que pre_run.sh est configuré correctement.   
 
 
Démarrer la mise à niveau du service
1.  Inventoriez tous les nœuds dans PFxM et confirmez que CLoudLink est conforme à la nouvelle RCM sur tous les nœuds SDS.
2. Effectuez la mise à niveau RCM sur le service.

 
Pour PowerFlex Manager 3.8.2, appliquez le correctif joint avant les mises à niveau de service avec chiffrement CloudLink:

Avant de commencer la mise à niveau de RCM, appliquez le correctif PowerFlex Manager 3.8.2:  
  1. Prenez un snapshot de l’appliance PowerFlex Manager.  (supprimez le snapshot une fois l’opération terminée).
  2. Téléchargez le fichier zip joint à cet article de la base de connaissances et décompressez-le.   
  3. Copiez le fichier Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm dans le répertoire /var/tmp de l’appliance PowerFlex Manager.
  4. connectez-vous en ssh à l’appliance PowerFlex Manager.
  5. Assurez-vous qu’aucune tâche n’est en cours d’exécution sur PFxM.
  6. Exécutez les commandes suivantes sur l’appliance PowerFlex Manager pour appliquer le correctif:
    • cd /var/tmp
    • sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm
    • sudo shutdown -r now 
 
La mise à niveau RCM peut désormais être effectuée et il ne doit pas y avoir d’erreurs SDS sur les disques chiffrés lors du redémarrage des nœuds.   

Affected Products

PowerFlex rack, PowerFlex Appliance
Article Properties
Article Number: 000202412
Article Type: Solution
Last Modified: 08 Feb 2023
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.