Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

使用 PowerFlex Manager 升級 CloudLink 時發生問題

Summary: 使用 PowerFlex Manager 3.8 升級 CloudLink 時,可能會發生問題,導致服務升級失敗。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

軟體定義儲存 (SDS) 節點升級的服務將會失敗。   SDS 節點將升級 CloudLink 代理程式,但仍處於維護模式。 

Cause

CloudLink 7.0、7.02、7.1.0、7.1.1 並未在 /opt/emc/extra/pre_run.sh 中新增所需的睡眠計時器。  如果是手動新增,PowerFlex Manager 3.8 會在 SDS 節點上進行服務升級時移除睡眠計時器。   如果沒有睡眠計時器,PowerFlex 服務會在 CloudLink 解鎖磁片磁碟機之前啟動。  這會導致部分或所有磁片磁碟機處於錯誤狀態。 

Resolution

此問題將在 PowerFlex Manager 3.8.3 中修正。   有 PowerFlex Manager 3.8.2 修補程式,可確保有睡眠計時器。

若為 PowerFlex Manager 3.8.0 和 3.8.1,請使用下列方法執行具有 CloudLink 加密的服務升級。

使用 RCM 將 CloudLink 資源升級至所需的版本。 
1.登入 PowerFlex Manager。
2.移至「Resources」卷標,然後選取「All Resources」,然後選取 CloudLink Center 進行升級。您只需要升級 CloudLink Center 叢集的單一節點。其餘節點會自動升級。
3.按一下[Update Resources] (更新資源)
4.選擇Allow PowerFlex Manager 以立即執行韌體和軟體更新,或排程韌體和軟體更新
5.按一下「Apply,然後按一下「Yes」以確認。

自動升級所有代理程式。  
  1. 登入 CloudLink Center。
  2. SDS 節點會分別出現警報,表示 CloudLink 代理程式尚未升級。
  3. 針對包含要升級的 SDS 節點的機器群組,將 Machine Agent 升級原則設定為 Auto (這會觸發所有 SDS 節點上的 CloudLink 代理程式升級): 
    • 代理程式>機器群組>動作>修改群組>機器代理程式升級
  4.  等待幾分鐘,CloudLink 將 SDS 節點上的所有 CloudLink 代理程式升級至新版本。  確定已清除 SDS 節點上的 CloudLink 代理程式警報。

更新 /opt/emc/extra/pre_run.sh
  1. 在每個已升級的 SDS 節點上,檢查 /opt/emc/extra/pre_run.sh
  2. 如果不存在,請使用「vi」建立檔案,並使用下方顯示的所有命令。
  3. 如果確實存在,請使用「vi」新增「睡眠 60」計時器,如下所示。
/opt/emc/extra/pre_run.sh:
#!/bin/bash -f

如果 [-f /sbin/svm],則
echo svm 已安裝 $(date) >> /var/log/svm-sds
/sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid &
end=$((SECONDS+300))
睡眠 60
而 [$SECONDS -lt $end];
/sbin/svm 解除鎖定> /dev/null &break
睡眠 5

fi
 
4.變更 pre_run.sh 檔案「chmod 755 /opt/emc/extra/pre_run.sh」上的許可權
 
重新開機節點和清除錯誤 (選用):
1.讓 SDS 節點處於受保護的維護模式。
2.記錄使用中的磁片磁碟機字母 (例如: sda-sdk 或 sdb – sdl)
3.重新開機節點。
4. 重新開機完成後,請確定 PowerFlex GUI 中沒有 PowerFlex 錯誤。   如果有,請清除錯誤。
5. 檢查 /opt/emc/extra/pre_run.sh 仍包含「睡眠 60」計時器。如果沒有,請新增「睡眠 60」計時器,然後重複步驟 3。   
6.  檢查磁片磁碟機號順序。  如果磁片磁碟機已重新排序,請透過 scli 命令重設磁片磁碟機:
scli --query_all_sds
scli --query_sds -sds_id
scli --update_sds_original_paths -sds_id

7.如果第一次重新開機時發生 PowerFlex 錯誤,則重複步驟 3-6。
8.將節點帶出受保護的維護模式
9.對所有其他 SDS 節點重複步驟 1-8,以確認已正確設定 pre_run.sh。   
 
 
開始服務升級
1.  清查 PFxM 中的所有節點,並確認 CLoudLink 與所有 SDS 節點上的新 RCM 相容。
2.在服務上執行 RCM 升級。

 
若為 PowerFlex Manager 3.8.2,請先套用附加的修補程式,再進行具有 CloudLink 加密的服務升級:

開始 RCM 升級之前,請套用 PowerFlex Manager 3.8.2 修補程式:  
  1. 取得 PowerFlex Manager 裝置的快照。  (完成後移除快照)。
  2. 下載連接至此 KB 的 zip 檔案並解壓縮。   
  3. 將 Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm 檔案複製到 PowerFlex Manager 應用裝置上的 /var/tmp 目錄。
  4. ssh 至 PowerFlex Manager 裝置。
  5. 確定 PFxM 上沒有任何工作正在執行。
  6. 在 PowerFlex Manager 裝置上執行下列命令以套用修補程式:
    • cd /var/tmp
    • sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm
    • sudo shutdown -r now 
 
現在可以執行 RCM 升級,當節點重新開機時,加密磁片磁碟機上不應有任何 SDS 錯誤。   

Affected Products

PowerFlex rack, PowerFlex Appliance
Article Properties
Article Number: 000202412
Article Type: Solution
Last Modified: 08 Feb 2023
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.